What's new

Help with some routing/filtering configuration for CUPS printers in Debian linux

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Senior Member
I have an RT-AX88U as the main router connected to the internet, it has 2 printers (Brother Laser and Epson color) both connected via Ethernet cable directly to the AX88U. I have a Linux laptop running Debian 12, when I connect the Linux laptop directly via wifi to the AX88U the two printers will be auto discovered by Linux using via CUPS driverless, everything works fine. The network here is /

As part of a Home lab I am building, I have connected an RT-AX86U (WAN port) via ethernet cable to the RT-AX88U (Ethernet port), in Router mode (part of the lab objective), The network here is / Because of the Routing and the laptop and the printers being now on separate networks, I am having some issues with the Auto Discovery of the printers, I am outside the Broadcast area, printers are broadcasting some protocol, I don't know which one, in the 50 network, therefore they are not seen in the 100 network.

Is there a configuration (that doesn't mean setting up the AX86U as a Bridge, the purpose of the lab is to have to networks) that I can setup in the AX86U that will allow me the printers to be auto discover on the local network of the AX86? I know I can connect the laptop to the AX88U wifi network when printing, but that's not the purpose of the lab.

Thank you

NOTE: AX88U running Asus FW, AX86U running Merlin FW
You could try to run a /jffs/scripts/avahi-daemon.postconf to include:
pc_append " " "$CONFIG"
pc_append "[reflector]" "$CONFIG"
pc_append "enable-reflector=yes" "$CONFIG"

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!