What's new

Need help with OpenVPN server configured in non-routing mode

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Senior Member
I had posted about this before and had a brief answer from @RMerlin which I used to configure my RT-N66W as an OpenVPN server in "stand-alone" mode.
By this I mean I am not using this device as a conventional router or WiFi AP. I simply want it to sit on the network behind another router an accept VPN connections.

This is the setup I used:

I had tested this on my own network placing the N66W behind another Asus Merlin router in a conventional configuration and forwarding port 1198 to the N66W which was just configured with a local IP on the WAN port.
The full setup (which was minimal) is listed in my above post and I was able to connect and ping both local devices and route out to the Internet.

I have now brought the N66W to the location that I need to configure this in for good. Since it had been a couple of months since I set this up before I didn't recall the password and IP I used, so I reset the router to default and configured this again.

Currently I have the N66W's WAN port configured with a local LAN IP and plugged directly into a LAN port on my ISP router. The appropriate port is forwarded to the N66W for OpenVPN.

I am able to establish the VPN connection into the N66W and ping the N66W. However I am unable to ping anything else on the local network or access the internet through this connection.
I am ofc, able to ping anything I want from the router itself.

I am using IP addresses to test, so rule out any DNS issues to start. My OVPN connection settings are below.

I'm 99% confident that the configuration is the same I had previously which seemed to work, but as the environment is different, something else is likely going on.

Please be aware this is on FW 380.70 as it is the last supported FW for this device.

I would really appreciate assistance as I need to make this work here. Please let me know what else I can provide to help troubleshoot.


Apparently I had disabled NAT under the WAN settings in my efforts to disable all "unnecessary" services for this configuration.
I guess I had mistakenly assumed that since I was not using this device as a traditional router, that NAT would not be necessary to translate any external addresses.
But, apparently the rules created with NAT enabled are required to properly translate from the the OVPN server to the other subnets.

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!