how come can web browse, but I can't ping when I hardwire a LAN cable to my Asus (but I can via WIFI)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

abc5

Occasional Visitor
I've got an Asus ac68U. have all my devices via WIFI, can't recall the last time I had to PING something on my network while the Pc I am doing the command from is hardwired.

Today I decided to do that and I get general failures. Tested ALL 4 ports of the Asus.

Can web browse from all of the ports, but none can do a PING. Cannot ping the RaspberryPi I have on the network (running Pihole) cannot ping google.com


Once I connect the same pc back onto WIFI, I can ping my gateway, the RaspberryPi, and google.


since my WIFI becomes spotty within one of the rooms I started using as a office, I wanted to start using the hardwire lan cable that runs to that room to my Asus.

Just that I feel latency too when using the wired method so I wanted to get some PINGs going, but I can't due to what I described.


The Asus is running Merlin. Was wondering a bit where to post this question.
 

eibgrad

Very Senior Member
Did you try a different ethernet cable? Is the ethernet network adapter enabled in Windows? Is it configured for DHCP?
 

abc5

Occasional Visitor
the cable run from the router, into the walls of my house, into the room i have a computer (laptop) to which I discovered this inabilty to PING, I tried another computer, same issue. Then tonight I took the laptop put it side by side w/ the Asus router, and connected both via a simple 6 foot patch cable. Still same problem.

so I've tried 4 LAN ports on the asus, tried 2 computers, tried 2 LAN cables.

again, can webbrowse, can't ping though. I wanted to test ping latency. Can't ping my Raspberry, can't ping external sites, can't ping my 192.168. gateway.

Can browse websites, yes the ethernet adapter is enabled in windows. Just can't ping. yes it's configured for DHCP, both computers are.
 

abc5

Occasional Visitor
the asus has a network tool whereby you could enter an ip and tell the router to ping it. any pc hardwired to the asus, the asus cant ping it but the asus can ping the raspberry pi i have on the network. the asus can also ping any pc i have connected to the asus via wifi.

again the hardwired pcs get an ip and i can webbrowse.
 

Ronald Schwerer

Very Senior Member
You should be able to ping either way. Assuming the PC/laptop has both Wired and Wireless adapters, did you disable Wifi when testing the ethernet?
Do you have any filters or routing rules on your router? Keep in mind that your ethernet adapter MAC is likely different than the wifi adapter.
There's got to be some setting that is blocking you but without digging into the specifics of your settings, it would be difficult to diagnose.
 

abc5

Occasional Visitor
the only filter i have on the asus is dns filter by way of the following and its for the pi-hole

ive not set any routing rules within the asus.

yes on my laptop i had an occasion during my testing where i toggled off the wifi.

definitely puzzling as this is a basic ability. as i have not needed to ping from a hardwired pc i dont know when this may have stopped working.
 

Attachments

  • dnsfilter.JPG
    dnsfilter.JPG
    57.7 KB · Views: 10
Last edited:

abc5

Occasional Visitor
i have putty-ed into my raspberry pi, its just another device on my local lan. it is hard wired. from it, i am able to ping my gateway, im able to ping a pc ive on the network.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top