How is this possible AC5300 GPL 386 branch is not out

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

fearz

Senior Member
Hi there,

I saw in Merlins post that GPL For AC5300 has been changed to
6bb1ca7420 Merge 386_41535 binary blobs for RT-AC88U/RT-AC3100/RT-AC5300

but I can't find anywhere 386 branch for 5300 ?

Can we atleast know whats the didferetnec (from them)
 

ExtremeFiretop

Regular Contributor
Thats great any changelog available?

Update 2020/12/31 (9.0.0.4.386.41535)

This version includes
ZenWiFi XT8, XD4, CT8
GT series: GT-AX11000, GT-AC5300, GT-AC2900
RT series: RT-AX88U, RT-AX92U, RT-AX86U, RT-AX82U, RT-AX58U, TUF-AX3000, RT-AX56U, RT-AX55
RT series: RT-AC5300, RT-AC88U, RT-AC3100, RT-AC86U, RT-AC68U

Due to compile problem, not in this version
ZenWiFi CD6, Lyra, Lyra mini, Lyra trio

Change log
- Fixed Let's encrypt register issue.
- Fixed packet loop problem in ethernet backhaul.
- To improve security, RT-AC68U starts to encrypt the NVRAM from this version.
Known issue: RT-AC68U needs to be reset to default to resolve the login problem after upgrading to this beta version.
If you want to downgrade to the previous version, you need to do it with rescue mode.
We are looking for a solution to this problem if you worry about this known issue, please wait for a further version and not update to this version.

Happy new year!

That's the changelog for 386.41535
Link here: Beta - ASUSWRT 386 RC2 public beta with full functions AiMesh 2.0 | SmallNetBuilder Forums (snbforums.com)
 

fearz

Senior Member
Thank you.

can you help mein a different topic

I want to use https for 192.168.2.1

at the samw time i want to use https for router.asus.com


Alao i use ddns for fear.asusxomm.com still wanna use https for it.

I know ill havw to use a mizture of lets encrypr and pixelserv

But cant figure it out..

Can you please guide me?
 

ExtremeFiretop

Regular Contributor
Thank you.

can you help mein a different topic

I want to use https for 192.168.2.1

at the samw time i want to use https for router.asus.com


Alao i use ddns for fear.asusxomm.com still wanna use https for it.

I know ill havw to use a mizture of lets encrypr and pixelserv

But cant figure it out..

Can you please guide me?

I am assuming that 192.168.2.1 is your router's default gate?
Or it a different router you have connected in series to the ASUS router? (Different subnet?)

If it's the default gate for your ASUS router, and not a different router on the network;
Then first you need to make sure the following settings are checked under your Administrative --> System tab:

1610385541367.png

1610385575582.png


You can set it to "HTTP's only" if you rather instead of "Both".
You'll notice my installed Server Cert is my DDNS SSL cert.

You configure that under the WAN --> DDNS Tab as found below:

1610385677587.png


Just like that you should be good to access the WebGUI under the following addresses; router.asus.com or 192.68.2.1, fear.asusxomm.com using https (port 8443)
You may want to change the Method to retrieve WAN IP depending if you want internal or external.

If 192.168.2.1 is another router/IP on the network in a different subnet;
Then you'll need to do some port forwarding such as this under WAN --> Virtual Server / Port Forwarding:

1610385909567.png


(Assuming it's another router in your case, it would be port 8443 to 8443 instead of 32400, and pointing to the other router)
But only if you have another router in series (Different subnet). Otherwise no port forwarding is needed.

Adding another router in series might also require some routes to be setup depending on what router and subnets you setup.
 
Last edited:

fearz

Senior Member
I am assuming that 192.168.2.1 is your router's default gate?
Or it a different router you have connected in series to the ASUS router? (Different subnet?)

If it's the default gate for your ASUS router, and not a different router on the network;
Then first you need to make sure the following settings are checked under your Administrative --> System tab:

View attachment 29370
View attachment 29371

You can set it to "HTTP's only" if you rather instead of "Both".
You'll notice my installed Server Cert is my DDNS SSL cert.

You configure that under the WAN --> DDNS Tab as found below:

View attachment 29373

Just like that you should be good to access the WebGUI under the following addresses; router.asus.com or 192.68.2.1, fear.asusxomm.com
You may want to change the Method to retrieve WAN IP depending if you want internal or external.

If 192.168.2.1 is another router/IP on the network in a different subnet;
Then you'll need to do some port forwarding such as this under WAN --> Virtual Server / Port Forwarding:

View attachment 29374

(Assuming it's another router in your case, it would be port 443 to 443 instead of 32400, and pointing to the other router)
But only if you have another router in series (Different subnet). Otherwise no port forwarding is needed.

Adding another router in series might also require some routes to be setup depending on what router and subnets you setup.

Im very sory im confused

i have only 1 router 192.168.2.1 connected to a modem 192.168.1.1

i already have the 2 screenshots as you set
Can you please explain the difference between internet and external.

I alao have under lets encrypt: 192.168.2.1 & router.asus.com & fearz.asuscomm.com

but not still wannna use https,

do i have to use to use pixelserv as well?

Can uou kindly guide me stwp bu step how to secure 192.168.2.1 / router.asus.com and fear.asusxomm.com?

id also want to use port 443 instead 8443.

You help is extremely appreciated.

Thank you
 

John Fitzgerald

Senior Member

ExtremeFiretop

Regular Contributor
Im very sory im confused

i have only 1 router 192.168.2.1 connected to a modem 192.168.1.1

i already have the 2 screenshots as you set
Can you please explain the difference between internet and external.

I alao have under lets encrypt: 192.168.2.1 & router.asus.com & fearz.asuscomm.com

but not still wannna use https,

do i have to use to use pixelserv as well?

Can uou kindly guide me stwp bu step how to secure 192.168.2.1 / router.asus.com and fear.asusxomm.com?

id also want to use port 443 instead 8443.

You help is extremely appreciated.

Thank you

Do you want to access this externally and internally, or internally only?
 

ExtremeFiretop

Regular Contributor
Last edited:

ExtremeFiretop

Regular Contributor

ExtremeFiretop

Regular Contributor
I think you are off but I could be wrong:

View attachment 29380

Thanks for letting me know, but those were just the default values of my router. My country changes DST at the same time as you.
I just don't particularly care when my router changes from DST, in-fact, The Ontario government has passed legislation that would end DST for us, so extra reason for me not to care about it :p
 
Last edited:

ExtremeFiretop

Regular Contributor
Already did that but still none work with 443

I highly recommend against this as it's not secure, you would need to use a proxy or something to secure this.
Otherwise if security is not a concern for you, you may enable this under Administrative --> System tab:

1610393633162.png


Also make sure you are not forwarding any ports to 443. (That suggestion was only if you have a second router on a different subnet!)
Also not using the "Open Nat" on any consoles that use port 443.
 

fearz

Senior Member
I highly recommend against this as it's not secure, you would need to use a proxy or something to secure this.
Otherwise if security is not a concern for you, you may enable this under Administrative --> System tab:

View attachment 29382

Also make sure you are not forwarding any ports to 443. (That suggestion was only if you have a second router on a different subnet!)
Also not using the "Open Nat" on any consoles that use port 443.
Can you please explain the open nat?
 

fearz

Senior Member
why cna't for the love of gof secure router.asus.com ???

check the screenshot:
 

Attachments

  • RzCap-20210111234741.jpg
    RzCap-20210111234741.jpg
    49.2 KB · Views: 22

fearz

Senior Member
So Just to recap so everthing is clear

I want to secure (HTTPS) http://192.168.2.1 <- is that possible?

I also have the setting where i can redirect to: Redirect webui access to router.asus.com (sometimes it redirects and sometimes its not)

I Also want to secure HTTPS router.asus.com

Thats internal..

From the externak side i'ld like to use Let's Encrypt to have HTTPS cert for https://fearz.asuscomm.com

Please help.
 

fearz

Senior Member
I am assuming that 192.168.2.1 is your router's default gate?
Or it a different router you have connected in series to the ASUS router? (Different subnet?)

If it's the default gate for your ASUS router, and not a different router on the network;
Then first you need to make sure the following settings are checked under your Administrative --> System tab:

View attachment 29370
View attachment 29371

You can set it to "HTTP's only" if you rather instead of "Both".
You'll notice my installed Server Cert is my DDNS SSL cert.

You configure that under the WAN --> DDNS Tab as found below:

View attachment 29373

Just like that you should be good to access the WebGUI under the following addresses; router.asus.com or 192.68.2.1, fear.asusxomm.com using https (port 8443)
You may want to change the Method to retrieve WAN IP depending if you want internal or external.

If 192.168.2.1 is another router/IP on the network in a different subnet;
Then you'll need to do some port forwarding such as this under WAN --> Virtual Server / Port Forwarding:

View attachment 29374

(Assuming it's another router in your case, it would be port 8443 to 8443 instead of 32400, and pointing to the other router)
But only if you have another router in series (Different subnet). Otherwise no port forwarding is needed.

Adding another router in series might also require some routes to be setup depending on what router and subnets you setup.
Ok,
I changed the Aidisk port, and changed the webgui to port 443

so i need to do anythng in virtual port forwarding?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top