How to fix AX92U slow speeds on 2.4G & 5G bands?

Calrissian45

New Around Here
I just bought an RT-AX92U two pack and set it up as a mesh network, but it is very slow on the 2.4 GHz and 5 GHz bands. I upgraded the firmware on both and I followed recommendations on forums for settings that could fix the problem, but nothing worked. I tried using just one of the routers by itself and split the bands so I could test each one individually. After multiple tests, the best I could get was 50.8 Mbps on the 2.4 GHz band, 13.5 Mbps on the 5 Ghz-1 band, and 339 Mbps on the 5 Ghz-2 (WiFi 6) band. What could be causing the 2.4 and 5 GHz bands to be so slow? I attached images of the current settings. I got the same speeds when it was on the default settings. I'm on the 3.0.0.4.386_46061-g9a06866 firmware version, but I got the same speeds on the firmware that came with the routers.
 

Attachments

  • 2.4GHz.jpg
    2.4GHz.jpg
    40.6 KB · Views: 60
  • 5GHz-1.jpg
    5GHz-1.jpg
    40.6 KB · Views: 59
  • 5GHz-2 (WiFi 6).jpg
    5GHz-2 (WiFi 6).jpg
    39.2 KB · Views: 61

Calrissian45

New Around Here
I forgot to mention that I also keep getting a "Connected without internet" message on my phones when I connect to the 2.4 and 5 GHz bands. I don't have this when I connect to the WiFi 6 band.

Additionally, I was having all of these same problems on my previous router (ASUS RT-AC66U) that started recently, which is why I bought the new routers. Not sure if it's coincidence or if it could be some kind of outside interference. Any ideas would be appreciated.
 

OzarkEdge

Part of the Furniture
I just bought an RT-AX92U two pack and set it up as a mesh network, but it is very slow on the 2.4 GHz and 5 GHz bands. I upgraded the firmware on both and I followed recommendations on forums for settings that could fix the problem, but nothing worked. I tried using just one of the routers by itself and split the bands so I could test each one individually. After multiple tests, the best I could get was 50.8 Mbps on the 2.4 GHz band, 13.5 Mbps on the 5 Ghz-1 band, and 339 Mbps on the 5 Ghz-2 (WiFi 6) band. What could be causing the 2.4 and 5 GHz bands to be so slow? I attached images of the current settings. I got the same speeds when it was on the default settings. I'm on the 3.0.0.4.386_46061-g9a06866 firmware version, but I got the same speeds on the firmware that came with the routers.

I didn't bother to check your settings since you didn't bother to make them readable.

Did you reset the new firmware before you configured it?

Reset FAQ
Reset/Restore - clears settings in NVRAM; reboot restores firmware defaults from CFE.
Hard Reset/Restore+Initialize - also clears data logged in /jffs folder.

OE
 

Calrissian45

New Around Here
Yeah, I reset it after installing the firmware. I did it by the restore button in the settings menu and I did it again later by the red reset button on the back of the router.

Sorry about the images. I used an online website to combine them since I could only upload 5 images and didn't realize it degraded the images. I'm back to default settings now so those settings are irrelevant.
 

Calrissian45

New Around Here
I fixed the problem. I set the channel bandwidth to 40 MHz for the 2.4 GHz band and I set it to 20 MHz for the 5 GHz band. Now they are both very fast.
 

bbunge

Part of the Furniture
I fixed the problem. I set the channel bandwidth to 40 MHz for the 2.4 GHz band and I set it to 20 MHz for the 5 GHz band. Now they are both very fast.
Ah... should be 20 MHz for 2.4 and 80 MHz for 5 GHz. Better yet just use the defaults and give the router time to clear the 5 GHz for RADAR.
 

bbunge

Part of the Furniture
Those are the settings that caused very slow speeds. The AX92U doesn't have WiFi Radar.
Did not say WIFI RADAR. There are 5 GHz channels that are restricted if RADAR is in use in the area. Called DFS channels. If 160 MHz or DFS is selected the router scans for the presence of RADAR which can take several minutes. In this time the 5 GHz can be off or limited to 80 MHz. Thus it is a good idea to set the 5GHz to 20-40-80-160 MHz. I also recommend the use of Dual Band SmartConnect.
 

Calrissian45

New Around Here
Really? WHat are the "DFS settings for then?
My understanding is that only 5G-2 has DFS and only if you enable 160 MHz. The speed is just fine on that channel and the other two channels don't have DFS so that shouldn't make a difference for their speed. Am I missing something?
 

Calrissian45

New Around Here
Did not say WIFI RADAR. There are 5 GHz channels that are restricted if RADAR is in use in the area. Called DFS channels. If 160 MHz or DFS is selected the router scans for the presence of RADAR which can take several minutes. In this time the 5 GHz can be off or limited to 80 MHz. Thus it is a good idea to set the 5GHz to 20-40-80-160 MHz. I also recommend the use of Dual Band SmartConnect.
I started with this setup initially and the performance didn't improve after an hour or so. Also, I always hear that we should not enable SmartConnect if we care about performance. This proved good advice on my previous router. Is SmartConnect improved on this router?
 

Calrissian45

New Around Here
Okay. I think I found the real issue. I tried using SmartConnect and setting the channel bandwitdths to auto. I got incredibly slow speeds. Then I selected the option on the wireless mode to disable 11b and I had immediate performance improvement. I gave it some time and now I have excellent performance. Does that makes sense that 11b could cause everything to slow to a crawl?
 

OzarkEdge

Part of the Furniture
Okay. I think I found the real issue.

Oh really! Give yourself more time... WiFi is hard.

I tried using SmartConnect and setting the channel bandwitdths to auto. I got incredibly slow speeds. Then I selected the option on the wireless mode to disable 11b and I had immediate performance improvement. I gave it some time and now I have excellent performance. Does that makes sense that 11b could cause everything to slow to a crawl?

Disable Smart Connect to fix specific Wireless Modes, instead of Auto. My install notes outline some of these considerations.

OE
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top