What's new

RT-AX86U (AX5700) router dropping smart home devices every few weeks but Wi-Fi still works

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

pandacat

New Around Here
Been noticing my Asus RT-AX86U Router keeps dropping smart home devices (water sensors, cameras, temperature monitors, appliances). I Googled and this seems to be a known issue.

All my devices are connected to Guest Network (which has a different SSID than Main Network). That Guest Network uses 2.4 GHz. I have tried both "Enable" and "Disable" in the "Access Intranet" Option which made no difference. Time Remaining is "Unlimited access." I have also tried Disabling Roaming Assistant for the 2.4 GHz band.

I'm on the latest stock firmware. Not on AiMesh. Automatic DHCP IPs.

Security level is WPA2-Personal for Guest Network. My smart home devices on this network drops every few weeks and it's only these devices. My Wi-Fi on that same network still works. The only way to have the smart devices reconnect is to turn on and off the router.

Any recommendations?
 
What make/model are the smart home devices that are dropping?
Do these same smart home device drop if they are on the main WiFi network (not the guest network)?
Which Guest Network # are you using? If using Guest Network #1 try using Guest Network #2 instead. The Asus firmware may treat Guest Network #1 slightly differently (due to the AiMesh code in the firmware even when not used) than Guest Network #2 and #3.

A troubleshooting step. Make note of the 2.4Ghz channel number when the smart home devices are working, then make note of the 2.4Ghz channel number when the smart home devices are dropped from the WiFi. Could be the WiFi 2.4Ghz channel has changed an the devices have trouble picking up the new channel. If this is the case, one may have to manually set the 2.4Ghz WiFi channel to one the smart home devices support.

It may help if you post your 2.4Ghz WiFi settings, both General and Professional pages (redacting any sensitive information) in case others see a settings issue.
 
The only thing (and I just tried it a few days ago) was to set the 2.4GHz band to Legacy mode. All my ESP8266, ESP32, thermostats, and other wireless devices are MUCH happier when the Asus firmware does NOT try to play with N tricks.
 
Here's an update. I tried using Guest Network #2 instead of #1 but still same issue. Here are my settings in the stock Asus firmware.
 

Attachments

  • 1_router.jpg
    1_router.jpg
    106.4 KB · Views: 23
  • 2_router.jpg
    2_router.jpg
    71.2 KB · Views: 23
  • 3_router.jpg
    3_router.jpg
    60.7 KB · Views: 25

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top