IP isn't changing when connected to the VPN

jetpackjack

New Around Here
Hi All, I have an OpenVPN profile that I've created on my asus rt-ac86u. If I connect to the VPN and then view my IP Address it's still showing the external IP of the network the device is on and not the VPN's IP. I've been told I need to check the VPN settings and there should be a tick-box to configure it to act as the default gateway, usually says something like "Use this connection only for resources on its network" which you would want to be off. However, I'm unable to find this in either OpenVPN or the asus rt-ac86u's advanced settings under the OpenVPN section.

Any ideas how I can ensure any device using the VPN is using the right IP Address of the VPN?
 

L&LD

Part of the Furniture
What device are you using to connect back to your network? What browser are you using?

What VPN are you using (or is it just the OpenVPN connection back to your network)?

What are you expecting the 'VPN's IP' to be?

Have you enabled the 'Advertise DNS to Clients' checkbox in the OpenVPN advanced Server settings?

Did you correctly select 'Both' or at least 'Internet only' in the 'Client will use VPN to access' setting?

Can you provide screenshots of your setup to make this verification easier?
 

ColinTaylor

Part of the Furniture
VPN Server > General settings: Client will use VPN to access = "Both" (Merlin's firmware) or "Internet and local network" (stock firmware).
 
Last edited:

jetpackjack

New Around Here

L&LD,​

ColinTaylor

Thanks for both responding, it was the 'Client will use VPN to access' and needed to be set to 'Internet and local network'

Appreciate you taking the time to help me out. Thanks!
 
Similar threads
Thread starter Title Forum Replies Date
J asus rt-ac86u vpn isn't working and showing my WAN IP VPN 2

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top