I’ve done research but I’m at a bump. R7800 SQM

Thewrysigh

New Around Here
I have spent months/weeks on and off researching and hoping to find a resolution to the issues with stuttering or skipping in my games that I was unable to reproduce at my friends place. Thing is, it affects nearly all my systems and games. I thought I was going nuts but I found a correlation, it just didn’t hit me before. All of the games were online in some shape or form. I tend to play a lot of online games and I hadn’t seen a game t didn’t affect because I hadn’t been playing anything offline recently.

Turns out the most likely explanation was bufferbloat which I learned of in this process.

Things I’ve tried/looked into:

- Cabling, wires, line/signal quality. Ingress/egress checks. Tech replaced all fittings around the house.
-Several modem swaps and trying out a Netgear that doesn’t have a puma chip.
-Days of fiddling with archaic qos settings
-I upgraded my PS4 and PC initially thinking my tech was just old. Turns out the faster the frame rate, the more noticeable and off putting it is.
- Several cheaper routers over the past year. All had “fake” qos and did jack.
- got a higher internet package over a year ago, considered gig but heard that won’t help.

I found a single unopened X4S at one of my local stores in an areas that barely had them when they were new to begin with. I jumped on it because of its true sqm abilities. I know it’s not top of the line anymore but from everything I’ve read, it’s a beast regardless.

My problem? I’m aware of much of the inherent limitations of the X4S in terms of its sqm, stock firmware, hardware abilities locked out if using openwrt etc.

I have Spectrum internet with 400/20. This turns out to be over provisioned as I regularly get 470-480. Upload is really strange and I tried explaining it to the techs but they didn’t seem to care. I’ve seen it spike up to 90-100mbps on some speed tests. Most of the time however it’s settled around 22-24, but like it’s usually one or the other. I’m wondering if this upload stuff is making it hard to shape.

I seem to be able to suppress the download bufferbloat pretty damn well hovering from 0-5-25ms during the testing, but no matter what I do with upload, some strange stuff is going on.

If I try to use 80%,90,95, heck even 20% bandwidth limitation, the bufferbloat skyrockets. To be quite honest without any sqm, upload bufferbloat seems stable on its own.

Except, I decided to run a speed test on my phone while I had call of duty running in an online match. The ping was sitting comfortably around 30-40. The second the download test hit the upload side, my pings went insane for 3-4 seconds. This seems to happen on the initiation of anything upload intensive anywhere on the network NO MATTER, what I set. This happens with no sqm on the upload, and even if I find a sweet spot on codel or cake with upload to stabilize the bufferbloat, those spikes will still happen when I run the test.

This doesn’t seem to happen on the download side, only when I use no sqm. I can run other downloads and it seems stable.

Can anyone help me make sense of this?

Im using Hynmans latest stable build. Stock firmware was awful for my games qos wise. I also tried Voxels and stock OpenWrt.

my current setup that gets me A+ on everything but quality (shifts between a and a+). This is on a quiet network I can run it as many times as I want and it’ll be good. If anything else is done, it’ll go down to B and even D. Because of the several seconds it takes to stabilize the upload and for the pings to stop spiking.

Other info: I have the docsis option selected in the interface menu. I have a docsis 3.1 modem, does this apply to me? Should I turn it off?

I’ve tried not using anything in link layer and also 18 bytes. I’m still not quite sure what spectrums is. Software offloading seems to make download a little faster but that’s it. I have it off to troubleshoot.

I’m not quite sure what the channel bonding is on this modem from spectrum because they locked out. But I do recall when trying my own Netgear 32x8 modem, docsis 3.0 spectrum only utilized 24x4.

I seem to be able to control bufferbloat on download at setting it to 430 (over provisioned to 470 if you recall) this is with codel. I can’t seem to find anything to fix upload cake or codel. Oddly enough my score in bufferbloat is better if I overestimate my upload. The bursts of latency remain though.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top