Only the 1st OpenVPN works [SOLVED]

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

stevieosaurus

Occasional Visitor
Found an issue in version 384.19:
Same VPN client configuration (TCP / UDP) always works when it is the 1st VPN in the list, but the EXACT SAME config will not work loaded and activated on any other position.
To specify: connection to the VPN server is always successfully established, both public and local IPs are received, but internet access is only available when the 1st position of the list is the one active. Testing was made only with one OpenVPN connection active at one time, never multiple. Tried it with multiple VPNs, protocols, ports and countries, same result: only the 1st on the list works. Any suggestions?
Worthwhile mentioning: the exact same configuration shows a public IP when it is the 2nd, 3rd, 4th or 5th in the list (and no internet connection), but shows "unkown" when it is the 1st on the list (and internet works). IPv6 has been manually disabled in all cases.
 

Attachments

L&LD

Part of the Furniture
Did you reboot between tests?
 

octopus

Very Senior Member
Found an issue in version 384.19:
Same VPN client configuration (TCP / UDP) always works when it is the 1st VPN in the list, but the EXACT SAME config will not work loaded and activated on any other position.
To specify: connection to the VPN server is always successfully established, both public and local IPs are received, but internet access is only available when the 1st position of the list is the one active. Testing was made only with one OpenVPN connection active at one time, never multiple. Tried it with multiple VPNs, protocols, ports and countries, same result: only the 1st on the list works. Any suggestions?
Worthwhile mentioning: the exact same configuration shows a public IP when it is the 2nd, 3rd, 4th or 5th in the list (and no internet connection), but shows "unkown" when it is the 1st on the list (and internet works). IPv6 has been manually disabled in all cases.
You cant use same port on all clients. If you have block internet access on all clients then 1st on will be prioritised. No need to reboot between tests.
 

stevieosaurus

Occasional Visitor
You cant use same port on all clients. If you have block internet access on all clients then 1st on will be prioritised. No need to reboot between tests.
That is exactly why I specified that only one connection was tested at one time. No prioritzation was applied since only one connection was active at one time.
 

Xentrk

Part of the Furniture
Found an issue in version 384.19:
Same VPN client configuration (TCP / UDP) always works when it is the 1st VPN in the list, but the EXACT SAME config will not work loaded and activated on any other position.
To specify: connection to the VPN server is always successfully established, both public and local IPs are received, but internet access is only available when the 1st position of the list is the one active. Testing was made only with one OpenVPN connection active at one time, never multiple. Tried it with multiple VPNs, protocols, ports and countries, same result: only the 1st on the list works. Any suggestions?
Worthwhile mentioning: the exact same configuration shows a public IP when it is the 2nd, 3rd, 4th or 5th in the list (and no internet connection), but shows "unkown" when it is the 1st on the list (and internet works). IPv6 has been manually disabled in all cases.
Check the System Log for clues. You can also adjust verbosity to 4 and up to get additional debug msgs.
 

Jack Yaz

Part of the Furniture
you have the killswitch enabled for client 1, with the same clients routed (or all traffic) don't you?
 

stevieosaurus

Occasional Visitor
you have the killswitch enabled for client 1, with the same clients routed (or all traffic) don't you?
Yes, I have a killswitch for all of them. But again, the previous services are off. Only one on.
 

Attachments

RMerlin

Asuswrt-Merlin dev
Works for me, my test RT-AC66U_B1 actually has client 2 permanently connected for test purposes. The issue is with your setup.
 

Jack Yaz

Part of the Furniture
the firmware doesn't know the difference between the client being switched off, or the tunnel being down. disable the killswitch on 1. does connectivity now work on 2?
 

stevieosaurus

Occasional Visitor
the firmware doesn't know the difference between the client being switched off, or the tunnel being down. disable the killswitch on 1. does connectivity now work on 2?
Darn it! You were right @Jack Yaz ! The firmware doesn't know the difference and just parses all 5 OpenVPN settings no matter what, in ascending order. If ANY previous of them have killswitch enabled, the internet doesn't work, even if prev. VPN connection(s) are set inactive/disabled.

Thank you so much! What do I do with the tread now? Delete it or leave it for future reference?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top