Openvpn user name & password box location 386.2_4

ColinTaylor

Part of the Furniture
Those instructions are for an old version of stock Asus firmware. Go to the VPN Client page, upload your ovpn file, then enter your user name and password.

The process should be roughly the same as that for NordVPN (obviously don't use their DNS or custom settings).
 
Last edited:

wmmiller

Occasional Visitor
Those instructions are for an old version of stock Asus firmware. Go to the VPN Client page, upload your ovpn file, then enter your user name and password.

The process should be roughly the same as that for NordVPN (obviously don't use their DNS or custom settings).
 

wmmiller

Occasional Visitor
Hi Colin,

Thank you for your reply. If I understand you, the .ovpn file should contain the user name and password. If that’s the case, that’s my trouble. My .ovpn file does not contain that information. Surfshark support has been less than helpful. I asked them three times how I could manually put it in the .ovpn file and it seems to be top secret. This is from my .ovpn file and the area of the .ovpn file it should be in Correct?

Thank you, Bill

client
dev tun
proto udp
remote us-chi.prod.surfshark.com 1194
resolv-retry infinite
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping 15
ping-restart 0
ping-timer-rem
reneg-sec 0
remote-cert-tls server
auth-user-pass
#comp-lzo
verb 3
pull
fast-io
cipher AES-256-CBC
auth SHA512
 

ColinTaylor

Part of the Furniture
Thank you for your reply. If I understand you, the .ovpn file should contain the user name and password.
No, the ovpn file contains everything apart from your user name and password. After uploading the ovpn file to the router you manually enter your user name and password in the appropriate boxes further down the same page. Apply those changes and you're done.
 
Last edited:

wmmiller

Occasional Visitor
No, the ovpn file contains everything apart from your user name and password. After uploading the ovpn file to the router you manually enter your user name and password in the appropriate boxes further down the same page. Apply those changes and you're done.
Hello,

Do you mean in the Client Certificate & Client Key boxes? I did try that but I will again. I don’t think I tried the user name & password in the same box.

Thank you, Bill

Side note: I do have it running now on a Linksys WRT1900AC v1 running DD-WRT which is very easy to set up (because the user name & password field say user name & password) but it’s slow.
 

ColinTaylor

Part of the Furniture
Do you mean in the Client Certificate & Client Key boxes?
No. You seem to be making this more complicated than it is. It is really straight forward.

Did you look at the screen shots in that link I provided? Do you not see the same thing?

Username_Password.png
 
Last edited:

octopus

Very Senior Member
Hello,

Do you mean in the Client Certificate & Client Key boxes? I did try that but I will again. I don’t think I tried the user name & password in the same box.

Thank you, Bill

Side note: I do have it running now on a Linksys WRT1900AC v1 running DD-WRT which is very easy to set up (because the user name & password field say user name & password) but it’s slow.
Use "username" and "password" boxes.
 

wmmiller

Occasional Visitor
Hello Colin,

“Did you look at the screen shots in that link I provided? Do you not see the same thing?”

I did and no, I do not see the same thing, but think we just hit the nail. It is now my understanding that the .ovpn file upload is what should trigger the user name and password box to show up? If so, that is the issue. My .ovpn file from Surfshark does not make that happen. Therefore, when I upload and apply my .ovpn file, it does not trigger that box.

Thank you, Bill
 

ColinTaylor

Part of the Furniture
Can you post a screen shot of the screen you're seeing. The VPN GUI interface has changed slightly over the years so that might be why you're seeing something different.
 

wmmiller

Occasional Visitor
Can you post a screen shot of the screen you're seeing. The VPN GUI interface has changed slightly over the years so that might be why you're seeing something different.
Thank you, here they are. Bill

If I click the edit button under the “Crypto Settings” tab, I get what you see in picture 3.
 

Attachments

  • 1.PNG
    1.PNG
    39.1 KB · Views: 57
  • 2.PNG
    2.PNG
    455.2 KB · Views: 57
  • 3.PNG
    3.PNG
    56.1 KB · Views: 58

ColinTaylor

Part of the Furniture
That's very strange. Given the settings shown in post #4 you are missing quite a few sections of that web page. I can only think that either your router config in general is corrupted or the ovpn file you are importing is.

As an experiment can you try importing this NordVPN file as-is (don't worry it's a publicly available file containing no personal information) and seeing if the other sections (like user name and password) appear. As this is just a test there's no need to "Apply" this file, just remove the ".txt" extension and import it.

P.S. If you don't trust the file I've attached you can download one yourself directly from NordVPN's website here.
 

Attachments

  • uk2242.nordvpn.com.udp.ovpn.txt
    2.7 KB · Views: 49
Last edited:

octopus

Very Senior Member
If you use vpn "server" then turn on: "Manage Client-Specific Options" and then it's visible.
 

wmmiller

Occasional Visitor
That's very strange. Given the settings shown in post #4 you are missing quite a few sections of that web page. I can only think that either your router config in general is corrupted or the ovpn file you are importing is.

As an experiment can you try importing this NordVPN file as-is (don't worry it's a publicly available file containing no personal information) and seeing if the other sections (like user name and password) appear. As this is just a test there's no need to "Apply" this file, just remove the ".txt" extension and import it.

P.S. If you don't trust the file I've attached you can download one yourself directly from NordVPN's website here.
That file you sent gives me the same result. When I hit the apply button it says the same thing.

I have even done a factory reset on the router a couple times. I also in the Authentication Settings, tried to select the Static Key option, hoping perhaps the Username and Password fields would show. No joy.

I wasn’t expecting this to be a huge issue. The dd-wrt setup it’s working on now just has a “User Pass Authentication” button that can be enabled or disabled. I figured I was just overlooking a step and this would be similar.

Thanks, Bill
 

Attachments

  • 3.2.PNG
    3.2.PNG
    67.4 KB · Views: 55

ColinTaylor

Part of the Furniture
If you click on the "Default" button at the bottom of the page does that change anything?

As per post #14, try a different browser/PC. It might be anti-virus software blocking some JavaScript stuff.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top