Voxel r7800 ReadyShare pauses

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Theo Gjaltema

New Around Here
Hi, I have a R7800 running voxel V1.0.2-81SF firmware.
Since my nas crashed I connected a disk formatted ext-4 to the USB of the router and configured ReadyShare to export it to my local network.
When wathing movies stored on this disk I often get time-outs of multiple seconds.
The devices I used to watch movies are conneced not by Wifi but wired (passing a switch, SG-TL1008D), I tried sony-tv using codi and VLC as well as RPI4-codi
Any suggestions? How do I analyse this issue?
I know that is is not caused by the current voxel firmware, this issue is present quite some time.

Regards,
Theo
 
Last edited:

Theo Gjaltema

New Around Here
As a followup: Already tried the following:
1. Replaced all cabling&swith by a new cable without swith, no result (so I rule out the bad cable & bad switch option)
2. Replaced the WD 4TB -ext4 formatted disk by a WD 3TB ext-2 formated disk , looks like some improvement but still annoying pauses whilst watching a movie.

Logged in to the router, no significant messages in /var/log/messages, only 22 entries in /proc/net/arp (21 connected devices, 1xWAN)
Only startup message in /var/log/log.smbd
When writing (40MB/sec) to the disk from a PC the cpu load average is less than 6%
When reading (70..80MB/sec) from the disk to a PC the cpu load is less than 7% (measured by top, also states that smbd uses 30%...)
 

Voxel

Very Senior Member
I am sorry but I do not face such an issue. Maybe hdidle? I.e. your USB HDD goes to sleep... Did not you try to test with e.g. USB flash drive?

Voxel.
 

Razor512

Very Senior Member
While I have not experienced this issue with my R7800, I have experienced a similar issue with my Netgear RAX50. Basically every 50 or so minutes, the readyshare will stop sending or receiving data for a few seconds, which interrupts any stream as well as causes any file transfer to or from the USB storage to fail.

Overall, because of that, I largely stick with the R7800 for reliable USB storage.

The drive is formatted as NTFS.
 

Theo Gjaltema

New Around Here
I am sorry but I do not face such an issue. Maybe hdidle? I.e. your USB HDD goes to sleep... Did not you try to test with e.g. USB flash drive?

Voxel.
Did the test with an ssd of 250G connected to the USB. Stil not flawless. I have now turned off Qos. See what happens.
 

Theo Gjaltema

New Around Here
I found a work-around.
In the router I disabled Dynamic-QOS, no problems anymore! Previous (with Dyn.-QoS enabled) there were multiple hick-ups every hour, now during a test period of at least 10 hours it didn't happen again!
Since the disk nor file-system type didn't make a difference I switched back to the original 4T-Wd disk ext4 formatted.
Thanks for the support!
 

Theo Gjaltema

New Around Here
Since disabeling QOS solved this problem I also disabled the WMM for both 2.4 and 5b GHz.
This had the nasty sideeffect that wifi throughput dropped to 22 Mb/sec (measured with speedtest on a One+7)
After complains from my kids I re-enabled the WMM and the thougput restored to previous levels (max as provided by Ziggo in my case).
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top