1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC68U and Android device battery drain...

Discussion in 'ASUS AC Routers & Adapters' started by bleets, Aug 20, 2018.

  1. bleets

    bleets New Around Here

    Joined:
    Aug 20, 2018
    Messages:
    5
    Howdy.
    I've got an RT-AC68U running the latest firmware (3.0.0.4.384_32738) and a Google Pixel 2 running Android 9.0 Pie.

    Since updating to Pie on the phone I've noticed, when connected to the Asus router via WiFi the battery drains 5-6% an hour when the phone is idle. Turning WiFi off and it's 0-1% an hour drain.

    And to test further I connected to a WiFi network running on a TP-Link VR900 v1 to see if it was wireless on Pie in general and it didn't have the high drain when connected to the TP-Link...about 0-1% an hour when idle.

    So...yeah it's definitely something with the Asus router as it doesnt happen with other rotuers.

    I just don't know if it's something in Asus hardware or firmware or a compatability problem Google have introduced in Android?

    Probably the latter but still...can't hurt to ask right? :)

    Any ideas?
    Thanks
     
    Grisu likes this.
  2. drabisan

    drabisan Senior Member

    Joined:
    Dec 30, 2013
    Messages:
    326
    Hmmmm, that's really odd!
    I do also own a Pixel XL and Pixel 2, both with Android 9, and I have no power drain problem. My routers are a GT-AC5300 and a RT-AC68U, both running 3.0.0.4.384.21140. I'm planning to upgrade to 32738 once it will be available for AC5300; I'm running AiMesh so I prefer to have them both on the same release.
    It will be almost impossible to track down what exact feature in the router is causing the problem. Beacons from router can keep the phone awake for no reasons. Are you using something else than 100ms? Can you see the power problem on both 2.4 and 5GHz SSIDs?
    I would try forgetting the SSID on the phone and re-add it.
    Last hope would be to factory reset the router, install 21140 and do a minimal configuration.
     
  3. bleets

    bleets New Around Here

    Joined:
    Aug 20, 2018
    Messages:
    5
    If the Pixel 2 is running Pie try turn wifi off and then on again.

    I've re-added the network on the phone which resolved it until I turned WiFi off and then on again, then the issue recurred.
    It's a standard install, haven't messed with any WiFi settings other than to turn the SSID to hidden...and because of that I added a guest network with a visible SSID to connect to which had the same problem.
    And yes it's both 2.4 and 5ghz (although they share the same SSID. to force it during testing i disabled the 2.4 and 5ghz radios in turn).

    I might try downgrade to 21140 but I don't hold out much hope that fixes anything...looking at the changelog it doesn't look like anything would affect wireless but then Asus always seem to make changes that aren't in the changelog so who knows...
     
  4. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    764
    Location:
    USA
    I understand that hidden SSIDs 'burden' the connection... at least take longer to connect. Have you tried not hiding any SSIDs?

    OE
     
  5. bleets

    bleets New Around Here

    Joined:
    Aug 20, 2018
    Messages:
    5
    I did that by adding an unrestricted guest network.

    I might re-flash my phone back to 8.1 :| Can't figure out if it's an Asus or Google issue
     
  6. drabisan

    drabisan Senior Member

    Joined:
    Dec 30, 2013
    Messages:
    326
    Why don't you try downgrading the router?
    It's less trouble.
    In 21140 there are absolutely no problems with Pixel 2 running Android 9.

    In a couple of days they will release new Asuswrt for GT and at that moment I'll upgrade both my Asus devices. But before that time I can only conforctherecare no issues with 21140.
     
  7. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    764
    Location:
    USA
    This thread suggests the problem can present with other WiFi besides ASUS. The common denominator appears to be the Pixel 2 and the subject Android update. I would suspect it is an Android update issue. Stepping back may clear it; stepping forward again may also clear it, but I'd be inclined to downgrade Android and wait.

    What a pain... the battery is everything!

    OE
     
    Last edited: Aug 20, 2018
    Grisu likes this.
  8. bleets

    bleets New Around Here

    Joined:
    Aug 20, 2018
    Messages:
    5
    Well I downgraded the routers firmware and...still the same...this is even stranger now.

    @drabisan did you try turning wifi off and then on again to trigger it?
     
  9. bleets

    bleets New Around Here

    Joined:
    Aug 20, 2018
    Messages:
    5
    Hi.

    Just an update to this for anybody that is interested...
    My issue is not with the Asus router. It's definitely android.

    I've downgraded my Pixel 2 to several earlier android builds and all exhibited the issue.
    I downgraded the RT-AC68U several versions even going as far back as 3.0.0.4.380_7743 since that firmware didn't have AIMesh and I'd used it for quite some time...and I still had the battery drain issue.

    Then on a whim I left DHCP on and connected to the WiFi on the Asus again and..I couldn't reproduce the issue (I use static IP with DHCP off for several personal reasons...I know I can do static assignments via DHCP but there's still reasons I don't).

    So yeah...static IP has the battery drain issue, DHCP doesn't.

    To double check that I connected to the TP-Link router on a static IP that isn't in the DHCP pool and I observed the battery drain issue.

    So yeah, thanks for reading, nothing to do with the router. :)

    Strange though that connecting via static IP has this issue...real strange.

    *edit*
    Does anybody know if it's possible to have DHCP exclusions where a specific MAC address won't be assigned an IP via DHCP but can still connect via static IP? I've trawled through the settings but can't find anything so I'm guessing not.
     
    Last edited: Aug 22, 2018
    shont and Grisu like this.
  10. Dek Fin

    Dek Fin New Around Here

    Joined:
    Saturday
    Messages:
    1
    Battery draining is one of the common issues and many people are facing this. Always keep your device up to date or take help from Asus laptop battery replacement for the best suggestion regarding draining issue.
     
  11. MarkyPancake

    MarkyPancake Senior Member

    Joined:
    Dec 17, 2013
    Messages:
    208
    I had a Pixel 2 for about a month while my OnePlus 3T was away for a repair around July this year, so before Pie was out, and whilst setting it up I noticed Google had removed a setting from the Wi-Fi options that I use on other devices, which reduces battery drain. It's the 'Keep Wi-Fi on during sleep' option.

    The choices for this setting are always, only when plugged in (this is my preference) or never.

    It turns out along with Google removing this option from their Android GUI, they've set the default behaviour to always on. So, when you've locked your device, the Wi-Fi never sleeps. Perhaps Pie doesn't play nice right now with Wi-Fi being always on when the device is sleeping.

    You can change this setting to one of the previously available GUI options using ADB, but I can't remember what the command is.

    I've attached a screenshot to show the option I'm referring to on my 3T. It was also on my Nexus 5 and is on my Nexus 7.[​IMG]
     
  12. OBENZ

    OBENZ Occasional Visitor

    Joined:
    Nov 22, 2018
    Messages:
    13
    Android battery drain is caused by the phone being kept awake by receiving constantly packets from the router I think DMT is the culprit or the beacon interval I changed both and never experienced battery drain again
     
  13. MarkyPancake

    MarkyPancake Senior Member

    Joined:
    Dec 17, 2013
    Messages:
    208
    I've always left my Asus router DTIM and Beacon intervals on their default values (N66U, AC68U, AC86U) and never had the high battery drain the OP is experiencing with any of my Android devices. None of my current devices are running Pie though.