RT-AC86U IPV6 Router Advertisement not working properly

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

WillyTP

Regular Contributor
Hello everybody.
I've setup an Ac86u for my home network with latest stable Merlin, 384.19

Due to my ISP, I've configured IPV6 in 6in4 mode.

On router itself, Ipv6 is working properly;
On connected devices instead, Ipv6 lasts about 10 minutes, then it drops and doesn't get renewed again until I Switch on / off the network interface (eg. switching on/off network on mobile).

Obiouvsly Router solicitation is enabled.

Any suggestions?

Thanks
 
Last edited:

L&LD

Part of the Furniture
Did you reboot the router?

Did you power down all modem/ONT and router (i.e. all network infrastructure) for at least 20 minutes) and then power everything back up again?
 

WillyTP

Regular Contributor
Hi @L&LD

Yes, I rebooted the router, many times actually.
I'm trying now to see what happens after shutting everything down for 20 mins.

But excuse me, why keeping all off should solve the problem?
Personal curiosity in order to learn something :)

UPDATE1
P.S. I hope not to speak too soon: after keeping all off for 20mins, IPv6 seems to work.
However, every 10 minutes IPv6 changes. Is this behaviour normal?
I see the list of IPv6 under System Log -> IPv6

UPDATE2
Nothing, after successfully renewing IPv6 every 10 minutes for more or less one hour, now it's down again.
I don't find (or I'm not able to find) anything interesting within the system log.

Thank you!
 
Last edited:

L&LD

Part of the Furniture
What turning everything off would/should have done was reset the connection between your modem/ONT and your ISP. Yours needs a longer 'time out', possibly? You may want to test for 60 minutes or just over (that will definitely, rule that out). Some have suggested to call and get your ISP to do this on their end, but I haven't found any ISP to do what is asked in less than an hour anyway. :)

Can you another IPv6 connection type? I would test with Native or try 6to4 instead. Make sure you power down the modem/ONT for a 'fair test' and reboot (or better yet, power up the router) after the connection to the ISP has been fully established.
 

WillyTP

Regular Contributor
What turning everything off would/should have done was reset the connection between your modem/ONT and your ISP. Yours needs a longer 'time out', possibly? You may want to test for 60 minutes or just over (that will definitely, rule that out). Some have suggested to call and get your ISP to do this on their end, but I haven't found any ISP to do what is asked in less than an hour anyway. :)

Can you another IPv6 connection type? I would test with Native or try 6to4 instead. Make sure you power down the modem/ONT for a 'fair test' and reboot (or better yet, power up the router) after the connection to the ISP has been fully established.

Hi Again
I still haven't tried a longer shut down; I'll do it soon.

However, as UPDATE 3, now it seems that an IPv6 is "more or less" always provided.
More or less means, that now I go on IPV6-Test and it works, in 10 minutes it works with another IP, in 20 minutes maybe doesn't work, after other time works again...

6in4 is the only option I can use; better would be 6RD, but my Ac86u is behind another router which I cannot put in bridge mode (Fastgate of Fastweb, Italy in the case you know)

The list of IPv6 under Sistem Log is now pretty huge :-/
 
Last edited:

jeden

Regular Contributor
The same thing is happening to me using the regular firmware, so it seems like a bug in it.


Myself I am going to downgrade.
 

WillyTP

Regular Contributor
Hmmm I see.
@RMerlin, should we file a bug to Asus or are they already aware of this?

I'd be glad to help more but sincerely I don't know what to do.

Thanks
 

ColinTaylor

Part of the Furniture
Two different models of routers, two completely different versions of the firmware, no previous reports of this sort of behaviour. Both of these reports posted within 12 hours of each other.

Maybe it's not the router or firmware but your tunnel provider? Both using Hurricane Electric?
 
Last edited:

WillyTP

Regular Contributor
I'm not using any 3rd party tunnel.
I'm in Italy, with Fastweb provider.
They provide IPv6 connectivity via 6rd;
I must use 6in4 because I have to keep their Router too (I cannot put it in bridge mode... Just DMZ to my Asus router)
 

podkaracz

Senior Member
I'm not using any 3rd party tunnel.
I'm in Italy, with Fastweb provider.
They provide IPv6 connectivity via 6rd;
I must use 6in4 because I have to keep their Router too (I cannot put it in bridge mode... Just DMZ to my Asus router)

Im going to test different isp's soon to determine which one works better but one of them is Orange and they claim ipv6 compatibility only with their funbox device so its probably the same thing in your case that you need to keep their router and then your own. I know they provide ipv6 support so ill watch this thread to find out what you guys find out about ipv6 on asus rt86u
 

jeden

Regular Contributor
I am using HE, but it's not the tunnel's responsibility to send periodic route advertisements, but the router's.

Besides, I downgraded to 3.0.0.4.385_20631 and now it works fine.
 

L&LD

Part of the Furniture
And as a data point, no issues with IPv6 and Beta 3 across many routers when used with 'Native' IPv6.

Including, RT-AC86U, RT-AX88U, RT-AC66U_B1, RT-AC68U, RT-AC86U and RT-AC3100.
 

GHammer

Senior Member
IPv6 working here as well. Native. IPv6 through the firewall to services I host locally.
 

WillyTP

Regular Contributor
Hi,
I dirt-updated to 386.1 Beta3 another "less critical" AC86U which I own.

With this release the problem seems to be gone.
I need to test for more time anyway. I'll let you know.
 

WillyTP

Regular Contributor
Hi again
After one day of very little test (or better, system running without touching) I noticed that with 386.1 Beta 3
  1. On my desktop (Windows 10) IPv6 is being kept and seems to be always working
  2. On my mobile (Samsung Galaxy S10, Android 10, December 2020 update, IPv6 sometimes work, sometimes not... more NOT than yes. Neither connecting / disconnecting WiFi solves the issue. Rebooting Android solved.
  3. On another mobile (Iphone 8), IOS 14.3 - IPv6 works and seems to be always working
https://www.yourasusrouter.com:8443/Main_IPV6Status_Content.asp reports a few IPv6 changes, in my case maximum 3 per device.

However I don't suggest anyone to upgrade to 386.1 Beta3, in my opinion there is a severe bug causing overheating.

If someone more expert than me has some advices in order to inquire further is welcome.
 

L&LD

Part of the Furniture
@WillyTP, what router are you talking about?
 

WillyTP

Regular Contributor
Hello again everybody.

Unfortunately I haven't enough knowledge to inquire this issue deeply.

A thing I've noticed, it's that on the iPhone IPv6 seems to be always working, while on Android after 10 minutes it stops.

Does this make somewhat sense?
Can anybody try?

Thanks
 

L&LD

Part of the Furniture
Are you still on that old Beta?

Try the latest Beta 4b (in the Pre-beta test builds (occasionally available, hosted on Onedrive) link) for your router if you are.

Also, a full reset after flashing it may be in order to test it properly too.

 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top