RT-AX86U / Merlin 386.3_2 / Squeezebox Duet Receiver (Logitech)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

W3Wilkes

Occasional Visitor
I'm new around here as I've recently upgraded to this router and Merlin firmware and for the most part I'm extremely happy with this choice. I figured I'd start in the Merlin area and see if I can get some help. My Duet receivers are being "Deauthenticated" and then they come right back. The problem is the music server changes the player to another device and I have to reset the server back to the desired receiver. Below is the system log entries I believe shows what I'm talking about. Can anyone give me a hint as to what I may be looking at to fix this as I didn't have the problem on my old router. These receivers are old - 2.4GHz only and supposedly 802.11b/g/n compatible.

Sep 16 10:58:16 kernel: wl0: random key value: EF0657AA09545ADB20110208095A1389F3699C10F2050F8F85A21A0C2CBE7C86
Sep 16 10:58:16 kernel: wl0: random key value: 8D5277BDA85CDF4A1B7003289298427687E2AD10CF960578C4E77D4D8997A36F
Sep 16 10:58:16 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 00:04:20:16:AB:47, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Sep 16 10:58:16 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 00:04:20:1E:A7:09, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Sep 16 10:58:16 kernel: wl0: random key value: A1E580636FBAD11B5ED601B5D6684528C6C9F6BCDB590AE78608EAEC58375122
Sep 16 10:58:16 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 00:04:20:17:A6:84, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(505): eth6: Auth 00:04:20:1E:A7:09, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(505): eth6: Auth 00:04:20:17:A6:84, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(534): eth6: Assoc 00:04:20:17:A6:84, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(534): eth6: Assoc 00:04:20:1E:A7:09, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(505): eth6: Auth 00:04:20:16:AB:47, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(534): eth6: Assoc 00:04:20:16:AB:47, status: Successful (0)
 

Tom Ames

Regular Contributor
I am of absolutely no help in reading a log, but I just wanted to point out that the Receiver is not N compatible--only G--and 2.4GHz. I can't imagine that is related to your issue but wanted to mention it just in case your router settings got reverted somehow.

My only Receiver died a few years ago (replaced with a couple of piCore players) but my Controller and Boom are still going strong. Good luck in getting this sorted!
 

ColinTaylor

Part of the Furniture
First, make sure your 2.4GHz band is set to a fixed channel (not auto) and set at 20MHz bandwidth (not 40 or 20/40).

If that isn't sufficient you may need to experiment with other 2.4GHz settings. e.g. disabling Wi-Fi 6 mode, Wi-Fi Agile Multiband, Airtime Fairness, Multi-User MIMO and Universal Beamforming.
 

W3Wilkes

Occasional Visitor
My only Receiver died a few years ago (replaced with a couple of piCore players) but my Controller and Boom are still going strong. Good luck in getting this sorted!
Yes, I knew that the receiver is a g device. I still have 2 good receivers and a Boom. When this happens it drops all 3 from LMS. I do run a fixed channel as I found years ago that receivers don't follow "Auto" very well. My channel width was 40 so I've now set it to 20. I'd previously shut off WPS and Roaming Assistant (I don't have mesh) which had no effect. One thing at a time so the 20Mhz for now.
 

W3Wilkes

Occasional Visitor
First I apologize for posting this problem both here and in the Merlin forum, but I'm not getting much help in Merlin land. I have a single router RT-AX86U running Merlin 386.3_2 firmware. I have 3 Logitech devices, 2 Duet receivers and 1 Boom that periodically disconnect and then reconnect to the router. I then have to reselect my desired player in the Logitech Media Server application that feeds music to these devices. These are all 802.11g devices on my 2.4Ghz band. It appears to happen when I have the channel width set at 40Mhz wide. I had this same setting on my old router and these devices stayed connected with no problem. Here's the System log from the router when this occurs. If there's any log reading experts can you tell me why this is happening?

Sep 16 10:58:16 kernel: wl0: random key value: EF0657AA09545ADB20110208095A1389F3699C10F2050F8F85A21A0C2CBE7C86
Sep 16 10:58:16 kernel: wl0: random key value: 8D5277BDA85CDF4A1B7003289298427687E2AD10CF960578C4E77D4D8997A36F
Sep 16 10:58:16 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 00:04:20:16:AB:47, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Sep 16 10:58:16 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 00:04:20:1E:A7:09, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Sep 16 10:58:16 kernel: wl0: random key value: A1E580636FBAD11B5ED601B5D6684528C6C9F6BCDB590AE78608EAEC58375122
Sep 16 10:58:16 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 00:04:20:17:A6:84, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(505): eth6: Auth 00:04:20:1E:A7:09, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(505): eth6: Auth 00:04:20:17:A6:84, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(534): eth6: Assoc 00:04:20:17:A6:84, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(534): eth6: Assoc 00:04:20:1E:A7:09, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(505): eth6: Auth 00:04:20:16:AB:47, status: Successful (0)
Sep 16 10:58:22 wlceventd: wlceventd_proc_event(534): eth6: Assoc 00:04:20:16:AB:47, status: Successful (0)
 

Tech9

Very Senior Member
some older AC devices do not like lower channels

Can you give an example? I never had such device in my hands and knowing how most internal Wi-Fi circuits are made this doesn't sound right. I would say the opposite - most printed antennas are tuned closer to 5.2GHz frequency. I personally always use lower channels, constant better throughput. For best performance - SmartConnect disabled. Tested and confirmed multiple times. It is disabled by default as well.
 

W3Wilkes

Occasional Visitor

Tech9

Very Senior Member
Normal messages at device disconnection. One I believe is zero-key replacement related, the other is a debug info left enabled by Asus.
 

AlbumMan

New Around Here
Had the same issue with my RT-AX3000 and an Ambient Weather Station for awhile. I slowly changed the obvious settings a little at a time with mixed results but it was still happening. Set the bandwidth to 20Mhz, find a decent channel your neighbors are not on (not auto), change the Wireless Mode to Legacy and uncheck the b/g Protection box. You said you only had g devices anyway. Hasn't dropped since! Let me know if that works.
 

W3Wilkes

Occasional Visitor
Actually I said that these 3 devices were g, I didn't mention that I have more devices that are 802.11n that only do 2.4Ghz capable and they don't drop from the router, only these 3 g devices. These 3 devices worked fine on both my old Netgear routers - DGND3700v1 & D7000v2. I could set the data rate at max 150Mbps on the Netgear routers for 2.4Ghz and capable devices would run that speed. For whatever reason setting the channel width to 20Mhz seems to slow the 2.4Ghz n devices to just under 54Mbs. The rest of my stuff either lives in 5G land or ethernet attached. Seems to me there's a backward compatibility issue in the firmware.
 

W3Wilkes

Occasional Visitor
I did change the channel width to 20 / 40 and these 3 devices haven't cycled since. this feels like ASUS missed something in their backward compatibility. It does seem to throttle back my other n devices on the 2.4Ghz radio though.
 

Tech9

Very Senior Member
Don’t push 40MHz wide channel on 2.4GHz in residential areas. You’re basically trying to steal all the available 2.4GHz bandwidth, making things worse for you and everyone around you. Router set on 20/40 will use 20MHz most of the time. You may need to read how Wi-Fi works in order to avoid such issues in the future.
 

W3Wilkes

Occasional Visitor
According to my wifi analyzer on my phone and inSSIDer on my laptop I've got no conflicts with my neighbors. With both of these I do see that with 20 / 40 set it seems the router never brings up the 2nd channel even when I connect to the 2.4Ghz band with my laptop that can use a 40Mhz signal. When I go outside I do see a very weak signal appear and disappear from a neighbor that is using 40Mhz on what appears to be channels 11 & 8. Lots in my neighborhood run from about 1/3 to 1/2 acre so we are spread fairly well. Mine is set for 6 and Below. Since I can't see this neighbor or any other neighbors wifi anywhere in my house I don't see a problem with 40Mhz or a slight overlap with their channel 8 and my channel 6.
 

Tech9

Very Senior Member
You may not see a problem, but if the router stays at 20MHz wide, it sees interference around. 2.4GHz signals travel further. The router's radio is much more sensitive than your phone's. There is a Wi-Fi analyzer in Asuswrt-Merlin firmware, taking data from the SoC. You can see there what channels are in use and what is the maximum throughput available, as the router sees the environment. This is the better source of information.
 

W3Wilkes

Occasional Visitor
The Merlin wifi analyzer says my 2.4Ghz control channel is 11 and then 9 as the center channel, too bad that my control channel is 6 and I specified "Below" for the center. inSSIDer on my laptop and wifi analyzer on my phone see the 2.4Ghz band as I've set it. Merlin sees no other users on the 2.4Ghz band kind of like I said earlier. From this I don't place much faith in Merlin's wifi analyzer! Merlin does say my 2.4Ghz is set at 40Mhz bgn and max throughput at 600Mbps which I am pretty skeptical of since speed test on 2.4Ghz comes in at just under 40Mbps where my 5G comes in at 267Mbps down / 287Mbps up. I'm provisioned for 256Mbps from my ISP.
 

Tech9

Very Senior Member
It’s not Merlin’s, comes from Broadcom, as far as I know. You are a bit confused with Wi-Fi channels, max theoretical speeds, link speeds, and throughput + what to expect in real life.
 

W3Wilkes

Occasional Visitor
Really though much this has nothing to do with the problem of the old Logitech 802.11g devices periodically dropping and reconnecting. The wifi card in these devices is here. These devices do work when channel width is set at 40MHz, but eventually all 3 devices drop and reconnect at the same time as shown in the system log I posted while all other 2.4GHz devices are unaffected. Since only the 3 Logitech devices do this I would expect it's the router dropping them vs the devices causing it as they're not linked to each other and then the devices initiates the reconnect because that's what they do. Since these and all my other 2.4GHz devices worked just fine on my old Netgear dual band n router there's only one thing that's changed, the RT-AX86U. Don't get me wrong, this is one hot rod of a router (and it's not trying to look like some kind of "Transformer" or "Alien Space Ship"), I just hate the thought of partially crippling it when I really shouldn't have to.
 

ColinTaylor

Part of the Furniture
Did you try disabling the options I mentioned in post #3? They are the ones that frequently cause issues with older devices.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top