RT-AX88U on 386.16 having MiniDLNA/DNS dropouts

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

scott420

New Around Here
Good day,

I attempted to upgrade my RT-AC68U (99.9% solid) to a RT-AX88U and I keep running into DNS dropping out and MiniDLNA completely crapping out. I've reverted back to my RT-AC68U, but I'll see if anyone has any suggestions.

I wanted to upgrade for Wifi 6/AX, my wife's new Iphone supports it and I got a AX200 card when I purchased this.

The DNS drops out, and seems to be if/when I "push" the router (I.e. copy a file via SAMBA to one of the two USB's on the router) and it'll either take 5-10 minutes for it to come back, or I'll run ScMerlin and have it restart DNSMasq. After a few seconds, it's okay for some time. It's hard to tell what causes it, seems to happen about twice during my 8 hour shift, but happens more often copying files.

The second, and more important issue to my wife, is the MiniDLNA is extremely unstable.
I have two WD USB3 Portable drives plugged in, one 3TB one 5TB, both formatted etx3 (I believe, I know it's ext).It'll just disappear from showing up on my PC or my TV. PC is ethernet, TV is Wifi AC/5GHz. It MAY work after a router reboot, but if it does show/work, it will drop out. Turning off /on the switch in the router config/USB UPNP server rarely helps. When it's "down" - attempting to pull up the status page on port 8200 does not work either. The drives still show in Samba or the shell.

I started looking thru the minidlna.log to see if I can find anything useful -

2020/04/20 16:08:45] minissdp.c:315: error: sendto(udp_notify=8, 192.168.1.1): Invalid argument
[2020/04/20 16:08:46] monitor.c:129: error: inotify_add_watch(/tmp/mnt/nvram) [No such file or directory]
[2020/04/20 16:08:46] monitor.c:682: error: add_watch() failed
[2020/04/20 16:08:46] monitor.c:696: error: opendir failed! [No such file or directory]
[2020/04/20 16:08:48] minissdp.c:315: error: sendto(udp_notify=8, 192.168.1.1): No such device
[2020/04/20 16:14:23] minissdp.c:315: error: sendto(udp_notify=8, 192.168.1.1): No such device
[2020/04/20 16:14:23] minissdp.c:799: error: sendto(udp_shutdown=8): No such device
[2020/04/20 16:14:23] minissdp.c:799: error: sendto(udp_shutdown=8): No such device
[2018/05/04 22:05:16] minidlna.c:1313: warn: Starting MiniDLNA version 1.2.1.
[2018/05/04 22:05:16] minidlna.c:1354: warn: HTTP listening on port 8200
[2018/05/04 22:05:19] minidlna.c:168: warn: received signal 15, good-bye
[2018/05/04 22:05:19] minidlna.c:1313: warn: Starting MiniDLNA version 1.2.1.
[2020/04/20 16:15:21] sql.c:41: error: SQL ERROR 5 [database is locked]

I've tried-
Factory Reset
Downgrading to .15 (put it back to .16)
Swap file 2GB
No Swap file
No Diversion
Last one was a factory reset, and then turning on Guest Wifi and normal Wifi, and MiniDLNA/UPNP. I left everything else default - same issues.

I'll be happy to answer any other questions or try anything else. I have not tried the ASUS firmware, but would lose most of the options I enjoy. I'd probably just re-sell it if that's what I have to do.

Any suggestions?

Edit- So reading the log, I did the WPS hard reset, then restored the AX88U back to how I had it, and only have one USB drive in. I reset the 68U, set it to AP mode, and left one of the USB's in it. Solid so far. I won't know until tomorrow about the DNS dropping though. I'd rather eliminate the 68U and only one DLNA server, but this is progress. Copying files in SAMBA would have it go for about five seconds, then stop to 0 for a few seconds, and then resume again. I just copied a file and it was a consistent 90MB/s, no drops.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top