RT N66U - unable to upload John's Merlin Fork

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

jakeio012

New Around Here
I just tried to upload John's merlin fork on my ASUS RT N66U router however when I clicked upload nothing happened... It would say please wait while we apply the settings then nothing. It would return to the administration page with the file still in the upload area (un-uploaded).

The firmware I downloaded is the latest one released Dec 2020 - RT-N66U_374.43_46E8j9527.trx

The router is currently running ASUS firmware 3.0.0.4.382_52272

Could anyone help me with this?

Thank you!
 

L&LD

Part of the Furniture
You can't flash @john9527's RMerlin fork like that.

 

Jerom7

Occasional Visitor
It worked fine for me & my N66U with Asus restoration tools and a win10 laptop wired with network cable (as it is a version downgrade 382 to 374 LTS)...
I can help you if you're stuck.
Best,
 

wh7qq

Senior Member
You may need the Asus restoration tool or alternatively, the Mini-CFE Web server. An earlier upgrade of Asus-WRT complied with FCC dictates and removed the ability to upgrade (or downgrade, if you will) to forks using the older kernel (earlier versions allowed one to upgrade the transmitter power so they made it nearly impossible). Merlin, based on current Asus-WRT followed suit. I don't use Window$ or even have a copy of XP any longer so had to use the Mini-CFE...worked a charm. But please don't ask me how I got it...aging memory. It had something to do with button presses and powering down and up. I suppose I could get it by "hunt and peck" if I had to.
 

sebaaalecha

Occasional Visitor
I just tried to upload John's merlin fork on my ASUS RT N66U router however when I clicked upload nothing happened... It would say please wait while we apply the settings then nothing. It would return to the administration page with the file still in the upload area (un-uploaded).

The firmware I downloaded is the latest one released Dec 2020 - RT-N66U_374.43_46E8j9527.trx

The router is currently running ASUS firmware 3.0.0.4.382_52272

Could anyone help me with this?

Thank you!
Hi, you can do it work with the last version of John's Merlin fork?
 

Adooni

Senior Member
You can do that. You need to look in internet for firmware for your router older than soft on official Asus web. Asus removed all those soft that did not have protection. You can out old AsusWRT soft via Asus Firmware restoration and then from it just do what you want.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top