SSD in USB 3.0 port of Asus RT-AC87 always unmounted

badstuff9

Occasional Visitor
I am trying to attach a new external 1TB SSD (exFAT format) via the USB 3.0 port on an Asus RT-AC87 router with Asus firmware version 3.0.0.4.382_52545. This external SSD does not have its own power supply, if that matters.

The Asus router "sees" the attached drive, but won't mount it, the Asus router keeps reporting that it is unmounted. I don't know what to do to make it mount.

A previously attached drive did not have this problem.

I don't know what to do.

Why is it having this problem? What must I do to fix this?

If it matters for the steps for a solution: My computer is running Ubuntu Bionic.
 

Tech9

Part of the Furniture
exFAT is Microsoft proprietary file system. As far as I remember, the router sees FAT32, NTFS and Linux file systems. Ubuntu can read/write NTFS, so if you want to make the SSD more compatible, you can use NTFS. Otherwise it won't be visible in Windows.
 

Jeffrey Young

Very Senior Member
Did you check the logs to see what they had to say?

I had a SSD drive doing the same thing. Would not mount on router boot, but mouted fine when plugged in after the router booted.

After researching the error message in the logs (I forget what exactly it said now), and googling the SSD brand, it turned out that my particular SSD drive does not start up fast enough for the router's auto-mount stuff.

Switched to a higher quality SSD drive mentioned on this site and no issues. Later, I added a hub where the old SSD drive can power up faster (powered before the router turns on), and the drive worked as well on boot.

Point being, check the logs to see what is being reported.
 

Jeffrey Young

Very Senior Member
@badstuff9

As it happens, I undertook the exercise of trying to get my SSD drive, which is a JMS567 SATA 6Gb/s bridge JMicron drive to wok as a boot device for my Raspberry Pi 4.

The project worked for the most part, except that the Pi would hang on a reboot. Booted fine on a cold start.

After a few hours of troubleshooting, I learned that the Pi has issues with SATA SCSI Protocols (UASP). I was able to solve with the Pi through quirks (basically disable UASP and live with the performance hit).

That got me thinking about my experience with this drive and my RTAC86U. The 86U would mount the drive OK when I hot pluged the drive, but the router would not mount the drive on a boot (either warm or cold). After doing a quick look around here on the forums, I found this article on using TRIM to disable UASP on the router.

This may or may not be a solution. I can't test it as my SSD is now my boot drive for my PI (I am OK with taking the performance hit - still faster than the SD card and gives the storage I need). For me, it is a lessoned learned purchase.

 
  • Like
Reactions: Sky

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top