[Thread-1] [ 386.1_Alpha Build(s) ] Testing available build(s)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

LimJK

Senior Member
https://onedrive.live.com/?authkey=!AGY2taGX02nVmWA&id=CCE5625ED3599CE0!1427&cid=CCE5625ED3599CE0

NEW ALPHA BUILDS date (2020-11-03)

Available build(s)
RT-AC3100
RT-AC5300
RT-AC68U
RT-AC86U
RT-AC88U
RT-AX56U
RT-AX88U

386.1 (xx-xx-xxxx)
Switched to the new 386 codebase. Models are going to
gradually be re-added to this new code base.
386 introduces AiMesh 2.0, finalizes the move to
OpenSSL 1.1.1 firmware-wide, adds a new speedtest
(powered by Ookla). For more details, please refer
to Asus's own release notes.

- NOTE: For developers, note that firmware code is
once again back on the master branch, with
both mainline and ax being reunified again.

- NEW: Added stub and stub-v2 compression options to OpenVPN
clients. Not added to server, since compression is
considered deprecated, and will be removed most likely
in OpenVPN 2.6, for security reasons.
- NEW: Added tls-crypt-v2 support to OpenVPN clients.
- UPDATED: Merged GPL 386_40577 (beta GPL from Asus).
- UPDATED: Openssl to 1.1.1h.
- UPDATED: Updated to OpenVPN 2.5.0. Note that OpenVPN
2.4.0 or newer is now required by the exported
client config file.
- UPDATED: nano to 5.2.
- UPDATED: curl to 7.72.0.
- UPDATED: zlib to 1.2.11.
- UPDATED: lz4 to 1.9.2.
- UPDATED: e2fsprogs to 1.45.6.
- CHANGED: firmware update checks are no longer using the
server address stored in nvram, for security
purposes. Devs who were using that nvram
should instead edit the webs_scripts/* to
use their own URL.
- CHANGED: The old legacy cipher setting is now only available
when running with static key authentication.
- CHANGED: Tweaks to the OpenVPN webui layout
- CHANGED: OpenVPN clients will now NAT all outbound traffic,
regardless of the source subnet.
- CHANGED: Reworked the display of DNSPrivacy presets
- CHANGED: Added AdGuard (ad blocking) and CIRA Canadian Shield
(non US-based service) to the DNSPrivacy presets.
- CHANGED: At boot time, OpenVPN killswitch will only be
applied for clients set to auto-start with WAN.
- CHANGED: Increased number of available mount points for addon
webpages to 20.
- FIXED: DHCP could fail to renew its lease with some ISPs when
Trend Micro engine was enabled (workaround provided
by Asus)
- REMOVED: Option to disable NCP. The NCP cipher list is
now used both for NCP and non-NCP endpoints.
- REMOVED: fq_codel support for Adaptive QoS. Due to a change
in how Trend Micro configures QoS, it is no longer
possible to intercept these to inject fq_codel.
Octopus,
Would you consider to add the download link to Merlin's Pre-Beta Test Builds (occasionally available), Thanks.
 

nzwayne

Regular Contributor
Dirty upgrade completed without error on RT-AX88U (was 384.19), which is AiMesh backhauled to two RTAC86U's (was 384.19) & RT-AX56U (was 384.18), usually around 30 clients.
After reading the changelog for "tips & must do's, converted the 3x downstream units first, before the RT-AX88U. On the RT-AX88U, logged off the USB drive first, before firmware load. After the message load was successful, router sat there with five lights on solid for about 90secs, then it rebooted itself. All scripts appear operational.
Great day to start the work day, thanks @RMerlin for all your awesome work.
 

Sonyrolfy

Regular Contributor
Dirty upgrade from 384.19 to RT-AC86U_386.1_alpha2. left USB attached and powered off and rebooted. I only have some warnings from the vpn clients: 'link-mtu' and 'keysize' are used inconsistently, but doens't bother me. Scripts eg diversion/skynet/x3mRouting are working fine. Uptime 0 days 0 hour(s) 38 minute(s) 25 seconds. Cool!
 

QuikSilver

Very Senior Member
@RMerlin can these alpha firmware(s) be used with the new Asus router app which includes Instant Guard?
 

L&LD

Part of the Furniture
@QuikSilver, as this is Alpha and we're here to test, try and let us know too! ;)
 

octopus

Very Senior Member
Not true. Had to format /jffs on AC66U_b1 with the alpha2 firmware.
If you need to reformat RT-AC66U_b1 then you have something else that needs reformat.

384.19 (14-Aug-2020)
- NOTE: Due to flash partitioning changes done by Asus, it is
strongly recommended to make a backup of your JFFS
partition before upgrading the RT-AC86U, and restoring
that backup afterward. If you run into issues,
reformat your JFFS partition and reboot.
 

LimJK

Senior Member
All seems to be running well for me, including:
  • AiMesh Router and 2x AiMesh Nodes
  • AiProtection is On, QOS is OFF
  • WAN with Asus DDNS and Let's Encrypt
  • VPN Servers are working (OpenVPN, IPSec VPN, Instant Guard) with my iPhone and MacBookPro
  • Guest WiFi
  • All my favourite scripts with AMTM
  • ASUS Router APP for iOS
Except I got thousands of "kernel: protocol 0800 is buggy, dev eth7" in my log that was not found in Stock RC2-7 9.0.0.4_386_40577

Edit: iOS Instant Guard (1.0.0.0.8) and Asus Router App (1.0.0.5.83) are TestFlight versions
 
Last edited:

RMerlin

Asuswrt-Merlin dev
RT-AC68U don't have 64k nvram.
size: 63465 bytes (2071 left)
The RT-AC68U only has 64K of nvram. You are getting the notification because you have less than 3 KB of nvram available.

@RMerlin can these alpha firmware(s) be used with the new Asus router app which includes Instant Guard?
Instant Guard should work in theory, but it's untested, and I cannot guarantee whether anything related to their mobile app will work properly, as it may be relying on the firmware version number to determine which feature to offer.

Except I got thousands of "kernel: protocol 0800 is buggy, dev eth7" in my log that was not found in Stock RC2-7 9.0.0.4_386_40577
It's a flowcache problem that's been there for me since the very first RC2 beta on the RT-AX88U. No idea what triggers it since it's related to the closed source hardware acceleration, and I haven't had time to test things out with the stock firmware. Only workaround for now is to disable flowcache:

Code:
fc disable
 

L&LD

Part of the Furniture
Not yet. :)
 

octopus

Very Senior Member
The RT-AC68U only has 64K of nvram. You are getting the notification because you have less than 3 KB of nvram available.
Okey, I dont remember it its was 32k before 386 builds, anyway it's something eating nvram.
Same config have ~5700bytes free nvram on 384 build.

I found this, size: 60013 bytes (5523 left) latest nvram usge I have.

[email protected]:/tmp/home/root#
size: 63466 bytes (2070 left)
931 nc_setting_conf
840 custom_clientlist
628 dhcp_staticlist
557 rc_support
542 dhcp_hostnames
326 vpn_client3_cust2
326 vpn_client1_cust2
325 vpn_client_cust2
287 vpn_client_custom2
214 MULTIFILTER_MACFILTER_DAYTIME_V2
213 cfg_relist
205 wl1_chansps
182 vpn_server2_cust2
181 vpn_server_cust2
176 sshd_authkeys
166 subnet_rulelist
164 asus_device_list
148 vpn_client1_clientlist
147 vpn_client_clientlist
142 vpn_client2_cust2
129 wps_env_buf
120 qos_rulelist
112 vlan_rulelist
105 cfg_device_list
92 1:pa5ga2
92 1:pa5ga1
92 1:pa5ga0
83 vpn_server_custom2
77 sta_binding_list
71 vpn_server1_ncp_ciphers
 

LimJK

Senior Member
@RMerlin can these alpha firmware(s) be used with the new Asus router app which includes Instant Guard?
QuikSilver,

I have tested both TestFlight versions of iOS Instant Guard (1.0.0.0.8) and Asus Router App (1.0.0.5.83) on 386.1 Alpha2. Working like in RC2-7 9.0.0.4_386_40577
 

det721

Part of the Furniture
Just flashed 386.1 A2. Formatting the JFFS partition does not work always comes back unmounted with blinking ! mark. Factory reset fixes the issue and JFFS is mounted again. Also noticed the WAN MTU needs to be set manually is this by design or possibly because i set up the router with no internet connection ?
 

skeal

Part of the Furniture
Everything seems to work well enough, except I have a OVPN log error I know nothing about.

Code:
Nov  3 11:03:06 RT-AX88U-9D28 ovpn-client1[25731]: sitnl_route_save: rtnl: can't get ifname for index 0: No such device or address (errno=6)
Any ideas guys?
 

laracroftonline

Regular Contributor
on AC5300 i can't see the wireless connected devices on the frontpage thats the only bug i encountered so far.
 

brianward317

Occasional Visitor
So far so good. Not sure if this is a cosmetic issue or not, but my node rt-3100 shows like it's disconnected, but clients are connected to it and working. My 68 model seems to show connected fine and clients are connected. See attached. I have tried bypassing the switch and plugging everything direct into it to see if it changed.
 

Attachments

JWoo

Senior Member

brummygit

Senior Member
Having tried the Official Beta I'm really keen to give this Alpha a try on my RT-AX88U. Has anyone tested if Cake will run yet?
 
Status
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top