What's new

Trying to add second AiMesh Node - Need Help

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I am trying to add a second AiMesh node to my home network and I have been FRUSTRATINGLY unsuccessful.
My existing network setup has worked flawlessly for me, but I've added Ring cameras to the network and need a stronger signal for some cameras. See below for current network configuration.

So, I decided to add another AiMesh node.

I purchased a used RT-AC66U_B1 router for $11. It is in pristine shape. I'm hoping the router isn't bad. It boots up fine and I'm able to connect to it via its SSID, I can view its web configuration pages.
I reset the router to factory default and updated the Firmware to the current Asus firmware dated 03/02/2023.

Initially, I was able to successfully add the AiMesh node via an Ethernet connection.
But I wanted the node to be connected via Wi-Fi so after adding the node, I unplugged the Ethernet cable thinking the new AiMesh node would automatically connect to Wi-Fi but, it never connected to Wi-Fi. I thought I might have missed some setting in setup that would prevent the AiMesh node to connect via Wi-Fi, so I then deleted the new node via the Asus web interface and attempted to add the node again. Since that first and only successful add node, I have not been able to successfully add the AiMesh node again.

I have rebooted my main router and reset the new AiMesh node to factory defaults several times and NOTHING SEEMS TO HELP.

I have tried every approach I could find on the internet, viewed several YouTube videos and still no success.
I'm at a loss and looking for expert help.

Thank you.
Ed V

My Current network configuration is:
Main Router:
Model: RT-AC68U
Firmware: Merlin 386.9
current AIMESH node:
Model: RT-AC68U
Firmware: Merlin 386.9 - I have read about problems people have had when running Merlin Firmware on AIMESH nodes, but my setup has performed flawlessly for over 6 months.
Backhaul: Ethernet
RT-AC66U_B1 (Note - The B1 model version is AiMesh capable)
Firmware - ASUS FW_RT_AC66U_B1_300438651255 (Latest Release 03/02/2023)

I have tried to add this new node via Wi-Fi and via ethernet cable too many times to count.
Sometimes the AIMESH node is found and sometimes not found.
After every unsuccessful attempt to add the node, I do a factory reset on the node before attempting to add again.

When I ADD NODE VIA WI-FI: The AiMesh node is found frequently after clicking on Search button or Add AiMesh node button.
When the node is found via WIFI, here's what happens:
After node is found, I click on the box showing the "found" Wi-Fi node and the Percentage indicator will move from 0% to 1% and pause for about 3 seconds, then the percentage indicator moves to 2% and then races (takes about 4 seconds) to 100% (this happens every single time) and displays a dialog saying:
Unable to add node RT-AC66U B1
(7C:10:C9:00:xx:xx) to your Ai Mesh system due to the
following situations. Please check and try again.
1. Someone else is trying to set up an AiMesh system. Please
wait 1 minute and try again. (NOBODY ELSE IS ON MY NETWORK)
2. your AiMesh router and node should be within 3 meters of
each other during the setup process (THEY ARE-I've tried closer, and farther away)
3. Make sure your AiMesh node is powered on. (IT IS POWERED ON)
4. Your AiMesh node has been upgraded to AiMesh-supported
5. Your AiMesh node has been reset to default (I RESET BEFORE EVERY ATTEMPT)


When I ADD NODE VIA ETHERNET: This has rarely found the node via Ethernet. When it finds the node via ethernet, here's what happens:
After node is found, I click on the box showing the "found" ethernet node and the Percentage progress indicator will move from 0% to about 18% slowly and then races (takes about 3 seconds) to 100% and displays the same dialog as with the Wifi above.

Last edited:
I am wondering if maybe the successful first time adding of this Ac66U node and my subsequent removal of the node maybe left some setting in NVRAM related to trying to add an aimesh node. Maybe that leftover setting is now causing subsequent add node attempts to fail.

Does anyone know what settings are created in NVRAM when a new aimesh node is added?
Read this and decide what you want to do:

I wonder if its because the ac66u_b1 has a default wifi encrypted password enabled that makes this more tricky that other nodes. Because I can't connect to the ac66u_b1 with my laptop when i set it as a aimesh node without providing its default wifi password. Or maybe the aimesh router is connecting to the ac66u_b1 over another interface?

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!