330/110 Fiber - Best and easiest QoS settings to manage bufferbloat?

zakazak

Occasional Visitor
Hello guys,

I am running a ASUS RT-AX86U via fiber connection with 330mbit/s download and 112mbit/s download.
My provider states that the usual speed should be 275/78 mbit/s and the absolute minimum should be 225/56 mbit/s.
So far I had a smaller package with the same provider and always managed to max out the speed, so I will see if that still works out fine with the new 330/112 connection.

Usually I have connected:
  • Homeserver / HTPC (~1.500 Torrents, syncthing for local network backups, emby for local network streaming)
  • 2x Smartphone
  • 1x Xbox (Gaming)
  • 1x PC (Gaming)
  • 1x Laptop (Homeoffice)
  • SmartTV (which shouldn't cause much external traffic, only local network)
  • Router with VPN Server running
Torrents are restricted to upload speed (but not download speed) during the day. I allow full upload speed during night times.
Typical scenarios during a day include, downloading large files, gaming, seeding some torrents on low upload speeds, video calls during work at home, browsing internet, watching youtube.
At the same time local network operations might be happening (streaming music/video from server to TV, doing backups from all smartphones and laptops,...).
The VPN is getting rarely used.

I do not want to through the hassle of configuring every device and service in my network.
So I thought it might be just fine using fq_codel and setting 85% of maximum available download/upload speed.
I might be able to prioritize several devices (e.g. laptop > PC > xbox > smartphone > router > Homeserver > SmartTV) if that is useful?
Or is there a better approach?

Thanks!
 

geobernd

Regular Contributor
FlexQoS (see the thread here https://www.snbforums.com/threads/f...os-enhancement-script-for-adaptive-qos.75620/ ) should work without a lot of configuration. fq_codel without FlexQoS has a bunch of shortcomings that Flex fixes...
Start at 85% of sustained speeds - if your provider deliverys full speed 100% of the time you may be able to go up further (I have set 200/200 on a 209/209 connection and it works great)....

Don't prioritize a lot of stuff manually and see how well the classification engine works first...
Also: Do not use device priorities... Use the custom config in the FlexQoS tab do achieve the same. I have found device priorities not to work well...
 

zakazak

Occasional Visitor
FlexQoS (see the thread here https://www.snbforums.com/threads/f...os-enhancement-script-for-adaptive-qos.75620/ ) should work without a lot of configuration. fq_codel without FlexQoS has a bunch of shortcomings that Flex fixes...
Start at 85% of sustained speeds - if your provider deliverys full speed 100% of the time you may be able to go up further (I have set 200/200 on a 209/209 connection and it works great)....

Don't prioritize a lot of stuff manually and see how well the classification engine works first...
Also: Do not use device priorities... Use the custom config in the FlexQoS tab do achieve the same. I have found device priorities not to work well...

Thanks for your feedback.
And what should I choose if I dont want to install amtm or anything like it? Just using stock merlin wrt.

I noticed that I am currently simply using "cake" with automatic setting.
 

geobernd

Regular Contributor
amtm is already part of Merlin - check the FlexQoS thread for more details and alternative installation methods...
 

kernol

Very Senior Member
I suggest you simply stick to the suplied Cake-Qos within the firmware.
Try it with speed settings at 100% of your supplied capacity 112up and 330 down [Cake will throttle a small amount - no need for you to]
I have 125up and 250down fibre and always get A+ for Bufferbloat with near full speeds both up and down.
Cake-bufferbloat-125-200.png

EDIT: Test here ... https://www.waveform.com/tools/bufferbloat
 

zakazak

Occasional Visitor
amtm is already part of Merlin - check the FlexQoS thread for more details and alternative installation methods...

Oh crap. Thanks for correcting me.
I have FlexQoS installed now.

In Adaptive QoS:
I have selected "adaptive qos" with "customize" as mode.
I also set it to "manual" settings and converted the mbit/s results from speedtest.net to Mb/s and set ~88% of my max speed.
Edit: No need to convert. It says Mb/s but it actually needs mbit/s values.

In FlexQoS:
Which WAN packet overheard should I select for fiber 330/110?
ATM checked or unchecked?
Enable conntrack flushing - yes or no?
Router/VPN Client Outbound Traffic Class - Is set to streaming (I mostly use it for streaming or websurfing)
For the well known iptable rules I will not add anything for now and keep it at stock?
 
Last edited:

sl4fko

Regular Contributor
Just a (shower) thought...

Could be the best QoS solution just by setting 2.4 GHz radio on and connect to it every client (of course, if there are not too many of them to fill the radio bandwidth...)? All of them would be limited to 72 Mbps in that case.

I mean, 72 Mbps (or 144 in 40 MHz) is more than enough for everyday use and 4K streaming even...


Ideas?
 

zakazak

Occasional Visitor
I suggest you simply stick to the suplied Cake-Qos within the firmware.
Try it with speed settings at 100% of your supplied capacity 112up and 330 down [Cake will throttle a small amount - no need for you to]
I have 125up and 250down fibre and always get A+ for Bufferbloat with near full speeds both up and down.
View attachment 45353

EDIT: Test here ... https://www.waveform.com/tools/bufferbloat

From what I read, cake doesn't support hw acceleration and there for uses more CPU.
It seems to be recommended to only use cake on speeds below 250mbit/s.
For everything above 250mbit/s flexqos seems to be recommended?
 

kernol

Very Senior Member
From what I read, cake doesn't support hw acceleration and there for uses more CPU.
It seems to be recommended to only use cake on speeds below 250mbit/s.
For everything above 250mbit/s flexqos seems to be recommended?
AFAIK under latest firmware FlexQos on RT-AX86U no longer holds on to hardware acceleration - see recent posts in the Add-Ons section.
I was a long time user of FlexQos until Cake was embedded in the firmware - and, given my speed cap of 250Mbps - I'm a happy camper.
Much more to play with in FlexQos - so if tinkering is appealing ... go for it. ;).
 

geobernd

Regular Contributor
Oh crap. Thanks for correcting me.
I have FlexQoS installed now.

In Adaptive QoS:
I have selected "adaptive qos" with "customize" as mode.
I also set it to "manual" settings and converted the mbit/s results from speedtest.net to Mb/s and set ~88% of my max speed.
Edit: No need to convert. It says Mb/s but it actually needs mbit/s values.

In FlexQoS:
Which WAN packet overheard should I select for fiber 330/110?
ATM checked or unchecked?
Enable conntrack flushing - yes or no?
Router/VPN Client Outbound Traffic Class - Is set to streaming (I mostly use it for streaming or websurfing)
For the well known iptable rules I will not add anything for now and keep it at stock?
QoS Mode fq_codel
ATM unchecked
No WAN packet overhead (at least for my Fiber here)
Conntrack Flushing - yes

I would not add anything to table rules for now and see how well it works first...

With regards to the other comments: I haven't played much with Cake so I am just sharing what works for me - maybe Cake is working just as well and requires less tinkering :cool:
 

zakazak

Occasional Visitor
AFAIK under latest firmware FlexQos on RT-AX86U no longer holds on to hardware acceleration - see recent posts in the Add-Ons section.
I was a long time user of FlexQos until Cake was embedded in the firmware - and, given my speed cap of 250Mbps - I'm a happy camper.
Much more to play with in FlexQos - so if tinkering is appealing ... go for it. ;).
Your router can do 350Mbps (or a bit more) with Runner and Flow Cache disabled (NAT acceleration). Use the built-in Cake QoS.

Thanks guys, I will try Cake then and compare it to FlexQoS.
I guess I should also set my bandwith to ~90% manually with Cake and not use the "automatic" setting?
Given that I will have a 330/110 connection (and that even 200/60 would be fast enough for me) it might propably be wiser to set bandwith to smth like 75%? Just to be sure to never face any bufferbloat/bottleneck even if my connection is under lots of traffic?

One more thing I wonder about:
Since cake already consumes a lot of CPU with a 330mbit connection, will my router be overloaded by additionally using OpenVPN, DNSCrypt, Firewall, Port Forwarding, and a shirt ton of connections due to torrenting?
 

zakazak

Occasional Visitor
QoS Mode fq_codel
ATM unchecked
No WAN packet overhead (at least for my Fiber here)
Conntrack Flushing - yes

I would not add anything to table rules for now and see how well it works first...

With regards to the other comments: I haven't played much with Cake so I am just sharing what works for me - maybe Cake is working just as well and requires less tinkering :cool:

Oki, I had WAN packet overhard at "18" and did a few tests yesterday.
Could only reach "B" rating. But I will keep trying around and also compare it to cake today.
 

geobernd

Regular Contributor
Oki, I had WAN packet overhard at "18" and did a few tests yesterday.
Could only reach "B" rating. But I will keep trying around and also compare it to cake today.
I wouldn't focus too much on the rating. Run a ping test on a hardwired computer while you are testing
something like
Code:
ping -n 1000 google.com
and see how much the latency changes loaded vs unloaded...

And most important: Try the things that suffer with bufferbloat and see if they are still a problem. If they aren't it's "good enough"... (I am guilty of not leaving good enough alone so I have to remind myself of that sometimes too...)
 

zakazak

Occasional Visitor
I wouldn't focus too much on the rating. Run a ping test on a hardwired computer while you are testing
something like
Code:
ping -n 1000 google.com
and see how much the latency changes loaded vs unloaded...

And most important: Try the things that suffer with bufferbloat and see if they are still a problem. If they aren't it's "good enough"... (I am guilty of not leaving good enough alone so I have to remind myself of that sometimes too...)

I tried your ping method and also the bufferbloat test websites.

So far cake gives me the fastest and most consistent results.
With cake, my ping doesn't change at all when running e.g. speedtest.net at the same time.
Cake in "automatic" settings already works pretty good. But I get the best results with "manual" and setting the speeds to 95%.

I have no idea thought about what settings I should set for:
Wan packet overhard: 18
MPU: 64
Mode: Normal/ATM/PTM

I have GPON FTTH 330/100mbit/s fiber connection :S
 

kernol

Very Senior Member
Thanks guys, I will try Cake then and compare it to FlexQoS.
I guess I should also set my bandwith to ~90% manually with Cake and not use the "automatic" setting?
Given that I will have a 330/110 connection (and that even 200/60 would be fast enough for me) it might propably be wiser to set bandwith to smth like 75%? Just to be sure to never face any bufferbloat/bottleneck even if my connection is under lots of traffic?

One more thing I wonder about:
Since cake already consumes a lot of CPU with a 330mbit connection, will my router be overloaded by additionally using OpenVPN, DNSCrypt, Firewall, Port Forwarding, and a shirt ton of connections due to torrenting?
As I said in my earlier post - don't bother to reduce your up and down settings for Cake - just set them at your ISP's provided rate.
NB - I have PPPoE Fibre connection and these are my Cake-Qos settings ... NB - the speed settings are exactly what my ISP provides - but on download I bumped the setting up from 250 to 260 and still get A+.

Cake-bufferbloat-125x260.png

If you make use of the GeoForce NOW control - you may wish to enable it [I don't] and your WAN Packet overhead settings may need to be different to mine - but these settings give me an A+ Bufferbloat rating ...
https://www.snbforums.com/threads/3...tings-to-manage-bufferbloat.81706/post-800610

NB - see my signature for all the scripts I run - and my RT-AX86U cruises along without breaking into a sweat at all.
 

zakazak

Occasional Visitor
As I said in my earlier post - don't bother to reduce your up and down settings for Cake - just set them at your ISP's provided rate.
NB - I have PPPoE Fibre connection and these are my Cake-Qos settings ... NB - the speed settings are exactly what my ISP provides - but on download I bumped the setting up from 250 to 260 and still get A+.

View attachment 45365

If you make use of the GeoForce NOW control - you may wish to enable it [I don't] and your WAN Packet overhead settings may need to be different to mine - but these settings give me an A+ Bufferbloat rating ...
https://www.snbforums.com/threads/3...tings-to-manage-bufferbloat.81706/post-800610

NB - see my signature for all the scripts I run - and my RT-AX86U cruises along without breaking into a sweat at all.

Thank you! Highly appreciated :)

May I ask how and why you came to those settings? I tried to find and understand what wan packet overheard and MPU actually mean but this is over my head.
 

kernol

Very Senior Member
Thank you! Highly appreciated :)

May I ask how and why you came to those settings? I tried to find and understand what wan packet overheard and MPU actually mean but this is over my head.
Believe me - WAN packet overhead it is way over my head too ;) ... so I simply selected the default drop down option for "Ethernet with VLAN" which I gather is what my particular ISP serves up [and I make use of VLAN within my LAN anyway to handle VOIP - but done through a modest HP switch, not the Asus Router]. I see I may have accidentally bumped up the default from 42 to 48 ... so just reset to 42 / 84 ... bufferbloat result the same as before.
You might need to stick to the default for Cable [DOCSIS] which I believe is 18 and 64.
 

kernol

Very Senior Member
@zakazak - just to test I re-installed FlexQos via amtm menu item 3 and used same settings I had used moons ago before switching to Cake.
The Tools Tab page clearly showed for HW Acceleration that both Runner and Flow cache were enabled.

However - I got LOTS of these error message lines - suggesting that Flow Cache was buggy [to put it mildly] ..
Code:
kernel: [0;33;41mFCACHEfc_vblog_list_add ERROR: Duplicate blog: list blog<0xffffffc02f8b24c0> JOIN blog<0xffffffc02f8b1300>[0m
The log file was being filled with these "Duplicate blog" lines.

What is more curious is that even after uninstalling FlexQos and reverting to Cake - the above Flow Cache errors continued to show up - even after reboots and power off and power on.

The only way to get back to a clean install for me was to factory reset [and WPS button reset] - then load my Config Settings from saved backup before my games with FlexQos started - as well as reformat JFFS partition and restore my JFFS backup taken before FlexQos install.

Only after all that am I back to clean logs :D. You should perhaps check your logs for FCACHE Error entries?
If you get these running Cake - then there may be some carry over from the FlexQos install/uninstall :(
The solution is as above provided you made a Config settings and JFFS backup before you installed FlexQos the first time.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top