AC68U OpenVPN server won't allow more than one credentialed user...

erkme73

Occasional Visitor
Under the Merlin firmware (386.2_beta1), under VPN/OpenVPN server, I've successfully generated and applied the ovpn config files and they work perfectly on multiple android devices (using openvpn connect) - however, I am only able to save a single username/password credential set under the Asus-Merlin server page. The page says "Username and Password (max limit: 32)"

While I see a default one (with my router admin user account), and the one I created for myself, when I try to add a third one, it vanishes as soon as I click "apply".

I fill out the creds, click the "+" icon, at which point the new creds are shown in the list with the existing two, and then I click "apply". When it comes back from the "updating" box, the new one is gone.

I've tried this with VPN connected, disconnected, cleared to defaults, rebooted router - all of them limit me to a single account.

Is this a limitation of the router or VPN that I can only have a single VPN client account?
 

sferinga

New Around Here
Under the Merlin firmware (386.2_beta1), under VPN/OpenVPN server, I've successfully generated and applied the ovpn config files and they work perfectly on multiple android devices (using openvpn connect) - however, I am only able to save a single username/password credential set under the Asus-Merlin server page. The page says "Username and Password (max limit: 32)"

While I see a default one (with my router admin user account), and the one I created for myself, when I try to add a third one, it vanishes as soon as I click "apply".

I fill out the creds, click the "+" icon, at which point the new creds are shown in the list with the existing two, and then I click "apply". When it comes back from the "updating" box, the new one is gone.

I've tried this with VPN connected, disconnected, cleared to defaults, rebooted router - all of them limit me to a single account.

Is this a limitation of the router or VPN that I can only have a single VPN client account?
Hey, I have exactly the same problem with my Asus RT-AX3000. It was working fine (multiple users configured and connecting in openvpn) up until this week when the rest of the users just vanished! I haven't updated or changed anything on the router. It's using stock firmware, which leads me to believe it's something has changed or updated in the background?

Did you manage to resolve it?

BTW - i have the same issue with PPTP users as it will only allow me to add 1 user even though it supports up to 16. : /
 

erkme73

Occasional Visitor
No, unfortunately. And based on the lack of replies, I felt like it was probably just unique to how I set things up. In my case, I'm using this at home - so having multiple credentialed users isn't critical. I just wanted to have a unique one for myself and my wife. For now, we're just both using the same.

What is odd is that the password I've set for my user credential was a simple one I can remember. But after saving, applying, and rebooting, the password changes to some 30+ random-character string. It's as though it's being obfuscated, since on the client device, I can enter my simple password and it still works.
 

RMerlin

Asuswrt-Merlin dev
That was a bug in the beta, and fixed in the 386.2 final release.

That's why beta feedback needs to stay in the beta thread - the issue was reported and discussed in the beta thread.
 

erkme73

Occasional Visitor
That was a bug in the beta, and fixed in the 386.2 final release.

That's why beta feedback needs to stay in the beta thread - the issue was reported and discussed in the beta thread.

Ah, sorry @RMerlin, I didn't realize that thread existed. Will head over there. Thanks for the reply.
 

RMerlin

Asuswrt-Merlin dev
The Beta ended over a month ago.

 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top