• ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JohnD5000

Senior Member
Something I'm not clear on a dirty flash: Is it better to reboot, then dismount the usb drive and flash firmware, or dismount, reboot, then flash?
OK, this is definitely not best practice, but I just dirty upgrade, no dismount USBs (I have 2 attached) nor disconnect. It usually just works. So, I wouldn't worry about it. Been doing this on RT-AC68U and later RT-AC86U). Also, every now and then (say every 10 dirtys), I'll do a rebuild from scratch. Also, like many here, I load alphas and betas when available, not just release.

I also save a copy of the settings and JFFS partition before each flash, so I can always go back if something goes wrong.

Probably should unmount, though.
 

mruk30

Occasional Visitor
I cannot login to the router. I enter logs and after entering the password there is an error. Can anyone help.
 

Attachments

  • 1zle.png
    1zle.png
    422.5 KB · Views: 34
  • zle2.png
    zle2.png
    361.4 KB · Views: 34
  • zle3.png
    zle3.png
    47.7 KB · Views: 33

L&LD

Part of the Furniture
@mruk30, what router? What firmware? Be specific. When were you able to last log in? Have you upgraded the firmware lately? Does a reboot help? Have you tried copying and pasting the password that gets you into the GUI, into the ssh login?

Does your password have more than 16 characters? Are the characters alphanumeric without any special characters, spaces, punctuation, or smiley faces?

Have you tried changing the password in the GUI and copying/pasting that (with the restrictions above) into the ssh login?

What are you using to enter ssh?

Have you cleared any caches/rebooted the computer you're using to access the router with?

More details (particularly important details) never hurt.
 

mruk30

Occasional Visitor
@mruk30, jaki router? Jakie oprogramowanie? Być specyficznym. Kiedy udało Ci się ostatnio zalogować? Czy ostatnio aktualizowałeś oprogramowanie? Czy ponowne uruchomienie pomaga? Czy próbowałeś skopiować i wkleić hasło, które przenosi Cię do GUI, do loginu ssh?

Czy Twoje hasło ma więcej niż 16 znaków? Czy znaki są alfanumeryczne bez znaków specjalnych, spacji, interpunkcji lub uśmiechniętych buźek?

Czy próbowałeś zmienić hasło w GUI i skopiować/wkleić je (z powyższymi ograniczeniami) do loginu ssh?

Czego używasz do wpisywania ssh?

Czy wyczyściłeś pamięć podręczną/zrestartowałeś komputer, z którego korzystasz, aby uzyskać dostęp do routera?

Więcej szczegółów (szczególnie ważnych szczegółów) nigdy nie zaszkodzi.
thx, its ok
 

L&LD

Part of the Furniture

bsod

Regular Contributor
Thank you for this guide!

I have a frustrating problem. Perhaps someone has encountered similar?

I've been having a strange issue with my USB 2 port (power side) on my AC-86U running the latest Merlin firmware.

I have two flash drives hooked up, both prepared according to the guide. The one inserted into the USB 3 port is my main data drive and the other contains my swap file.

The router is set to USB 2 mode and all drives I've tried are USB 2 also. Each time the drive is formatted to ext4 in amtm and the swap is also created in amtm.

The swap drive always disappears after one or two reboots and is nowhere to be found unless I manually unplug and plug it back in. The drive(s) I've used in that port successfully pass the disk check each boot until they are no longer detected and the following boot disk check doesn't check them anymore because they aren't detected.

At first I thought it was a faulty drive but I've tried 3 in that port now that all behave the same.

In the system log there are errors that mention 'device descriptor failed' but the deer drives work fine on other devices and work okay if I manually unplug and replug.

If I keep my swap file on the same drive as my installed apps it always works fine.

Everything is up to date in amtm and I'm running unbound, skynet and diversion. I have cronnon(sp) and ntp Merlin also.

What could be preventing me from using a second drive?
Is there even a point to me keeping my swap file on a different flash drive?
 

L&LD

Part of the Furniture
Glad the guide is still useful! You're welcome.

I'm going to guess a few things here that aren't 100% clear right now, please confirm or fix my assumptions!

What firmware is your RT-AC86U running?

Did you do the hotfix for amtm that @thelonelycoder recently released?

What scripts, features, and other customizations are you running on your router past the suggested defaults?

Is the main drive where the scripts live? Or do they live where the swap file is installed on?

What model and capacity drives are you using? Are you regularly and heavily using the 'data' drive? What is the normal use of the data drive?

Are the two drives using more power (combined) than the USB ports can deliver (at their max)? What are the specs for the drives? Particularly with regards to power (maximum).

Not all USB drives are compatible with all Asus routers (even between Asus models, for some drives). Can you try different manufacturers to find a more compatible drive (this is hit or miss, there is no list to consult)?

How about using a UGreen external enclosure and an SSD instead? That option works the best, overall.

Depending on the answers to some of the questions above, your best path forward may be a dedicated NAS instead for the 'data' USB drive. But, let's cross that bridge if/when we get to it. :)
 

abir1909

Regular Contributor
This is a step-by-step guide that will show how to optimally set up a USB drive for Asus’ RMerlin powered routers that will at the very minimum allow for use of a swap file for your supported router. It will optionally install Entware properly too, all with the help of amtm by @thelonelycoder. The world of scripts will soon become child’s-play with these powerful tools and allow to make your network, more your own. :)

The full power and control this will give you over your network and clients have not fully been understood yet, but do not worry! Time will give to those who wait. In return, please consider any contribution you can to those that create and continue to support these scripts for us. They really and truly deserve our full support, including @RMerlin for providing such a powerful and stable platform for us to fully use and enjoy.

This guide will make a few assumptions to try to keep it as concise as possible. First, I am assuming that we are using a supported RMerlin Asus router. Second, I am assuming that your router is stable and is in a good/known state. Thirdly, I take no responsibility for what the following steps and scripts may potentially do to your router, your USB drive, or your network. Not that there is anything wrong with the steps or scripts as presented and used correctly, but I have no control over your use of these steps and scripts. Follow the steps closely, please ask questions if you need to ask, but the final decision and responsibilty to go ahead with this guide is yours alone. For support on these scripts, please use the appropriate thread that each developer has created for their script(s).

Hope this guide leads you a little more gently down the scripting path for some of the same rewarding discoveries I have found on it too. Let's begin.

Enable JFFS custom scripts and configs
  1. Go to Administration and select the System Tab
  2. Click 'Yes' to the 'Enable JFFS custom scripts and configs' option
  3. Click USB Mode option to use 'USB 2.0'
  4. Enable SSH to 'LAN Only'
  5. Change SSH Port to '51111'. (Example port number)
    1. We want to use a different 'default' than Port '22'
    2. Anything between '49152 - 65535' is allowed for Dynamic and/or Private Ports
  6. Make sure 'Allow Password Login' is 'Yes'
  7. Set 'Enable SSH Brute Force Protection' to 'Yes'
  8. Finally, make sure to hit the Apply Button at the bottom of the screen
Now, reboot the router, after it has booted up, wait at least 10 minutes for it to settle.
The CPU cores will be mostly idle when it is ready.

Hi L&LD,
thanks for the detailed tutorial.
I have 1TB external drive that I want to use for Swap file and also SMB server. should i format two partitions or? (the recommendation is 1) but with the given situation what would you recommend? also, Ext4, right? Thank you
 

L&LD

Part of the Furniture
I would not recommend using the router as a file server at all. A NAS is highly recommended.

It may help to post your router model and firmware version too, along with the expected use of that SMB server. But I would not count on the recommendation changing.
 

abir1909

Regular Contributor
I would not recommend using the router as a file server at all. A NAS is highly recommended.

It may help to post your router model and firmware version too, along with the expected use of that SMB server. But I would not count on the recommendation changing.
Thanks for the quick reply.
I have AX86U Asus Merlin 386.3_2. Would it make any difference?
 

L&LD

Part of the Furniture
And the expected use?
 

L&LD

Part of the Furniture
No. But depending on how it was used, specifically, it may be alright for you.
 

abir1909

Regular Contributor
No. But depending on how it was used, specifically, it may be alright for you.
ok. going back to my 1st question. should I format in 1 partition or more? or it doesn't make a difference?
partition 1 system
partition 2 smb
or?
thanks
 

L&LD

Part of the Furniture
Details matter. I'm still waiting for my questions to be answered. :)
 

L&LD

Part of the Furniture
How much data is moved each time? Kb, MB or GB's?
 

L&LD

Part of the Furniture
Yes, I would not use the router like that. If you depend on the network to be stable and reliable.

To answer your question above, two partitions.

Good luck.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top