Beta ASUSWRT 386 RC3-3 public beta for IPv6 DDNS and IPv6 VPN server

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

LimJK

Very Senior Member
@ASUSWRT_2020 how do we get IPv6 DDNS in this firmware ??
sanke1,

Have you check WAN -> DDNS page where you can find the lookup link
http://iplookup.asus.com/nslookup.php

I did that on my GUI, I see both IPv4 and IPv6 address for my DDNS domain. I am using Asus DDNS. Hope it helps

PS: I just turn on IPv6 by setting it as NATIVE and
I found the following in my syslog ... I don't understand what it means ... I remove information that I thought is personal and replaced it with [comments in square brackets]

Code:
Nov 24 10:33:02 start_ddns: eth0 has not yet obtained an ipv6 address
Nov 24 10:33:02 modprobe: module ip6t_REJECT not found in modules.dep
Nov 24 10:33:02 modprobe: module ip6t_ROUTE not found in modules.dep
Nov 24 10:33:02 modprobe: module ip6t_LOG not found in modules.dep
Nov 24 10:33:03 modprobe: module ip6t_REJECT not found in modules.dep
Nov 24 10:33:03 modprobe: module ip6t_ROUTE not found in modules.dep
Nov 24 10:33:03 modprobe: module ip6t_LOG not found in modules.dep
Nov 24 10:33:04 dhcp6 client: bound address [My IPv6 address]/128, prefix [My IPv6 prefix]/64
Nov 24 10:33:04 rc_service: dhcp6c 8244:notify_rc restart_ddns
Nov 24 10:33:04 start_ddns: update WWW.ASUS.COM [email protected], wan_unit 0
Nov 24 10:33:04 start_ddns: Clear ddns cache.
Nov 24 10:33:04 start_ddns: Start Inadyn.
Nov 24 10:33:04 inadyn[8548]: In-a-dyn version 2.8.1 -- Dynamic DNS update client.
Nov 24 10:33:04 inadyn[8548]: Update forced for alias [my dons domain name].asuscomm.com, new IP# [my IPv4 address]
Nov 24 10:33:04 inadyn[8548]: eth0 ipv6 address=<[my IPv6 address]>
Nov 24 10:33:04 inadyn[8548]: alias address=<[my IPv4 address]>
Nov 24 10:33:04 inadyn[8548]: request<GET /ddns/update.jsp?hostname=[my dons domain name].asuscomm.com&myip=[my IPv4 address]&myipv6=[my IPv6 address]&model=RT-AX88U&fw_ver=9.0.0.4.386_57317-gd068439 HTTP/1.0^M Authorization: Basic [my some string that I removed]^M Host: ns1.asuscomm.com^M User-Agent: inadyn/2.8.1 https://github.com/troglobit/inadyn/issues^M ^M >
Nov 24 10:33:05 inadyn[8548]: [response_update]HTTP/1.1 200 OK^M Date: Wed, 24 Nov 2021 02:33:05 GMT^M Server: Apache^M Content-Length: 0^M Connection: close^M Content-Type: text/html; charset=UTF-8^M ^M
Nov 24 10:33:05 inadyn[8548]: Updating cache for [my dons domain name].asuscomm.com
Nov 24 10:33:05 ddns: ddns update ok
 
Last edited:

dmtg

Occasional Visitor
This firmware RT-AX88U the ddns dynamic is not working

Nov 22 20:03:12 start_ddns: eth0 has not yet obtained an ipv6 address

and i have ipv6 ative and working but thhe ddns dynamic not update the ipv6 and ipv4
My isp provider is Meo and ipv6 prefix is /56 and Native is atived, in ddns no-IP not working say no ipv6 and not update de ipv4
 

sanke1

Senior Member
sanke1,

Have you check WAN -> DDNS page where you can find the lookup link
http://iplookup.asus.com/nslookup.php

I did that on my GUI, I see both IPv4 and IPv6 address for my DDNS domain. I am using Asus DDNS. Hope it helps

PS: I just turn on IPv6 by setting it as NATIVE and
I found the following in my syslog ... I don't understand what it means ... I remove information that I thought is personal and replaced it with [comments in square brackets]
http://iplookup.asus.com/nslookup.php

This page doesn't even open for me.

I get error on DDNS page:

"The wireless router currently uses a private WAN IP address.
This router may be in the multiple-NAT environment and DDNS service cannot work in this environment."

Log error is :
Nov 24 21:29:33 start_ddns: ppp0 has not yet obtained an ipv6 address

I have zero clue on what basis have they tested IPv6 DDNS. The router doesn't even get it's own IPv6 address to begin with.
Huge bugfixes needed for this beta.

I tried with Asus and Noip DDNS both.

Image to show all my devices except RT-AX88U not getting IPv6 when IPv6 is set to native.
Screenshot 2021-11-24 213553.png
 
Last edited:

dmtg

Occasional Visitor
http://iplookup.asus.com/nslookup.php

This page doesn't even open for me.

I get error on DDNS page:

"The wireless router currently uses a private WAN IP address.
This router may be in the multiple-NAT environment and DDNS service cannot work in this environment."

Log error is :
Nov 24 21:29:33 start_ddns: ppp0 has not yet obtained an ipv6 address

I have zero clue on what basis have they tested IPv6 DDNS. The router doesn't even get it's own IPv6 address to begin with.
Huge bugfixes needed for this beta.

I tried with Asus and Noip DDNS both.

Image to show all my devices except RT-AX88U not getting IPv6 when IPv6 is set to native.
View attachment 37479
what is your ipv6 prefix ? 56 or 64 ?
 

LimJK

Very Senior Member
Tried the AX88. With both RC3-2 and RC3-3 my download speed goes from 940mbps to 530mbps. Revert back to latest GA then it goes back up again. Tried resetting config without any change. Only difference i see is wireguard is enabled on RC3 builds otherwise its the same config between versions.

On RC3-3 DoT no longer works. Just gives errors. Is fine on GA.
alskaer,
I can confirm that RC3-3
  • download speed from my MacBookPro with Wired Ethernet Connection goes from 950mbps to about 550mbps, I have 1gbps fibre subscription
  • DNS-over-TLS is also not working
I have also just moved back to RT_AX88U_3.0.0.4_386_45934, will come back when RC3-4 become available and these got fixed.
 

LoPro

Occasional Visitor
My ISP has a tunnel 6rd setup for ipv6 so I dont know if there’s any benefit in me risking an upgrade to RC3-3 when RC3-2 has been so good to me ?

My WAN ipv6 address ends with /30 ….

EDIT: … although, after having been remote with a live rc3-2 wireguard server connection for a day, wan Internet is usually down at the house when I return. Prompting a router reboot.

EDIT 2: Actually, the isp just started offering native IPv6 this summer without me noticing. This seems to work well on RC3-2 so I’m staying a bit as I’ve also turned to Tailscale for mesh remote networking.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top