[AX92U][DHCP]Cannot reach by hostname

LLeg0

New Around Here
Hello,

New to Asus routers (ex mikrotik hap ac2 but i wanted better wifi).
Obviously non-merlin firmware on this RT-AX92U;
Issue I have is I cannot reach computers inside my network via hostname when using WiFi;

AX92U is in router mode (PPPoE);
LAN1 - desktop1
LAN2 - miniPC
WiFi: - aptop1

If i try to ping from desktop1 to minipc (ping miniPC) it resolves the host and i can also connect to it via rdp using its hostname;
If i try to do the same from the laptop1 it does not work;
Both desktop1 and laptop1 running windows10 21H2

PS: I have not setup local domain and I would like to stay like that;
 

ColinTaylor

Part of the Furniture
PS: I have not setup local domain and I would like to stay like that;
Why? Try setting a local domain (e.g. home.lan) just to see if it makes a difference. Setting a local domain doesn't preclude you from using either qualified or non-qualified names.

You say "it does not work". What doesn't? Resolving the laptop's name or the ping?

Is the laptop connected to the primary WiFi network or a guest network? Is the laptop configured as a normal DHCP client?
 

LLeg0

New Around Here
Why? Try setting a local domain (e.g. home.lan) just to see if it makes a difference. Setting a local domain doesn't preclude you from using either qualified or non-qualified names.

You say "it does not work". What doesn't? Resolving the laptop's name or the ping?

Is the laptop connected to the primary WiFi network or a guest network? Is the laptop configured as a normal DHCP client?
You're actually right, i should have known i can still call them without fqdn :D brainfart moment;
Now it seems to be working both short hostname and fqdn;


However I have one more issue: I cannot connect to the NFS share hosted on the same miniPC (was working with the other router)
 

ColinTaylor

Part of the Furniture
However I have one more issue: I cannot connect to the NFS share hosted on the same miniPC (was working with the other router)
There shouldn't be anything on the router that specifically interferes with NFS. Can you provide more details.
 

LLeg0

New Around Here
There shouldn't be anything on the router that specifically interferes with NFS. Can you provide more details.
so minipc runs a NFS server;
On my windows machines i enabled Client for NFS and mounted my shares; It has never been as stable as i wanted in terms of speed and reliability but i suppose this is due to windows limitations;
However it used to at least work.Now with Asus i can't seem to be able to connect again ''Map Network Drive'' feature anymore;

ssh,plex,other things work; Do you have any idea on what should i check next?
 

ColinTaylor

Part of the Furniture
Has the IP address range of your LAN changed with the new router?
 

ColinTaylor

Part of the Furniture
As a side note, when I was debugging a Windows NFS issue a while back it became apparent that the way Microsoft has implemented the client is really badly done. In short, to get Windows client to detect NFS changes you must get Windows to do a full reboot. You cannot use a fast reboot or just refresh Explorer, that won't work.
 

LLeg0

New Around Here
As a side note, when I was debugging a Windows NFS issue a while back it became apparent that the way Microsoft has implemented the client is really badly done. In short, to get Windows client to detect NFS changes you must get Windows to do a full reboot. You cannot use a fast reboot or just refresh Explorer, that won't work.
Yea...also a good point. I'll give a shot to samba.This also works for my mobile phone


Later edit: It did work with SMB;
thanks @ColinTaylor for help
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top