What's new

DNScrypt cant start/uninstall dnscrypt

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

i installed dnscrypt (via AMTM) on my RT-AX58U, but it does not start up and i can't uninstall it.
Since that my guest wifi's with VPN (YazFi) are not working anymore :-/
Can you help me how to uninstall it manually?


Merlin 388.2_2
dnscrypt 2.4.8


  • dnscrypt_log.txt
    31.8 KB · Views: 21
Last edited:
same result also when i run

curl -L -s -k -O https://raw.githubusercontent.com/thuantran/dnscrypt-asuswrt-installer/master/installer && sh installer ; rm installer

how to remove it manually completely from router?
I recommend:
In the SSH terminal, issue the command service stop_dnscrypt-proxy; rm -rf "/jffs/dnscrypt/dnscrypt-proxy".
Then "Uninstall ALL" option of the installer, other wise labeled option 9.

Last edited:
Here is the solution, please do not create duplicate posts when requesting or seeking help. Please follow the rules of the forum.

uninstall was working now, thank you!

BTW - dnscrypt is working normally on my RT-AC86U (other location), but not on my RT-AX58U...
It seems to have a love hate relationship with that particular model router. That one, and the RT-AX56U. Other users had reported it was working just fine in the past. It looks like I am back to no other choice but to mark those models as no longer compatibe.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!