Guest network doesn't have internet access

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

iTyPsIDg

Regular Contributor
Running latest stable Merlin 386.1, VPN Manager, YazFi, and Diversion. I had the exact same issue when on 386.1 beta 3 without VPN Manager, YazFi, or Diversion. I use NordVPN. I'm using Wireless router mode / AiMesh Router mode (Default).

I'm a digital nomad. I got the RT-AC86U because I want it to look like I'm always in the US, just in case I have to connect to my company's network.

I will start by saying that I haven't been able to test this on a direct WAN connection to the public internet. All of the places I've been in require that I plug the RT-AC86U into another WiFi router. So the WAN is using a private IP (192.168.1.X), the LAN uses 192.168.50.X, and Guest 1 uses 192.168.101.X.

If I connect to the regular WiFi network (2.4 or 5 GHz) everything works fine. If I configure Guest 1 (2.4 or 5) I connect to WiFi, but I can't access the Internet. I almost think this is a routing issue (I can't even ping 8.8.8.8). I'm just not sure what to do to fix it. I've spent hours trying to figure it out (which is why I now have VPN Manager, YazFi, and Diversion), but I'm lost. Can anyone offer any advice? Do I need to set up a static route?

Here is my routing table, if it helps:
1612380951314.png
 

L&LD

Part of the Furniture
@iTyPsIDg welcome to the forums.

Known issue, use search for more info (won't really help you though).

Use GN 2, 3, or 4 instead (for now).
 

iTyPsIDg

Regular Contributor
@iTyPsIDg welcome to the forums.

Known issue, use search for more info (won't really help you though).

Use GN 2, 3, or 4 instead (for now).
Thank you. That helped, as did the similar thread 386.1 LAN->DNS Filter does not work on Guest 1 network. Now I see that my DHCP settings for Guest 2 won't work. It also seems that VPN Client doesn't do anything either, it will use the same VPN as my primary. I just hope that the isolation works correctly since I'm on the same subnet as my primary.
 

iTyPsIDg

Regular Contributor
That did the trick! Thank you so much!
 

chongaik3

Occasional Visitor
Hi all, hope some one can clarify the issue i am facing. I have a Blue Cave with Guest Network (2.4GHz) enabled (mainly for IoT devices). However, i cannot see these IoT devices in Network Map or Wireless Log even i set "Access Intranet==Enable". Meaning i have no visibility who connect to my Guest Network at all. Is this scenario normal?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top