Help on Setting up a wireless AP

folfox

Occasional Visitor
Hello All,

Found some threads about this but I want to make sure I have this right:
My main router (ax88u on Merlin connected to modem) will be connected (via Ethernet LAN to WAN) to an ax86u (stock firmware) in AP mode to be a wireless access point.

1: is there any benefit on me flashing the firmware on the ax86u to Merlin? I’ve seen most just keep it at stock firmware… is this the firmware out of the box? Or should I update to the latest firmware from ASUS?
2: I would like to keep the same SSIDs - I currently have my 2.4 and 5 separated on specific control channels (1 and 36 respectively) if I keep the same SSIDs, I just need to pick channels other than 1 and 36 right? Will my devices automatically switch to whichever router it’s closest to?
3: This might be a dumb one, do I just log in to the router being used as the AP and switch it from wireless router mode to wireless AP mode? Can someone please provide me with some quick steps on what I need to do?

Thanks in advance!
 

ColinTaylor

Part of the Furniture
1. No real advantage using Merlin for an AP that I can think of. Update to the latest Asus firmware for the most recent wireless drivers.
2. Roaming decisions are predominantly down to the client rather than the router.
3. Just click the button on the Administration - Operation Mode page. There's an explanation of what happens on that page also.

N.B. These instructions say to connect the router to the AP's LAN port. I suggest you don't do that and connect it to the AP's WAN port. Either will work but by using the WAN port you minimise potential network problems should you accidentally reset the AP back to router mode.
 
Last edited:

folfox

Occasional Visitor
1. No real advantage using Merlin for an AP that I can think of. Update to the latest Asus firmware for the most recent wireless drivers.
2. Roaming decisions are predominantly down to the client rather than the router.
3. Just click the button on the Administration - Operation Mode page. There's an explanation of what happens on that page also.

N.B. These instructions say to connect the router to the AP's LAN port. I suggest you don't do that and connect it to the AP's WAN port. Either will work but by using the WAN port you minimise potential network problems should you accidentally reset the AP back to router mode.
Thank you! AP router will connect to my main router via switch located in another room, will that cause any issues?
 

drinkingbird

Senior Member
Hello All,

Found some threads about this but I want to make sure I have this right:
My main router (ax88u on Merlin connected to modem) will be connected (via Ethernet LAN to WAN) to an ax86u (stock firmware) in AP mode to be a wireless access point.

1: is there any benefit on me flashing the firmware on the ax86u to Merlin? I’ve seen most just keep it at stock firmware… is this the firmware out of the box? Or should I update to the latest firmware from ASUS?
2: I would like to keep the same SSIDs - I currently have my 2.4 and 5 separated on specific control channels (1 and 36 respectively) if I keep the same SSIDs, I just need to pick channels other than 1 and 36 right? Will my devices automatically switch to whichever router it’s closest to?
3: This might be a dumb one, do I just log in to the router being used as the AP and switch it from wireless router mode to wireless AP mode? Can someone please provide me with some quick steps on what I need to do?

Thanks in advance!

Looks like your questions were answered but just one other item - you can use "roaming assistant" feature to force clients with low signal to disconnect and (assuming they are closer to the other AP) reconnect to that one. You can play with the threshold but if your APs overlap at least a little bit you can probably set it to -60 to start and go from there. If you want them to roam more aggressively, go to like -50 or -40, less aggressively, -70 or -80 (anything less than -80 is going to be a pretty lousy signal so wouldn't go beyond that).

The only disadvantage of that feature is if you are far away from both APs you would keep getting disconnected, when not having the feature enabled might let you stay connected but with a slow connection.

On Windows PCs check the advanced settings under the network adapter, some have "roaming aggressiveness" and you can set it to maximum. If you don't have it you can try updating the driver to the latest from the manufacturer, the built in windows drivers are often missing this option.

Most clients these days will prefer 5ghz (even if 2.4 signal is stronger, which it almost always is) so you can even combine your SSIDs into a single one if you want and clients will use 5ghz unless the signal gets weak, but I know many prefer to keep them separated. Actually I believe both of your routers support Smart Connect which will make even older clients prefer the 5Ghz band.

Rather than running router/AP you can also use AIMESH. I don't have any experience with it but it may give you better roaming. AX wifi does have a much better implementation of seamless roaming however the client has to support it (be an AX client with that feature implemented). Not sure if Asus has that feature implemented or not, but I'd think it would.
 
Last edited:

folfox

Occasional Visitor
Looks like your questions were answered but just one other item - you can use "roaming assistant" feature to force clients with low signal to disconnect and (assuming they are closer to the other AP) reconnect to that one. You can play with the threshold but if your APs overlap at least a little bit you can probably set it to -60 to start and go from there. If you want them to roam more aggressively, go to like -50 or -40, less aggressively, -70 or -80 (anything less than -80 is going to be a pretty lousy signal so wouldn't go beyond that).

The only disadvantage of that feature is if you are far away from both APs you would keep getting disconnected, when not having the feature enabled might let you stay connected but with a slow connection.

On Windows PCs check the advanced settings under the network adapter, some have "roaming aggressiveness" and you can set it to maximum. If you don't have it you can try updating the driver to the latest from the manufacturer, the built in windows drivers are often missing this option.

Most clients these days will prefer 5ghz (even if 2.4 signal is stronger, which it almost always is) so you can even combine your SSIDs into a single one if you want and clients will use 5ghz unless the signal gets weak, but I know many prefer to keep them separated. Actually I believe both of your routers support Smart Connect which will make even older clients prefer the 5Ghz band.

Rather than running router/AP you can also use AIMESH. I don't have any experience with it but it may give you better roaming. AX wifi does have a much better implementation of seamless roaming however the client has to support it (be an AX client with that feature implemented). Not sure if Asus has that feature implemented or not, but I'd think it would.
Thanks! I actually stumbled upon the roaming assistant today and am trying out different thresholds. I’ll try out aimesh if I run into any issues with current set up.
Coming across some other posts, is it true Merlin doesn’t support aimesh?
 

L&LD

Part of the Furniture
No, not true.

In my experience, having both the main and the node(s) on the same (RMerlin) firmware version is key to a stable AiMesh network.
 

folfox

Occasional Visitor
No, not true.

In my experience, having both the main and the node(s) on the same (RMerlin) firmware version is key to a stable AiMesh network.
Does this also apply if I’m just using one router in AP mode? Technically I’m not using AiMesh right?
 

drinkingbird

Senior Member
Does this also apply if I’m just using one router in AP mode? Technically I’m not using AiMesh right?

You would setup your main router as the AIMESH hub or root and the second router that you're using as AP as an AIMESH node off that.

As far as I know that essentially sets the second one as an AP, but not positive. don't see why it would use routing and NAT when acting as a node.
 

helwifi

New Around Here
Hello,

I'm trying to do the same here with Roaming Assistent....
- Use 3 Asus routers, one on each floor, using original asus firmware;
- all 3 routers conected with cable;
- 2 routers set as AP (top and bottom floor);
- use on 3 routers the same SSID;
- use diferent channels on 3 routers;
- Disconnect clients with RSSI lower than : -70 dBm (to be adjusted here)

Is this a possibility of work, or I'm missing something and what I need is only possible on AiMesh?
AiMesh sucs and I want something stable.

Do someone here has this kind of setup that can share his experience?
 

drinkingbird

Senior Member
Hello,

I'm trying to do the same here with Roaming Assistent....
- Use 3 Asus routers, one on each floor, using original asus firmware;
- all 3 routers conected with cable;
- 2 routers set as AP (top and bottom floor);
- use on 3 routers the same SSID;
- use diferent channels on 3 routers;
- Disconnect clients with RSSI lower than : -70 dBm (to be adjusted here)

Is this a possibility of work, or I'm missing something and what I need is only possible on AiMesh?
AiMesh sucs and I want something stable.

Do someone here has this kind of setup that can share his experience?

Depending on the size of your house and the materials between floors, -70 may never disconnect, at least not on 2.4ghz. 3 APs for 3 floors seems a bit overkill but not sure the size of the house you're dealing with.

What you describe above will work fine, if you want more aggressive roaming you'll probably have to go to like -50, and also check the clients to see if you can bump up the roaming aggressiveness.

On 2.4Ghz make sure you're only using channels, 1, 6, and 11. On 5ghz you have more to choose from but space them out as much as possible (do a site survey to see which ones are best).

Bear in mind when machines roam, especially when forced by minimum RSSI measures like roaming assistant, they will disconnect briefly. Typically not an issue but a stream will glitch for a few seconds and some video/conferencing apps will disconnect. I use Teams a lot and min RSSI and sometimes it just glitches for a second and others I have to re-join (sometimes it doesn't even disconnect me just sits there silent). The main reason for this is the client needs to not only reconnect to the wireless but also renew its DHCP lease and send a DNS update etc. Pretty much as though you unplugged and replugged its ethernet cable.

With AX wifi there is a much better implementation of seamless roaming available but the router and client must both support it and it is relatively new so still being tweaked.

You can also research which firmware is best for AIMesh and your routers, I know some have great luck with it and others don't like it, I think it varies on hardware and software combo.
 

helwifi

New Around Here
The house has around 110m2 each floor, the wall are made of 20cm bricks, internally and to outside 40cm. In between floors ist made of concrete + bricks.

From one floor to the other and in 2.4ghz, I've lost wifi signal with my AC88U.
Frequently my 2.5 shely wich controls blinds, are offline on top floor.

I'm tired of disassemble shelly from the wall to reset them.

So I will give try to Roaming assistant, because AiMesh on AC88u and AC68U x2 it didn't work at all.

Thanks for your feedback
 

degrub

Part of the Furniture
Turn off 2.4 GHz radio unless you have devices that require it.
Reduce the power to 50 % on each radio until you see drop out atthe furthest distance or most remote access. Increase power if you need but only on 5GHz band.
Set 5GHz to 40/80 to start
If you use 2.4 GHz, use 20/40 setting as a start.

with your physical situation you should only need 5GHz , one per floor. If you have an L shape or rooms that cannot see enough signal, try moving the AP. If you cannot move, then a low
Most APs put out strongest signal to the sides with about 50 % in the top direction.

RSSI of -65 dB is about the level where the client device will think about switching APs. You can try -60 for AP dropping, but the client always decides.
 

drinkingbird

Senior Member
The house has around 110m2 each floor, the wall are made of 20cm bricks, internally and to outside 40cm. In between floors ist made of concrete + bricks.

From one floor to the other and in 2.4ghz, I've lost wifi signal with my AC88U.
Frequently my 2.5 shely wich controls blinds, are offline on top floor.

I'm tired of disassemble shelly from the wall to reset them.

So I will give try to Roaming assistant, because AiMesh on AC88u and AC68U x2 it didn't work at all.

Thanks for your feedback

OK yeah in that case I can see why you need 3.
 

drinkingbird

Senior Member
Turn off 2.4 GHz radio unless you have devices that require it.
Sounds like they do have at least one thing that requires it.

Reduce the power to 50 % on each radio until you see drop out atthe furthest distance or most remote access. Increase power if you need but only on 5GHz band.
Why? Roaming assistant is a better solution. Yes, too much power on a radio will increase noise but the power settings on these Asus routers aren't excessive. If the OP finds they have plenty of signal on each floor then sure, turning it down a bit might not be a bad idea but then on another day when there is more interference, it could be an issue.

Set 5GHz to 40/80 to start
If you use 2.4 GHz, use 20/40 setting as a start.
Never set 2.4ghz to 40 or 20/40 unless you live where there is nobody else nearby. Consuming the entire 2.4 spectrum is a jerk move. Be a good neighbor and set it to 20. It will also help your own signal, in many cases you'll have better speed on 20 than 40 as there is less interference. Plus you'll cause issues for your bluetooth devices etc. They never should have released 40mhz channel for 2.4.

with your physical situation you should only need 5GHz , one per floor. If you have an L shape or rooms that cannot see enough signal, try moving the AP. If you cannot move, then a low
Most APs put out strongest signal to the sides with about 50 % in the top direction.

RSSI of -65 dB is about the level where the client device will think about switching APs. You can try -60 for AP dropping, but the client always decides.

With roaming assistant, the device does NOT decide, that's the whole point of it. The AP will kick you off at a certain threshold and your client will then reconnect to the strongest available AP. Some even take it a step further and block you from the original AP for a few seconds to ensure you don't reconnect to it.

-65 will only make the client think about roaming if it is very aggressive. Many will hang on as long as possible even until -80 or worse. That's why so many vendors have released roaming assistant, min RSSI, etc.
 

helwifi

New Around Here
Hello Wi-Fi enthusiasts :) :cool:

So far so good....

To setup the network it took some precious hours!

I've took all of your tips and implement them, but I want to share my experience here so far.

Installed 1 router per floor:
- AC68U on garage,
- AC88U on living room,
- AC68U on rooms

I've in all 3 routers like this:
- signal power: power saver (minimum possible)

- min RSSI @ 2.4Ghz: -50dBi
- min RSSI @ 5Ghz: -60dBi

- Chanel Bandwidth @ 2.4Ghz: 20Mhz
- Chanel Bandwidth @ 5Ghz: 80Mhz

- Channel @ floor 1 @ 2.4Ghz: 1
- Channel @ floor 1 @ 5Ghz: 36

- Channel @ floor 2 @ 2.4Ghz: 6
- Channel @ floor 2 @ 5Ghz: 60

- Channel @ floor 3 @ 2.4Ghz: 10 (Shelly doesn't like higher that 10)
- Channel @ floor 3 @ 5Ghz: 112


I create a lot networks, and even with RSSI control, I see that Shelly and other devices connect from 1 floor to another.
As I've, Shelly, Sonoff, Broadlink, Soundmate, Xiaomi Cameras, etc.... with Wi-Fi @ 2.4Ghz, and totally around 35 diapositive's, I've to take severe measures here!
Being said, I've this idea of MAC blocking, where on each floor I've block, the Wi-Fi fixed devices from other floors.
At this moment I just have the phones and 3 laptops, "free" to move in the house.

So far... it's working, and I hope for ever!

I've stopped with AiMesh and seeking for Mesh expensive systems.
If it works, it's much cheaper that any mesh system form Ubiquiti, Microtik, Cisco, etc...

Lets wait some days/weeks and see how it behaves :)

More ideas/tips are welcome, this is a live project :cool:
 

drinkingbird

Senior Member
Hello Wi-Fi enthusiasts :) :cool:

So far so good....

You should leave your 5ghz set to 40/80 to ensure compatibility, but not a big deal.

Using channel 10 is hurting your channel 6 devices since it overlaps. If possible, use channel 11 in a place where "shelly" (not sure what that is) doesn't need to connect, and use 1 and 6 in the other places.

Setting your power level to minimum isn't really necessary, may result in some dead spots. The roaming assistant is taking care of booting weak devices for you.

MAC filtering will help keep your devices that never leave a certain area on a certain AP, but in some cases if that device insists on trying to connect to one of those APs that is blocking it, it may not be able to connect at all. You'd be better off setting 3 different SSIDs and using that to force each device to connect to that particular AP. For devices you want to be able to connect to 2 or 3 APs, just make sure they have the relevant SSIDs set up and they will roam between them (roaming assistant will force them to).
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top