I want to replace the wifi card in my laptop

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

BobD

Regular Contributor
I was given a several years old Lenovo laptop. It has an Atheros QCA9377 wifi card plugged into an M2 key E socket. This card is working but slow. I happen to have several Intel AC-9260 wifi cards which also plug into an M2 key E socket.
These Intel cards are up to 4x faster than the Atheros.
The question: Would I be able to use the Intel AC-9260 card in this PC instead of the Atheros. The Intel card physically fits in the socket but I can't find out the electrical compatibility.
Any advice greatly appreciated.
 

BreakingDad

Very Senior Member
I would of thought it would be fine, but if you go to the lenovo website, you can check compatibility https://pcsupport.lenovo.com/ph/en

It would help to post the model number of the laptop
 

L&LD

Part of the Furniture
It won't hurt to just switch the cards and test. Be sure you've downloaded the drivers for the AC-9260 first before you do.

And be extra careful of those antennae pins/connectors too.
 

BobD

Regular Contributor
I put the AC9260 in and it worked for a short while then died. Investigations underway. I'll get back soon.
 

BobD

Regular Contributor
I tried another ac9260 card and it doesn't work at all. I've changed back to the original Atheros wifi card and experiment finished. Thanks for your replies.
 

RMerlin

Asuswrt-Merlin dev
Lenovo use BIOS whitelists to only allow very specific cards, making it next to impossible to upgrade it, unless you know which specific cards are allowed by your laptop's BIOS.
 

L&LD

Part of the Furniture
RMerlin, that hasn't been true of many models of Lenovo laptops for a very long time now.

@BobD, which specific laptop is this?

What steps did you take to try to get it to work?

I'm not sure if the original Atheros card is working or if it has also failed?

(You did remove, disable (in the BIOS), or disconnect the battery before removing components, correct)?
 

RMerlin

Asuswrt-Merlin dev
RMerlin, that hasn't been true of many models of Lenovo laptops for a very long time now.
He said it was a "several years old" model.

And my one year old Ideapad still uses a whitelist according to what their tech support told me when I asked about upgradability (though I'm not 100% sure their tech support even understood half of what I asked... I hate when I know more than a company's actual tech support department). It depends on the specific model.
 

L&LD

Part of the Furniture
I don't ask (tech support), that is definitely a waste of time. I just test the latest cards and none in the past few years have failed to install, work, and (continue) working in almost all Lenovo laptops I've encountered.

I'd be curious to see you test an Intel AX210 card and see if it worked (or not) in your IdeaPad.

Anything that is replaceable (i.e., not soldered down) is fair game for upgrades in most brands.
 

RMerlin

Asuswrt-Merlin dev
I'd be curious to see you test an Intel AX210 card and see if it worked (or not) in your IdeaPad.
Waiting for it to be available locally rather than an overpriced part shipping from China. Then I might give it a try, tho that's not a high priority as I don't have any use for Wifi 6e.
 

BobD

Regular Contributor
RMerlin, that hasn't been true of many models of Lenovo laptops for a very long time now.

@BobD, which specific laptop is this?

What steps did you take to try to get it to work?

I'm not sure if the original Atheros card is working or if it has also failed?

(You did remove, disable (in the BIOS), or disconnect the battery before removing components, correct)?
The machine is a Lenovo IdeaPad S145-14AST Type = 81ST0044AU
Yes I did disconnect the battery although not the cmos battery.
I checked the BIOS and it showed the Intel AC9260 card.
I reset the BIOS to optimum defaults.
I did remove the Atheros drivers using the Windows Device Manager.
I confirmed the Intel ac9260 was working OK in Device Manager.
I loaded up the latest Intel drivers applicable to the device.
Once the new card was running I used the Intel Driver Support Assistant to ensure the drivers were correct.
When the Intel AC9260 failed I put the original Atheros wifi card back in and it is working but slow (433MHz on the 5GHz radio).
The speed is less important now as I bought a USB3 to gigabit ethernet gadget which works well and removes the dependency on the Atheros wifi card.
The router is an ASUS RT-AX86U running the latest ASUS software.
The in house network is 3 gigabit switches. One adjacent to the router and two downstream in other rooms.
 
Last edited:

BobD

Regular Contributor
He said it was a "several years old" model.

And my one year old Ideapad still uses a whitelist according to what their tech support told me when I asked about upgradability (though I'm not 100% sure their tech support even understood half of what I asked... I hate when I know more than a company's actual tech support department). It depends on the specific model.
If my machine has a whitelist then it doesn't apply to the SSD as I have replaced it with a larger one I had spare. The NVME device is still the original.
 

ColinTaylor

Part of the Furniture
My Lenovo laptop used a whitelist for WiFi cards. It's implemented in the BIOS. So if you install an unlisted WiFi card when the laptop turns on you immediately get a message saying "Unauthorized Wireless network card is plugged in. Power off and remove it". The laptop will not boot past this point.

I had to get someone to provide a modified BIOS so that I could install a better card. As you got as far as booting an operating system and installing the drivers it doesn't sound like your laptop is using a whitelist.
 
Last edited:

BobD

Regular Contributor
My Lenovo laptop uses a whitelist for WiFi cards. It's implemented in the BIOS. So if you install an unlisted WiFi card when the laptop turns on you immediately get a message saying "Unauthorized Wireless network card is plugged in. Power off and remove it". The laptop will not boot past this point.
I have seen that message before in older HP machines but I had no such problem with the Lenovo. My laptop booted and the wifi card was working for a short while.
I wonder if the Lenovo BIOS is a silent assassin and just clobbers the wifi card without a message?
There is the possibility that my Intel AC9260 was defective. It had never been used before. I have two more and I will try one of them when I have a spare moment.
 

ColinTaylor

Part of the Furniture
How trustworthy was the source of your AC9260. The first AC7260 I got from China turned out to be some dodgy pre-production sample that only partially worked. I got another "genuine Intel" one off eBay. What arrived looked like it had been salvaged from a Dell laptop but it worked.
 

L&LD

Part of the Furniture
Yes, it sounds like you need to try again with another card. It will be worth it.
 

BobD

Regular Contributor
How trustworthy was the source of your AC9260. The first AC7260 I got from China turned out to be some dodgy pre-production sample that only partially worked. I got another "genuine Intel" one off eBay. What arrived looked like it had been salvaged from a Dell laptop but it worked.
 

BobD

Regular Contributor
The first one was (and still is) in an ASUS PCE-AC58BT add in card and I bought two more from the same retailer.
That retailer has a very good reputation here in Melbourne Australia.
Link to that retailer PC Case Gear
 

Tech9

Very Senior Member
I confirmed the Intel ac9260 was working OK in Device Manager.
I loaded up the latest Intel drivers applicable to the device.

It's not the whitelist, if you got that far. It won't be recognized at all or you'll get the error message at boot. Try with default Windows drivers first. Intel drivers are quirky and latest doesn't always mean the best.
 

BobD

Regular Contributor
It's not the whitelist, if you got that far. It won't be recognized at all or you'll get the error message at boot. Try with default Windows drivers first. Intel drivers are quirky and latest doesn't always mean the best.
OK, I tried again with my other spare Intel AC9260 (I marked the first one so I know it) and this time their was no recognition at all.
The BIOS allows me to make wifi active or not but never actually identifies the adapter, not even the original Atheros one.
Windows Device Manager did not recognise the 9260 nor did it include it in the list of unrecognised devices, the category Other.
My thoughts are that the BIOS is blocking or unable to recognise the Intel ac9260.
As I indicated earlier, I now have a $15 USB to ethernet adapter for any heavy work so the slow wireless is not a problem.
I have finished with this experiment as I am now concerned for the connectors on the antenna cables.
They have a lifetime of 30 insertions and I reckon I have used nearly half of those.

One thing that others might find useful. When I got the machine it had Win 10 Home installed.
This is how it left the factory. I installed Win 10 Pro and then went to check its activated status and it was activated with a digital licence.
My good luck? When I inspected the licence keys with Showkey the embedded licence was for Win 8 pro.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top