What's new

Issue with Non-Asus Router in AIMesh Network

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I have a big house with a large rural property. My internet is a Bell wireless 50/10 system. For my network I am using have an Asus AIMesh system with the following components:

the main router (RT-AC86U) []; and 6 nodes, as follows:

RT-AC86U (WiFi) []

RT-AC68U (wired) []

4 ZenWiFi XD5’s (3 are wired and 1 is WiFi) []

Two, of the ZenWiFi XD5’s, are in separate buildings.

One of those is hard wired to the main house to either the main router directly or a switch next to the router.

The other router which is in a building further from the house is connected using 2 Ubiquiti radios (NanoStation Loco M5’s). The Ubiquiti radio in that building is connected to a non-managed switch, which has the XD5 and two security cameras connected. The mesh system sees this XD5 as a wired connection.

I also have 7 security cameras (currently all HikVision) and an NVR. 5 of the cameras are connected to the NVR in the main house and the other 2 are connected as indicated above.

I also have a Generac Generator (20Kw) on the property which is about 300’ feet from the main house. Recently I installed, as an add on to the generator, a WiFi/Ethernet module (#7170) which is a router with WiFi and Ethernet capabilities. Surprisingly, given the distance from the main house, I was able to connect to the generator using WiFi. However, the signal is fairly weak and I am concerned about the reliability of that signal, particularly in the winter when the snow piles up.

So, given that concern, I decided to try to connect the generator to my network using Ethernet instead of WiFi. To do this, I installed 2 more Ubiquiti radios (NanoStation AC devices) so that I could beam the network signal from the house to a pole close to the generator. Then I connected an ethernet cable from the data port on the NanoStation AC device to the generator module.

This is where problems started to happen. Whenever that final link is active (ethernet connection to the generator module), it causes problems in my mesh system! The WiFi signals start to weaken and using the mobile Asus app I can no longer see any of the network AIMesh clients! It just shows the AiMesh nodes and keeps spinning as though it is trying to refresh. In addition, the WiFi signal on my iPhone is very weak. As soon as I disconnect the generator module and reboot the main router everything starts working properly again!

So, it appears that introducing a non-Asus router (the generator module) into the network seems to bring the system down. Does this make sense? Has anyone else encountered this type of issue?

Recently, I also had a similar issue when I was trying to setup the new Ubiquiti radios because I accidently purchased the wrong PoE switch and ended up with an tp-link 8-port Gigabit Easy Smart With with 4 PoE ports (TL-SG108PE) which seems to have some management features. I have no idea as to what this switch was doing but shortly after I connected the switch to my network, I lost all access to the network and it required a complete reboot of the router. After this happened several times, I pulled the switch off the network and bought a non-managed switch which has been working without issue. Given that this issue took a bit of time to manifest itself, after I connected it, I am wondering if the switch was doing some type of monitoring that was overloading my network. Any thoughts on why this was happening?
Too many possibilities of why it may have happened as stated (one of those; Control Channel issues).

Why don't you just add an Asus router in Media Bridge mode to your generator instead?

In the scenario you're describing, you do not want any sort of router capability at the generator. Ideally you'd just plug the ethernet cable from the remote nanostation directly into the generator, but if I read between the lines I guess the generator itself has no ethernet capability until you plug that wifi module into it. Fine, but you've got to completely lobotomize the module's router functionality. Turn off its wireless radio, and turn off its DHCP service if any, and make sure it is in plain "access point" mode. (For that matter, make sure the nanostations think they are access points not routers.) Also, if the module has both WAN and LAN ports, you may need to avoid using the WAN port.

I suspect that the problems are due to multiple DHCP services appearing on your network and/or a routing loop involving the wifi module's WiFi connection and the nanostation connection. I'm not real sure why that would manifest as devices reporting weak wifi signals; but I've seen plenty of devices (especially Apple devices) that deliver entirely misleading diagnoses of a broken local network, so I wouldn't take those reports at face value.

If I'm right, the problem is with the generator's module not with the nanostations, so @L&LD 's suggestion of replacing the nanostations with a media bridge wouldn't change anything.
[ A bit later ... ] I took a look at the Generac #7170's user manual, which is distressingly short of information on how to use wired not wireless connectivity; to the point where I wonder if that is a "feature" that they never test and it doesn't really work. However, being generous and assuming that it should work, I think the answer is probably that you need to fully reset the #7170 and reconfigure it from scratch for wired connection. Just plugging a cable into the ethernet port is not going to change its opinion that it should use its own wifi connection. I doubt now that it has DHCP capability, but the routing-loop theory still seems very viable.
Thanks for the replies.

@L&LD I have never used a router in Media Bridge but doing a bit of reading I see that it’s primarily for connecting devices with an Ethernet cable to improve the speed of that connection. If I understand that correctly then I would think that I still have the same issue when I connect the generator to that Media Bridge router. If I were to even try that, I would probably have to place the router in Media Bridge mode in the house right before the Ubiquiti radio beams the signal to the other radio, which would then be wired to the generator.

@tgl I don’t think the NanoStations are an issue. I already have 2 others in my network (older versions than these) and they behave properly.

With respect to the WiFi / Ethernet module there does not seem to be any way to log into the device and as you point out the manual is “distressingly short of information”! I have asked Generac’s support for instructions on how to change from a WiFi mode to an Ethernet mode and I tried their instructions but they did not seem to work. They said that I had to turn off the generator; remove a fuse; connect the Ethernet cable to the module; restart the generator; and then run through the set up process. However, after doing this I noticed that the WiFi connection was still on my network and then a little while later the Ethernet connection also tried to join the network. I blocked the WiFi connection on my network and accepted the Ethernet connection but I then ran into the network issues.

After reading your posts, it occurred to me that the Generac support instructions were not complete. Given that there is a battery in the generator simply turning it off and removing the fuse probably didn’t kill the power to that module, meaning that it didn’t fully reset the # 7170! I think that my next step should be to go back to the generator and try to disconnect the battery after I turn the generator off. I will try that and let you know how it goes.

If only Asus had an outdoor router that played well with the AIMesh system then I could use that to broadcast a WiFi signal to the generator.
Follow up...

I went back to the generator today and went through the various steps in turning the unit off, including disconnecting the battery. Unfortunately, I still ended up with a WiFi connection.

I sent a detailed email, to Generac support, laying out all the steps I went through and asked them for a proper explanation on how to make an Ethernet connection work.

I am going to be away for the next 3 weeks so hopefully in the meantime they will provide that explanation and, when I return, I will try it. If it works, I will then determine whether or not an Ethernet connection to that module causes problems for my network.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!