Kamoj Add-on 5.1 Beta testing poll

Do you want to beta test Kamoj add-on v5.1b1?

  • No, I don't trust 3rd party software

    Votes: 0 0.0%
  • No, I don't use the Voxel firmware

    Votes: 0 0.0%
  • No, I don't like your add-on

    Votes: 0 0.0%

  • Total voters
    132

jrbmw

Regular Contributor
After loading latest version 5.3b21 lost internet.Also after uninstalling @kamoj addon still no internet,had to reinstall Voxel latest and gone back to 5.3b20
 

KW.

Regular Contributor
Thank you so much! Man you gave me hours of play time now with open the router to a whole new world of entware. A essential security boost with ssh for people like me that could not fix it on my own.

The b21 works perfect for me too. Not just you give me the tools, you let me learn and understand it in the process of the detailed installation process and FAQ.

So f great.
 

Gallo

Occasional Visitor
@kamoj dnscrypt problem solved with this update props to ya.
ssh key installed without a problem copied my ppk file for use with all my devices and was fine after add-on update excellent work
On a side note, you have been pumping out updates frequently and by no means am i complaining.
I would like to request and add-on update automation addition to your add-on
I would think a static name and a constant location to retrieve the file from would aid in this matter
uninstall, reboot, re-install, reboot a retrieval of the file could be done by the user and placed in a designated location or an outright download from a host.
Just a thought, I'm not a programmer and this might be unnecessary or open it up to a myriad of problems but it really would be cool ;) hehe

yeah im lazy there i said it :p
 
Last edited:

kamoj

Very Senior Member
Changes in kamoj-addon beta version 5.3b22
---------------------------------------------------
- OpenVPN Client: Added: PureVPN. (@LSM - thank you for support and encouragement!)
The add-on now directlty supports these 8 OPENVPN providers:
AzireVPN, Integrity, Mullvad, NordVPN, PrivateInternetAccess (PIA), PrivateVPN, PureVPN, SurfsharkVPN
- OpenVPN Client: Many small fixes, please report irregularities
- Enhanced: Supervision of Internet, OpenVPN, Wireguard, DNSCrypt2, Stubby, AdGuard, dnsmasq, net-lan
Now back to original idea of 5.3b17, but with several improvements and logging.
Still not full coverage since router itself use dnsmasq and no tunneling
- Settings: Added: Show "Start & Supervision log"
- Settings: Congestion Control: Made persistent after reboot and add-on/firmware update
- Minor fixes
- FAQ.txt updated
 

kamoj

Very Senior Member
Thank's for the suggestion.
For now you have to refresh the Router Information to see if there is a new add-on release.
And download and install as before.

The reason is that this is still in beta testing, and I don't have time to take care of many
new users before the add-on is stable.
That would be bad to users, to give them bad software in their routers as well.
Once the beta test is over, I'll consider your suggestion again! Now on my growing to-do-list.
@kamoj dnscrypt problem solved with this update props to ya.
ssh key installed without a problem copied my ppk file for use with all my devices and was fine after add-on update excellent work
On a side note, you have been pumping out updates frequently and by no means am i complaining.
I would like to request and add-on update automation addition to your add-on
I would think a static name and a constant location to retrieve the file from would aid in this matter
uninstall, reboot, re-install, reboot a retrieval of the file could be done by the user and placed in a designated location or an outright download from a host.
Just a thought, I'm not a programmer and this might be unnecessary or open it up to a myriad of problems but it really would be cool ;) hehe

yeah im lazy there i said it :p
 

R. Gerrits

Regular Contributor
Changes in kamoj-addon beta version 5.3b22
---------------------------------------------------
- Enhanced: Supervision of Internet, OpenVPN, Wireguard, DNSCrypt2, Stubby, AdGuard, dnsmasq, net-lan
Now back to original idea of 5.3b17, but with several improvements and logging.
Still not full coverage since router itself use dnsmasq and no tunneling
An idea for a potential improvement:
If you'd run the supervision as cronjobs, you could then run some of the scripts under a different user.
And if a script runs under a different user, you can use iptables rules to redirect dns-traffic for that specific user to AdGuard
Or you could route traffic for that user directly to internet, to test the real internet connection, instead of the VPN connection.
 

Alex Wood

New Around Here
Hi
Been using your beta for a while now, and am loving it. Thank you very much. I was wondering if it would be possible to suggest a feature? I've been trying to get pxe boot to work with my R7800. I kill udhcpd and dnsmasq, and then run the full version of dnsmasq (installed via entware) with my conf file with lines such as these:
dhcp-match=set:bios,60,PXEClient:Arch:00000
dhcp-boot=tag:bios,netboot.xyz.kpxe,,192.168.1.2

This works, but after a few hours the router stops sharing out the internet and needs to be reset. I assume this is because netgear's software depends upon udhcpd, which I have to kill as running the full version of dnsmasq AND udhcpd would be counterproductive (two DHCP servers saying slightly different things). Unfortunately this is where I'm stuck, and I was hoping that this may be an easy thing for you to add considering your weath of experience and knowledge (maybe even doing it using udhcpd, if that's possible).

The script I created to do this is here (ignore the openwrt big, that;'s another project): https://github.com/ajw107/openwrt-config/blob/master/mnt/sda1/mydns
but as I say, using this script means that after a few hours the router stops working, so having something added to your addon would no doubt be far superior.
 

Gallo

Occasional Visitor
@kamoj ummmm not sure if its something I did or maybe a bug. My flash drive is improperly displayed but the df output is correct.

still running 21b but I noticed it be4 also

Filesystem 1k-blocks Used Available Use% Mounted on
tmpfs 512 0 512 0% /dev
ubi0:eek:verlay_volume 51032 7288 41100 15% /overlay
overlayfs:/overlay 51032 7288 41100 15% /
/dev/sdb 3900568 538696 3163728 15% /tmp/mnt/sdb
/dev/sda1 976759804 461882800 514877004 47% /tmp/mnt/sda1
tmpfs 512 0 512 0% /hipplay/dev
/dev/sda1 976759804 461882800 514877004 47% /hipplay/home/0external/C2667E95667E89C5
/dev/sdb 3900568 538696 3163728 15% /hipplay/home/0external/78c7314e-cdf3-47ae-b761-eb8bd4c7ca40
tmpfs 241760 0 241760 0% /hipplay/dev/shm
 

Attachments

kamoj

Very Senior Member
Thank you very much for this report.

The picture is really too small for my eyes.
And text output is better if you post as "code" snippets (press ...:</> code in reply window header)

But anyhow, I've been changing the "show USB" code quite a bit to get it working with the R9000.
But since I don't own an R9000, it's been a difficult task, and not finished as I indicated in the release_notes.

I guess your problem is with a R7800 though,
and I would appreciate if you post the Settings: USB1 + USB2 info output, please!

Do you know if it was working with any previous add-on versions?
@kamoj ummmm not sure if its something I did or maybe a bug. My flash drive is improperly displayed but the df output is correct.

still running 21b but I noticed it be4 also

Filesystem 1k-blocks Used Available Use% Mounted on
tmpfs 512 0 512 0% /dev
ubi0:eek:verlay_volume 51032 7288 41100 15% /overlay
overlayfs:/overlay 51032 7288 41100 15% /
/dev/sdb 3900568 538696 3163728 15% /tmp/mnt/sdb
/dev/sda1 976759804 461882800 514877004 47% /tmp/mnt/sda1
tmpfs 512 0 512 0% /hipplay/dev
/dev/sda1 976759804 461882800 514877004 47% /hipplay/home/0external/C2667E95667E89C5
/dev/sdb 3900568 538696 3163728 15% /hipplay/home/0external/78c7314e-cdf3-47ae-b761-eb8bd4c7ca40
tmpfs 241760 0 241760 0% /hipplay/dev/shm
 
Last edited:

KW.

Regular Contributor
@kamoj Would it be possible to add express opvn to the addon.
From Kamojs FAQ:

Q: Why don't you directly support ExpressVPN?
A: Because they have no free trial, and no add-on user has wanted to let me
use their credentials even for a day, or payed me for a trial period.
I can not add OpenVPN providers without being able to test it!
General to all beta testers including myself is to remember that as beta testers we also have some responsibility to help as good as our abilities let us. We get a very nice product but we have to keep remind ourself that we are a part of a program to get this stuff early and that we signed up to help test and improve the work. Kamoj is for sure doing allot of work to try prevent some problems that can be user related by doing allot of documentation. To be responsible and to show our motivation to help I think it's important to spend time with the beta, not just enjoy it but see it as project we signed up to and should be a part in.

Kamoj dont seem to ask to much but from his read me file:

9). Read Release Notes with changes: release_notes.txt

10). Read Frequently Asked Questions: FAQ.txt
Let us all beta testers remember that we signed up to be a part of a great project.
 

jrbmw

Regular Contributor
From Kamojs FAQ:



General to all beta testers including myself is to remember that as beta testers we also have some responsibility to help as good as our abilities let us. We get a very nice product but we have to keep remind ourself that we are a part of a program to get this stuff early and that we signed up to help test and improve the work. Kamoj is for sure doing allot of work to try prevent some problems that can be user related by doing allot of documentation. To be responsible and to show our motivation to help I think it's important to spend time with the beta, not just enjoy it but see it as project we signed up to and should be a part in.

Kamoj dont seem to ask to much but from his read me file:



Let us all beta testers remember that we signed up to be a part of a great project.
Fair comment.;)
 

kamoj

Very Senior Member
I have a patch for the USB info problem, can you try it and report back?
(Others can try too - of course!)
Code:
fr='USB_DEVID="$(find /dev -type b -name "$USB_DEV""*" | grep -v "$USB_DEV$" | head -n1)"'
to='USB_DEVID="$(df | awk "/^\/dev\/$USB_DEV/ && /\/tmp\/mnt\/sd/ {print "'$1'"}" | head -n1 | xargs)"'
sed -i "s#$fr#$to#g" /usr/bin/addon_info_update.sh
@kamoj ummmm not sure if its something I did or maybe a bug. My flash drive is improperly displayed but the df output is correct.

still running 21b but I noticed it be4 also

Filesystem 1k-blocks Used Available Use% Mounted on
tmpfs 512 0 512 0% /dev
ubi0:eek:verlay_volume 51032 7288 41100 15% /overlay
overlayfs:/overlay 51032 7288 41100 15% /
/dev/sdb 3900568 538696 3163728 15% /tmp/mnt/sdb
/dev/sda1 976759804 461882800 514877004 47% /tmp/mnt/sda1
tmpfs 512 0 512 0% /hipplay/dev
/dev/sda1 976759804 461882800 514877004 47% /hipplay/home/0external/C2667E95667E89C5
/dev/sdb 3900568 538696 3163728 15% /hipplay/home/0external/78c7314e-cdf3-47ae-b761-eb8bd4c7ca40
tmpfs 241760 0 241760 0% /hipplay/dev/shm
 

LSM

Occasional Visitor
kamoj,

thanks for the help with configuring the *.ovpn file for PureVPN. Lately their service has been a bit rough but as of 5.3b22 of your addon the killswitch & reconnect is working. Here are 3 log files that may provide some useful information.

The Port 53 fail from yesterday morning was just after I updated to 5.3b22 and everything seemed a bit touchy and I spent a fair bit of time warm and cold rebooting the router and rebooted the modem too. However, the other Port 53 file presents results from yesterday afternoon, evening and night. It started OK and, despite disconnects from the provider, your reconnect scheme kept it going. Early this morning I changed the *,opvn file to use port 1194 and it has been fine since then with this more standard VPN port, although dropouts/reconnects are evident.

Overall, 5.3b22 is a wonderful improvement in features and stabilty with my rather volitle VPN service. I'l keep exploring and reporting as I try to better understand VPN and the capabilities of this router with Voxel's firmware and your essential addon.

LSM
 

Attachments

kamoj

Very Senior Member
Yes, try on. It seems like PureVPN has a lot going on "at the moment" and is not stable for anyone.
Hopefully they sort it out soon.

Port 53 is often used for tcp connections, but PureVPN use it for UDP as well.
I left out TCP as option in the add-on since UDP is "much" faster, but you can manually edit the .ovpn file and try it out!
kamoj,

thanks for the help with configuring the *.ovpn file for PureVPN. Lately their service has been a bit rough but as of 5.3b22 of your addon the killswitch & reconnect is working. Here are 3 log files that may provide some useful information.

The Port 53 fail from yesterday morning was just after I updated to 5.3b22 and everything seemed a bit touchy and I spent a fair bit of time warm and cold rebooting the router and rebooted the modem too. However, the other Port 53 file presents results from yesterday afternoon, evening and night. It started OK and, despite disconnects from the provider, your reconnect scheme kept it going. Early this morning I changed the *,opvn file to use port 1194 and it has been fine since then with this more standard VPN port, although dropouts/reconnects are evident.

Overall, 5.3b22 is a wonderful improvement in features and stabilty with my rather volitle VPN service. I'l keep exploring and reporting as I try to better understand VPN and the capabilities of this router with Voxel's firmware and your essential addon.

LSM
 

Gallo

Occasional Visitor
I have a patch for the USB info problem, can you try it and report back?
(Others can try too - of course!)
Code:
fr='USB_DEVID="$(find /dev -type b -name "$USB_DEV""*" | grep -v "$USB_DEV$" | head -n1)"'
to='USB_DEVID="$(df | awk "/^\/dev\/$USB_DEV/ && /\/tmp\/mnt\/sd/ {print "'$1'"}" | head -n1 | xargs)"'
sed -i "s#$fr#$to#g" /usr/bin/addon_info_update.sh
Same thing i unmounted it also upon mount it shows up same way. tossed in a reboot with the drive removed and still same thing
Problem has changed a little both drives are represented as /sda1
df is reporting it correctly
 

Attachments

Last edited:

kamoj

Very Senior Member
I would appreciate if you give me needed information.
As per my request above:
"I guess your problem is with a R7800 though,
and I would appreciate if you post the Settings: USB1 + USB2 info output, please!"

And also this command, please:
Code:
grep -Hv "^ATA\ *$" /sys/block/*/device/vendor | sed s/device.vendor:.*$/device\\/uevent/ | xargs grep -H ^DRIVER=sd | sed s/device.uevent.*$/size/ | xargs grep -Hv ^0$ | cut -d / -f 4 | xargs
Same thing i unmounted it also upon mount it shows up same way. tossed in a reboot with the drive removed and still same thing
Problem has changed a little both drives are represented as /sda1
df is reporting it correctly
 

kamoj

Very Senior Member
Changes in kamoj-addon beta version 5.3b23
---------------------------------------------------
- Settings: Added: Allow SSH login with Username & Password.
- Router Information & other places: Changed way of handling "strange" USB mountings.
- FAQ.txt updated with info about WinSCP usage
 

Gallo

Occasional Visitor
@kamoj absolutely right
yes its a r7800

Im sorry kamoj i just read up and saw the post your talking about

output of your code is
sda sdb

settings were assigned by the r7800
/dev/sda1 on /tmp/mnt/sda1 type ufsd (rw,nodev,noatime,nls=utf8,uid=0,gid=0,fmask=0,dmask=0,force)
/dev/sdb on /tmp/mnt/sdb type ext3 (rw,nodev,relatime,errors=continue,user_xattr,barrier=1,data=writeback)

tried another screenshot to see if its better for you

im a work in progress with linux but whatever i can do let me know.

TIA
 

Attachments

Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top