What's new

Localization problem on VPN

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Since a while I'm experiencing an issue with the VPN set on my AX88U with Merlin firmware.
As I live in Germany, I use the VPN set on my Asus router (located in Italy) to get access to geolocalized content of my home country. The VPN (OpenVPN) works like a charm on two laptops but since a while I'm having a problem on my Android device (Pixel 7a with Android 14, but it was there also when I had Android 13). All the apps I need work fine, except one called Sky Go (streaming of pay TV for which I have a regular contract, i.e. no legal infringement). When I open this app and I'm connected to the VPN (both on WiFi and mobile data) it complains that I cannot visualize that content because I am abroad. Where is the OpenVPN protocol failing to hide the real location?

Here is my settings page of my AX88U. I've tried to disable the compression, but the result is the same.

May not be the settings but the Android client. There are two that should work: Openvpn Connect and Openvpn Client for Android. Over the years I have used both with great success.
Do you use an app or browser to access Sky Go?
If it's an app and it has access to location, it could get it from GPS, mobile, IP address. Take away access to location services and that should do the job. Virgin Media's tv app behalf the same if it gets access to location. But it doesn't on my phone ;)
If it's a browser, especially Chrome, it's a bit problematic to take away permission for location. But you access the website in incognito and if it acts for location don't grant it.

It's not your fault and there's nothing wrong with OpenVPN. I'm not sure if the new location came with Android 12, but I'm sure I've encountered exactly what you are talking about in Android 13 and 14. Every single time when I'm traveling...
Sky Go is an app and yes, I also tried to disable all the location services but still the app complains that I am in a foreign country (as I said, both on WiFi and mobile data). I think it's just some hole in the OpenVPN protocol that allows the app to have access to the real IP rather than the VPN IP.
Check what https://www.whatismyip.com/ reports. If it shows the redirected IP, then it probably means that app is somehow bypassing or detecting the VPN.

If it shows the wrong IP, then make sure on the server you configured it to route both "LAN and Internet".
I forgot to mention I've already tried it. It shows the correct IP (i.e. the IP of the VPN server)
Then it might be somehow bypassing or detecting the VPN if a web browser is properly getting redirected through it. Since it`s a mobile app maybe it`s relying on the phone`s Location services to determine your location rather than rely on the IP address. You could try withdrawing its permission to access the Location service, and restart your phone to see what happens.
The app itself doesn't have the permission to access the location in the list. It only has Notification permission (granted) and Photo & Video Permission (not granted).
The app itself doesn't have the permission to access the location in the list. It only has Notification permission (granted) and Photo & Video Permission (not granted).
In that case try disabling location services altogether, and reboot.
I have the impression that for some reason the app can kinda make a hole in the VPN protocol and see the real IP of the device (and thus send it to the streaming server). Maybe could the change of VPN protocol help?
which app are you using on your phone to connect to your VPN OpenServer ?
I just did a 4G test with OpenVPN Connect v3.3.4 on my Samsung Galaxy S10 and connected to my OpenVPN Server ("Both" parameter set-up) using TUN/UDP and the browser on the phone shows the correct IP of my router ... So the only thing I can see as you mentioned is that the app detects your real IP and bypass the VPN on the phone.
May be check "Seamless Tunnel" option in the VPN app on the phone.
as said, tick "seamless tunnel" and retest
It's probably getting your location from the cell tower information and/or the SIM card's MCC/MNC.

Try putting your phone into airplane mode and then switching on only the Wi-Fi.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!