What's new

RP-AX58: Poor speeds using AiMesh but ok in Access Point mode

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

psychopomp1

Senior Member
Hi,
I have an Asus XT12 which I'm using as the main router and 3 plug-in 'range extender' units, RP-AX58 which are connected via ethernet to the XT12. Each RP-AX58 is plugged in one of the 3 bedrooms as wifi coverage from the main router is extremely poor because of thick walls. My internet connection is 1000 down /250 Up Mbps

After setting up the RP-AX58 units as AiMesh nodes (3) with ethernet backhaul, I'm getting no more than 200 Mbps over Wifi 6 even when stood next to each range extender. However when I remove the units from the AiMesh system and set them up as Access Points (AP), then speeds jump to 800-900 Mbps over wifi 6. So why the huge difference in speeds between AiMesh and Access Point modes, despite nothing changing physically? Firmware on the RP -AX58 is up to date. Any suggestions?

Cheers
 
Hi,
I have an Asus XT12 which I'm using as the main router and 3 plug-in 'range extender' units, RP-AX58 which are connected via ethernet to the XT12. Each RP-AX58 is plugged in one of the 3 bedrooms as wifi coverage from the main router is extremely poor because of thick walls. My internet connection is 1000 down /250 Up Mbps

After setting up the RP-AX58 units as AiMesh nodes (3) with ethernet backhaul, I'm getting no more than 200 Mbps over Wifi 6 even when stood next to each range extender. However when I remove the units from the AiMesh system and set them up as Access Points (AP), then speeds jump to 800-900 Mbps over wifi 6. So why the huge difference in speeds between AiMesh and Access Point modes, despite nothing changing physically? Firmware on the RP -AX58 is up to date. Any suggestions?

Cheers

Did you enable AiMesh\Ethernet Backhaul Mode to disable the wireless backhauls... if they are ON (visible in Wireless Log), then wireless client connections get less throughput. That still may not improve on unknown issues.

OE
 
Disable AiMesh/System Settings/Ethernet Backhaul Mode. Also make sure Wireless/WPS is enabled. With an Ethernet connection the router/system will detect the wired connection and use it. It is my experience that letting the system run on "auto" mode is best. I also recommend using the default WIFI settings.
 
I'm guessing it has most to do with the router having a split 5GHz band and the nodes not. AP mode with common SSIDs works too well to ignore.
 
I'm guessing it has most to do with the router having a split 5GHz band and the nodes not. AP mode with common SSIDs works too well to ignore.
No, it is the Ethernet Backhaul Mode setting does not work well.
 
Never had a problem with ethernet backhaul, and never tried controlling a node with different radio radio topology (split vs. unified band) either. How does the controller with 5-1 and 5-2 deal with a foreign plain 5?
 
Thanks guys. I have disabled 'ethernet backhaul' setting in AiMesh settings but still can't get more than 200 Mbps from each extender. I wonder if the extenders channel bandwidth is set to 20/40 Mhz (instead of also including 80/160 Mhz)? But I believe the wifi settings of the extender can't be changed in Aimesh mode, like they can in AP mode? Is it worth asking Asus support to look into this?
 
If you don't /need/ a propagated guest network then, to me, AP mode is the better, more individually controllable setup anyway. The only downside is the requirement for such individual control as opposed to the one centralised location of the mesh.

I have such little care for the current mesh scheme that I haven't investigated my hypothesis where the controller, which selects channels and their bonding system-wide, can have a substantially different view of things than does a remote node, which may then be configured in a crippling manner. At least, presently, such a node can stand a better chance by itself deciding such parameters, acting as a "dumb" AP.
 
Dear, how are you doing? I have the same problem, yesterday I received two units of the RP-AX58 (one of them I updated the firmware and the other I left as it came from the factory) issue when using Aimesh I cannot go above 150mbps, instead I use it in Ap mode and there if the speeds I get are greater than 500mbps.
Could you guide me what it could be? I have an Asus AX11000 as my main router and a GT-AC5300 as a node.
 
Dear, how are you doing? I have the same problem, yesterday I received two units of the RP-AX58 (one of them I updated the firmware and the other I left as it came from the factory) issue when using Aimesh I cannot go above 150mbps, instead I use it in Ap mode and there if the speeds I get are greater than 500mbps.
Could you guide me what it could be? I have an Asus AX11000 as my main router and a GT-AC5300 as a node.
I think it could well be a firmware bug on the RP-AX58 as its a relatively new release. I've reported the issue to Asus via the GUI of the node, Administration>Feedback and yet to receive a reply.
 
Thank you very much for the response, I really appreciate it and I could see your post in the ASUS forums reporting the problem, but I don't think it is the firmware because I received two new units with the first firmware and exactly the same thing happens, obviously it is limited or has some drama, and it is really annoying that these devices fail, I don't understand why?
 
Why not just use them in AP mode instead? Works just as well, maybe even better since you can use different wifi bands on your equipment. If you have a lot of clients it might make a difference.
 
Heck, It'll make a noticeable difference with only a few clients if they do much talking to each other.
 
After tonnes of emails to & from Asus support they have come to the following conclusion:

Kindly refer below to our teams feedback.

1. The speed difference is caused by the AiMesh node operating in repeater mode.

In repeater mode, bandwidth needs to be divided for upstream and downstream, resulting in a halved performance. Additionally, with interference factors considered, only around 2xxM is left.
However, the benefit is the ability to roaming and the option to manage through the AiMesh system.

2. If you prioritize speed, it's recommended to set it to AP mode. However, in AP mode, roaming isn't supported, and each device needs to be individually configured.

Does that make sense?
 
It does NOT make sense. AImesh is just a marketing gimmick. The only advantage you get is that you can configure all nodes from the router. Using APs, they need to be configured separately.

By using APs instead of AImesh you get the advantages that you can use different Wifi bands for the nodes and you can adjust the transmit power to avoid too much of wifi overlap.

I have 1 router and 2 APs. Roaming works perfectly well and is 100% controlled by the client, not the router or the AP.
  1. All nodes should support 802.11k and 802.11v (which RT-AX58U does). If not, the roaming will be somewhat slower, but it works.
  2. Switch OFF Smart connect
  3. Use DIFFERENT SSIDs for 5 and 2.4 GHz (to avoid roaming to the slow 2.4 GHz band). Use the 2.4 GHz band for IOT devices and/or guests only.
  4. Set Protected Management Frames to Enable
  5. Set Roaming Assistant to Disable
  6. Set Airtime Fairness to Disable
  7. Set Universal Beamforming to Disable
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top