RT-AX88U Latest Firmware changed Country Code to DE?!

taltalon

New Around Here
Hi All,
I updated like 2 weeks ago to the latest firmware 3.0.0.4.386_48631-g10d88e5.
I started noticing sometimes that the 5Ghz WIFI disappears and some nodes - mostly Apple devices like my MacMini M1 and MacBook Pro 16", 2019 model will not reconnect automatically unless I manually click to reconnect or turn the WIFI settings ON to OFF to ON.
I am located in Israel. I bought the RT-AX88U in Israel from the official retailer here. The apple devices were bought in Israel as well.

as I had these weird WIFI issues now - I launched the Wireless Diagnostics app built in inside MacOS (Monterey here) - and I see there that when scanning for networks - my SSIDs are labeled with DE as country.
I never seen this before. Can this happen by the new firmware? The Macs WIFI card does connect and show Country: IL.
Other AP around me are labeled either EU or IL or "-".
Can this be a problem ?


I even tried hard factory reset (with the latest firmware still installed) and fresh new network setup. Still sometimes the 5Ghz WIFI simply disappears (I use channel 36, or 44 - 44 provides best performance for me) and I need to manually reconnect.
  • Should I roll back the Jan Firmware (I see many critical CVEs were fixed in the last one)
  • Should I use Merlin firmware instead of ASUS?

Thanks
Tal
 

ColinTaylor

Part of the Furniture
Can this be a problem ?
This is normal. AFAIK Israel uses the same WiFi channel rules as the EU therefore the router sold in your country has a generic European type configuration. The "DE" identification is just representative of this. Clients don't care about the country identifier. Many of the router's I have bought in the UK have had the same "DE" country code.

P.S. The country code is hard-coded into the router at manufacture. A firmware update doesn't change it.
 

taltalon

New Around Here
This is normal. AFAIK Israel uses the same WiFi channel rules as the EU therefore the router sold in your country has a generic European type configuration. The "DE" identification is just representative of this. Clients don't care about the country identifier. Many of the router's I have bought in the UK have had the same "DE" country code.

P.S. The country code is hard-coded into the router at manufacture. A firmware update doesn't change it.
Thanks for your prompt reply. very helpful. I know from previous experience with my previous Apple Extreme Airport router that I got from the US - is that if I configured them to use US Channel 149 and up - the Mac devices here will not reconnect to it after sleep or on SSID drop, because the AP is labeled as US and what is around me is IL/EU and Apple refuse to allow this reconnection. hard coded in their drivers. I just hope its not the same case again :cool:
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top