RTAC86U 384.17 major issues after upgrading

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JustTom

Occasional Visitor
Firstly - thanks to all who have contributed to Asuswrt-Merlin and custom scripts

I was running 384.16 perfectly fine with SkyNet, Diversion, Fresh JR QoS script. Updated today, loosly following L&LD's steps - didn't make config backups, and not all the setting changes suit me - but followed the important steps such as factory resets, reboots and JFFS format. Link bellow.

https://www.snbforums.com/threads/n...l-and-manual-configuration.27115/#post-205573

I also reformatted my USB which contained the Swap

However, since updating I have had serious problems. When I first connected via SSH and loaded up amtm I got -sh: can't fork error which isn't good. I did another factory reset and JFFS format. When that didnt help I reflashed 384.17

Since then I am getting regular can't fork errors and have given up trying to install any custom scripts since I just end up with can't fork errors and an inability to connect to the gui / reconnect ssh, without reboots. The router is stable ish as long as I don't try and load amtm or custom scripts.

Am I right in thinking this is a memory problem?

Currently I cannot access the GUI but have access to the internet. So I will do a reboot once posted...

What further steps can I take to fix this? And please let me know if I have messed up somehow so I won't do it again.

I am considering following L&LD's nuclear reset guide: https://www.snbforums.com/threads/major-issues-w-rt-ac86u.56342/page-4#post-495710 but would appreciate some advice from someone more experienced in these matters.

Edit: just connected via ssh after the reboot and was looking around the filesystem with df and ls. After about 30 seconds I could no longer use ls or df without getting can't fork errors which was followed by the web gui becoming inaccessable again.

Cheers,
Tom
 
Last edited:

ColinTaylor

Part of the Furniture
You have indeed run out of memory. I suggest that you unplug the USB drive and perform a WPS reset.

Power off the router. Press and hold the WPS button. Power on the router while holding the button. Wait 10 seconds and then release the button.

Now do a manual setup without any additional software to verify the router is stable.
 

JustTom

Occasional Visitor
Thanks Colin, I performed a WPS reset like you suggested and the router seems stable. I plan on leaving it for at least 12 hours to test the stability

After that I will see if I can load up amtm without getting errors.
 

JustTom

Occasional Visitor
So the router was pretty stable for 12 hours. The only issue I came aross was when changing USB to 2.0 mode, enabling https authentication and removing wan down redirect. The router required a manual reboot after the settings had been applied to access the web gui.

However after 12 hours, when I attempted to set up a 2gb SWAP file though the skynet installer on amtm I ran into issues.
Out of curiosity I opened up another terminal and used top to watch the memory usage as the script ran.

Memory usage climbed up to 412108k used 28312k free, after which I got can't fork errors.
I have done another manual reboot, disabled custom scripts and will format the jffs partition again.

Could this have anything to do with the usb? I will check it for errors using a linux vm but that will take some time.
 

JustTom

Occasional Visitor
I cannot see any errors in the syslog. I had set logging to errors only, and have now changed to debug.

I am now seeing constant dropped incoming packets but I assume that is background noise which my firewall is dropping as expected.

I'm currently zeroing the USB drive which was in the router so that will start afresh. When that is done I will re enable custom scripts and attempt to create a swapfile again whilst watching the syslog.
 

dosborne

Very Senior Member
Could be a bad or slow USB stick?

Personally, given the issues you are having, I'd avoid anything "extra" such as swap and scripts for a while. Make sure you can run a few days, then do 1 thing at a time giving it lots of time between changes.
 

L&LD

Part of the Furniture
@JustTom I would format the USB drive on a PC in NTFS format and also format the JFFS partition on the next boot and then reboot 3 times in the next 15 minutes, waiting 5 to 10 minutes between reboots too to fully start afresh. :)

While it is on the PC, I do a simple transfer of a large file to/from the USB drive (including testing after it is removed and re-inserted too, after that initial NTFS format) to see that it is nominally stable.
 

JustTom

Occasional Visitor
Thanks, L&LD will do.

Your right dosborne - i'll probably just order another usb off amazon and then try this all again when that arrives (leaving custom scripts off in the mean time to check system stability). I have a feeling its probably the USB at this point. This particluar one is a no frills SanDisk I wasn't using, I normally get Samsung.

Additionally i'm more than happy to attempt again and share the syslog with you.
 

JustTom

Occasional Visitor
Update on stability front - i'm now seeing 50% CPU usage being taken by acsd which I believe is the auto channel selection daemon. JFFS formatted in previous reboot, could that cause issues with acsd? (Kept scripts disabled as suggested by dosborne)

I have two other wireless AP in the house, one is set to channel 1, the other to channel 6 leaving the router to take up channel 11.
I normally leave the asus router on auto while manually setting the other two to stay on those channels.
No other wifi signals from neighbours etc

Occassionally the gui doesn't accept my password (odd because I use a password management program so no typos)

I'm going to follow L&LDs nuclear reset option tomorrow to the letter.
 

ColinTaylor

Part of the Furniture
Disable the automatic channel selection, it's known to sometimes cause problems. If there are no other nearby signals it serves no purpose over manual channel selection.
 

JustTom

Occasional Visitor
As advised I have left the router alone since I have performed numerous JFFS partion formats and full restores.
The new USB arrived today, however as soon as I enabled custom scripts and tried to load amtm I recieved 'can't fork' errors and access to gui ceases.

What on earth is going on?
The only thing I can think of is that my JFFS partition is not being formatted resulting in custom scripts trying to load without the swap file present when I enable custom scripts?
 

ColinTaylor

Part of the Furniture
Probably not related but you said earlier that you were seeing "constant dropped incoming packets" in the syslog. Do you have set "Logged packets type" to both or dropped? If so turn that off as it serves no useful purpose other than to create load on the router.

At this point if I were you I would go back to version 384.16 which you said worked and confirm that is still the case. It could simply be a bug in version 384.17 that you have no control over.
 

JustTom

Occasional Visitor
I didn't enable any logging of the firewall, and by that point had done numerous resets so it would have been set at factory default.

Currently about 3/4 of the way through a 'nuclear reset'. I'm going to keep it on 384.17 after the nuclear reset and try again so I can let you know of a possible bug if I'm still getting issues.

If issues persist I will downgrade and report back. :)
 

JustTom

Occasional Visitor
Well , I don't want to tempt fate but so far so good after a the nuclear reset. Amtm working fine alongside 2GB swap file.

Loaded up Diversion, Skynet and FreshJR QoS.
Wifi channels, dns etc set up.

Only issue that I run into was a 'no space left on the device' error but a power off at the wall solved that one. - I imagine there was some log file in the tmp directory causing it.

Thankyou all for the help, others have mentioned it but this community is excellent! I'll monitor the router closely over the next few days and let you know if any major errors occur.
Not really sure what caused this to happen - don't think it was the USB but could have been that alongside other errors on the device which the nuclear reset got rid off.
 

JustTom

Occasional Visitor
Okay there is still an issue hanging around.

I'm getting 'no space errors' reported from skynet and diversion. Looking at the directories tmpfs mounted on /var is full with around 220208 kilobytes used. So it appears to be a rogue log file.

Filesystem 1K-blocks Used Available Use% Mounted on
ubi:rootfs_ubifs 79016 65400 13616 83% /
devtmpfs 220096 0 220096 0% /dev
tmpfs 220208 220208 0 100% /var
tmpfs 220208 1848 218360 1% /tmp/mnt
mtd:bootfs 4480 3356 1124 75% /bootfs
tmpfs 220208 1848 218360 1% /tmp/mnt
mtd:data 8192 604 7588 7% /data
tmpfs 220208 1848 218360 1% /tmp
/dev/mtdblock8 49152 5912 43240 12% /jffs
/dev/sda1 30702664 2192428 26927544 8% /tmp/mnt/Samsung
/dev/mtdblock8 49152 5912 43240 12% /www/QoS_Stats.asp
tmpfs 220208 1848 218360 1% /www/index_style.css
tmpfs 220208 1848 218360 1% /www/require/modules/mes....

Causing errors such as these in systemlog.

May 5 13:17:01 dnsmasq-dhcp[1929]: failed to write /var/lib/misc/dnsmasq.leases: No space left on device (retry in 60s)
May 5 13:18:01 dnsmasq-dhcp[1929]: failed to write /var/lib/misc/dnsmasq.leases: No space left on device (retry in 60s)
May 5 13:19:01 dnsmasq-dhcp[1929]: failed to write /var/lib/misc/dnsmasq.leases: No space left on device (retry in 60s)

Hunting down the rogue file I find it is log.nmbd in /var/log - which according to google is part of samba. Now I have not touched samba settings on this router ever.

I do have a samba share running on another linux device on my network however.
 

JustTom

Occasional Visitor
Exploring the log file, I can see it is being progated with this error:

process_name_registration_request: unicast name registration request received for name SEC001599362BEA<20> from IP 192.168.1.100 on subnet UNICAST_SUBNET. Error - should be sent to WINS server
[2020/05/05 02:00:04, 0] nmbd/nmbd_incomingrequests.c:213(process_name_registration_request)
process_name_registration_request: unicast name registration request received for name SEC001599362BEA<00> from IP 192.168.1.100 on subnet UNICAST_SUBNET. Error - should be sent to WINS server
[2020/05/05 02:00:04, 0] nmbd/nmbd_incomingrequests.c:213(process_name_registration_request)
process_name_registration_request: unicast name registration request received for name SEC001599362BEA<20> from IP 192.168.1.100 on subnet UNICAST_SUBNET. Error - should be sent to WINS server

That particular device (192.168.1.100) is a samsung printer
No new changes have been made to the device, however I have turned it off for now and rebooted the router to clear the log file.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top