What's new

Solved Solved (for me): WiFi issues and/or crashes with Merlin on RT-AC86U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
With all of your help - THANK YOU - and a lot of careful A/B testing (where A was Asus firmware and B was Merlin) I can now confirm, that my router has been completely stable for 24 days now without a crash, WiFi failing, running out of memory or over temperature:

Firmware: Merlin 386.12_4
Uptime (so far): 24 days
Memory usage now: 302MB (290MB at first boot 24 days ago)
Temps: CPU 78C, 2.4/5Ghz Wifi 46C (ambient room temperature 19C, no extra router cooling)

Folk may remember, that I finally narrowed down a possible external issue with the AsusWRT integration in Home Assistant: https://www.snbforums.com/threads/l...-386-12-1-2-3-4-running-home-assistant.87985/

This now seems to be confirmed here: https://github.com/home-assistant/core/issues/103230 but note, at the end, an interesting discussion about a aioasuswrt connection leak and a "misleading option "Idle timeout" under SSH server config" - but I don't understand any of this.

Anyhow, removing the AsusWRT integration in Home Assistant has cured my particular problem and I would suggest, that anyone who is suffering from this and who is not running Home Assistant, should check that they don't have any other network devices/monitoring (like Mikrotik Dude) doing SSH connections.
Thank you for this, I had been having issues - just turned it off in Home Assistant so let’s see how long I can go for.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!