Strange network issue, faulty switch or possible other issue?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

manhas

New Around Here
Not sure if this was posted in the correct section, please move it if it belongs somewhere else.

TL;DR
When my AppleTV is connected to the switch and it puts load on the network, other ethernet devices connected to the switch experience packet loss to/from my NAS that's connected directly to the router, but only against the NAS, not other devices. If the switch is bypassed or if the AppleTV uses WiFI this does not happen, also other devices putting load on the network does not cause packet loss, only when the AppleTV does it.

Is the switch faulty or are there any other possible issues?


Longer version:

This is my network setup:

Router: RT-AC68U with 384.16 merlin, with 2.4GHz/5Ghz enabled
  • WAN port connected
  • Ethernet port 1: PiServer with HomeAssistant and UniFi Controller
  • Ethernet port 2: Synology Diskstation DS414, DSM 6.2.2-24922 Update 4
  • Ethernet port 3: MacMini 2010 running Plex Server
  • Ethernet port 4: Switch TP-Link TL-SG108 (unmanaged)
Switch: Switch TP-Link TL-SG108 (unmanaged)
  • Workstation (iMac)
  • AppleTV 4k
  • UniFi AP-AC-Pro, version 4.0.80.10875
  • 5 x Unused network outlets in various rooms

All devices connected to the switch will get dropped packets if they ping the NAS whenever the AppleTV (also connected to the switch) puts load on the network. If the AppleTV start playing a 720p/1080p video over the local network (from the NAS via the PlexServer), if it's streaming using Netflix, or if the AppleTV does an internet speed test, other devices connected to the switch will experience packet drops when they ping the NAS. Pinging any other device on the network at the same time is unaffected. If another device (e.g. my workstation) put load on the network the network is unaffected, it's only load from the AppleTV that causes the issue. If I SSH to the NAS and ping the workstation I get similar packet drops, so it goes both ways.

If the AppleTV connects through WiFi instead of the switch the issues are gone, also if I bypass the switch completely with the devices connected directly to the router there are no issues either.

So to summarize:

- Only issues when the AppleTV put load on the network and is connected to the switch.
- Only devices connected to the switch have issues with the NAS.
- Only connection/ping to/from the NAS is affected, no issues connecting to other devices.
- If the switch is removed and connecting directly to the router, there are no issues between devices.

- I've tried different ports on the router, NAS and the switch.
- I've tried 4-5 different cables.
- All ethernet connected devices have manually assigned IP addresses.
- It does not appear to be any IP conflicts on the network.


Is the switch the likely cause or could it be something else?

If it wasn't for the NAS being the only device I have issues to/from I would assume it was the switch that is faulty. But I find it strange that the AppleTV and the switch causes problems to/from a devices that's connected directly to the router and that other devices connected the same way or using the same port/cables are problem free.
 

degrub

Very Senior Member
that switch only does 11.9 Mpackets/sec. It does not say "non-blocking" or " full duplex " for the bit rate. Do you have any QOS on ? or did you just power it up ?

you want a switched bit rate total throughput = # of ports x 2 gigabit/sec. So it may be that the switch is getting saturated. Your tests seem to indicate that. You can get another unmanaged switch that is full line rate, full duplex , non-blocking for 30-60 USD.. Netgear Pro or business switches will give non-blocking full line rate. there are others.
 

manhas

New Around Here
It's just powered up, the specification states that it features "IEEE 802.1P QoS" so I assume there is some kind of QoS enabled there that isn't configurable since it's unmanaged.

This isn't my area of expertise, so perhaps I'm way off here, but doesn't the following specification meet the requirements you listed above? It has 16Gbps switching capacity so 2x8 and also lists full duplex.


8-Port 10/100/1000Mbps Desktop Switch TL-SG108
Features & Performance

Switching Capacity: 16Gbps
MAC Address Table: 4K
Packet Forwarding Rate: 11.9Mpps
Buffer Memory: 1.5MB
Jumbo Frame: 15KB
Advanced features: IGMP Snooping, QoS (802.1p/DSCP Priority)

Data Transfer Rate
Ethernet: 10Mbps (Half Duplex), 20Mbps (Full Duplex)
Fast Ethernet: 100Mbps (Half Duplex), 200Mbps (Full Duplex)
Gigabit Ethernet: 2000Mbps (Full Duplex)
 

degrub

Very Senior Member
What is the version number of the switch ? they are up to V4 on the support web listing.

Here is a troubleshooting guide on their support pages
https://www.tp-link.com/us/support/faq/737/


are you using the standard default MTU of 1500 bytes or are you running jumbo frames on any of your devices ?
i think your testing has narrowed it down to the switch. It may be a configuration mismatch with the router or other devices on the lan or a hardware issue.
 

coxhaus

Part of the Furniture
I run an AppleTV 4K into a Cisco switch with no problems that I have seen. In fact I recommend running an AppleTV off a switch.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top