Traditional QoS kills router throughput, internet/LAN traffic unaffected

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

dawt

New Around Here
Description:
Enabling Traditional QoS kills throughput for traffic to/from the router itself (eg. built-in FTP server). By "kill", I mean getting throughput of ~100KB/s, whereas with QoS off I'm getting > 20MB/s. Traffic from LAN devices to the internet, or LAN devices to other LAN devices are affected, but nowhere to the extent I see with LAN to router traffic (eg. LAN to LAN I only get 30-40MB/s). This is all over a wired connection and I can reproduce issue with the latest stable firmware and after a factory reset (see steps to reproduce).

What's strange is that this issue appears after a fresh reboot, but logging into the web interface and navigating to the QoS page somehow fixes this. I traced it down to the /getTraffic.asp url. In other words, after a reboot I get slow speeds, but I get much faster speeds if I log into the web interface and visit only the /getTraffic.asp page. The speeds are nowhere as good as the non-QOS speeds, but I'm guessing that's from the inherent overhead of QoS. Furthermore, not connecting the WAN somehow causes the issue to not appear, independently of the /getTraffic.asp fix.

I searched around the forums and it looks like Traditional QoS is fundamentally broken or something and it's hard to fix. Since visiting the /getTraffic.asp seems to fix it, is it possible to add a workaround by automatically visiting that page, or better yet calling the underlying function of bwdpi_status() on startup?

Steps to reproduce:
1. navigate to the firmware update page and upload RT-AC68U_386.3_2.trx (current stable version)
2. after upload success, perform factory reset (using the hold WPS button method https://www.asus.com/support/FAQ/1039077)
3. go through the setup wizard as normal (router mode, DHCP mode for WAN, WAN cable is plugged in).
4. log into web ui, enable built-in FTP server
5. perform speed test by downloading a file from the built-in FTP server [I get around 30-40MB/s throughput at this step]
6. enable traditional QoS (this causes a reboot)
7. perform speed test again [I get 100KB/s download at this step]
8. log into web interface, visit the /getTraffic.asp page
9. perform speed test again [I get 30-40MB/s at this step]

Expected results:
I get good speeds (ie. not 100KB/s) from the router at all times, even after a fresh reboot

Actual results:
I get crap speeds from the router after a reboot, unless I visit the getTraffic.asp in which case it's magically fixed.
 

dawt

New Around Here
I'll try that, but given that this has such a trivial fix (adding a few lines of code somewhere) I hope RMerl add it to the core code.
 

Tech9

Very Senior Member
FlexQoS is Adaptive QoS custom configuration script. It will work, but I don’t think is necessary. It won’t fix the described issue, if Adaptive QoS doesn’t fix it. I’m not sure why the OP uses Traditional QoS. It’s incompatible with hardware acceleration.
 

dawt

New Around Here
I’m not sure why the OP uses Traditional QoS. It’s incompatible with hardware acceleration.
The non-hardware accelerated speeds are fine for me, and I don't want to consent to trendmicro's data collection.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top