What's new

QOS Cake with merlin and MTU - slow download speeds / inconsistent mtu fragmentation results

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

icanfly

Occasional Visitor
Hi all

I am trying to get my ASUS RT-AX88U router set to optimal because everyone always tells me when I use wifi calling I sound like I am underwater

It happens with two different Samsung phones (different models) both on Optus.

It might be a QOS issue and I also I tried playing around with MTU as well and I thought I had that set right but now thats playing up too.

The other day I did the Blufferboat test and got an A. Now I am getting a B but then tried again and got an A+ (That's the first time I've gotten that with QOS turned off) - Just did another test straight after and back to an A again (https://www.waveform.com/tools/bufferbloat)

In short here is what is going on I hope someone can help

on my NAT Passthrough, I have set:
PPTP Passthrough, L2TP Passthrough, IPSec Passthrough all Enabled
RTSP and F.323 Passthrough – Enabled + NAT helper
SIP Passthrough -Disable
PPPOe Relay – Disable
FTP AlG port – 2021

(Im assuming all those VPN protocols need to be enabled. I work from home using BIP Edge IP client for my work so I need this to be able to work)

A long time ago, I did the MTU test to see the optimal with no fragmentation and I had it set at 1492 before (ping -f -l 1492 www.google.com)

but now I am getting fragmentation with that MTU so I kept trying lowering the MTU and got a figure of 1436 now with no fragmentation but the problem is I went and set MTU and MRU to 1436 and reboot but now when I do the ping test at 1436 it gets fragmentation again!
and then testing again it told me 1408 was the optimal so I set it at that and then 1408 gets fragmented!

Lastly, I tried playing around with QOS Cake. I have FTTP 1000/50 speeds tests usually yield around 900 – 930 so I set the upload and download to 95% 107 / 45

But now on my speed tests I am only getting 50 mbps down! Upload is still good though


So for now I have gone back to 1492 MTU and QOS even though I get fragmentation with that MTU but everything else except wifi calling is working fine but I really would like to solve that!

Cheers!
 
Last edited:
1492 MTU suggests that your using pppoe. Under these conditions fragmentation is normal because most client devices will be using 1500 LAN MTU and fragmentation converts the MTU from 1500 to the WAN MTU 1492. Even if you set your MTU to 1500 on a pppoe connection it will forcibly default to 1492. You can optimize your MTU, but that doesn’t really matter much for bufferbloat. When setting up cake it’s going to ask for your speed.

For cake-qos start with QOS disabled limit your devices to one device connected to the router, and do a speed test from the router to get a idea of what your true speed is; it should be close to what your ISP plan is rated for give or take 1 Mbps. With QoS off Nat hardware acceleration is enabled which will help you hit your line speeds. Cake does not use hardware acceleration so speeds may drop a bit. Assuming your internet is synchronous meaning the upload speed and download speed are the same set cake 1 Mbps lower than what your speed test says. Or 95% as you’ve done.


Well not relevant to you ADSL, VDSL ect will fluctuate in speed due to Signal to Noise ratio and Line Attenuation during sync which changes with line conditions. This may affect the speed you set in cake setting a lower speed will increase the bufferbloat score, but at the cost of usable speed. Meaning your speed test will show lower speeds.

Also if you have bandwidth monitor on your router setting the priority bulk, standard, high, very high. Will change the priority of speed each device gets and may change the results of a bufferbloat or speedtest.

In the case if dsl users using pppoe if your line is not synchronous then too low an upload speed available may affect your download speed performance if someone is uploading. Often the case with say 10 down 1 up due to TCP requiring a reply for each packet. DSL also uses ATM mode which can lower usable speeds to keep stability. [ In your case you use fibre upload was fine using Cake because 50Mbps doesn’t tax your cpu as hard as 1000Mbps when hardware acceleration is disabled.]

Fibre lines over pppoe usually don’t have this issue like dsl users because often the line speeds are much higher, and probably shouldn’t be using ATM mode instead PTM mode, and on a single fibre line upload and download are on two different frequencies so there is no collision when upload and download packets are sent. Meaning they are not fighting for bandwidth on the same line.

Hope this helps.

Edit:

With your speeds being non-synchronized fibre 1000/50 and using cake it’s not going to use hardware acceleration so it could be a matter of your router cpu being taxed that your bufferbloat / speedtest results are mixed.

Personally I use a MTU of 9014 on my client devices which is then fragmented down to 1492 soon as it hits the WAN. Still get a A+ score on bufferbloat test. Jumbo frames enabled allows larger faster file transfer over Ethernet LAN to tax you clients cpu less because the payload per packet is larger, but may not be optimal for smaller files. With Jumbo frames enabled the routers LAN should be rated for 16000 MTU so anything within that should be fine ie. 9014 on each client provided your clients have the same MTU on each device IF you’re talking to each-other for file transfers otherwise fragmentation occurs. Jumbo frames only work with Ethernet so your wireless clients will always be 1500 MTU. So if one client is 9014 MTU talking to a 1500 MTU client over wireless it’s going to fragment. Same with WAN, wireless 1500 MTU will fragment down to 1492 WAN.

If you’re having issues with wifi calling I would enable SIP pass through. Not certain that’s what wifi calling uses for voip.
 
Last edited:
Here’s mine on cake I’m rated for 16 down / 16 up on fibre pppoe. (I can get 1G down 1G up, but don’t want to pay the prices my ISP offers).

IMG_0177.jpeg


If you set the speed too high cake won’t work and you’ll get a non-cake bufferbloat rating or worse. I also use PTM instead of ATM. ATM will ensure a better score, but will likely reduce your usable speed.

IMG_0178.jpeg


If you haven’t already add the cake-qos gui.

 
Last edited:
Here’s mine on cake I’m rated for 16 down / 16 up on fibre pppoe. (I can get 1G down 1G up, but don’t want to pay the prices my ISP offers).

View attachment 56585

If you set the speed too high cake won’t work and you’ll get a non-cake bufferbloat rating or worse. I also use PTM instead of ATM. ATM will ensure a better score, but will likely reduce your usable speed.

View attachment 56586

If you haven’t already add the cake-qos gui.

[QUOTE="DJones, post: 893346, memb.../github.com/ttgapers/cakeqos-merlin [/QUOTE]

[/URL]
Thanks I have set upload down to 35 and download to 900 and still only getting 350 down so I am not sure what I need to do. The speedtest before I turned cake back on was 45 up and 908 down. I installed the cake gui but havent played with any of the settings. it did say before I install cake gui to uninstall the legacy script but I dont think that applies I havent installed cake gui before?

so Im not sure what I need to set for the WAN packet overhead and MPU and Mode, and the priorities and other options but I will try putting same as yours

Thanks
 
Thanks I have set upload down to 35 and download to 900 and still only getting 350 down so I am not sure what I need to do. The speedtest before I turned cake back on was 45 up and 908 down. I installed the cake gui but havent played with any of the settings. it did say before I install cake gui to uninstall the legacy script but I dont think that applies I havent installed cake gui before?

so Im not sure what I need to set for the WAN packet overhead and MPU and Mode, and the priorities and other options but I will try putting same as yours

Thanks

Legacy script doesn’t apply. I would maybe try turning off nat acceleration with QoS off to see how the router fairs for a speedtest that way you can determine where 95% stands on true speeds. Without NAT acceleration your speeds will be cut regardless because the router simply isn’t strong enough to push those speeds with cake. But if cake is what you want to achieve better bufferbloat scores and fairness on your network then you’re going to have to play around with the settings to see what kinds of speeds you can get. Personally unless you’re having a ton of congestion from client devices using too much speed I’d just leave QoS off at your speeds. But if you have devices that leach then maybe QoS and bufferbloat is a concern.

I can’t remember the ssh command to disable nat acceleration temporarily. Someone here might know.

MPU can remain blank. Besides the manual speed you can mirror my settings.
 
Legacy script doesn’t apply. I would maybe try turning off nat acceleration with QoS off to see how the router fairs for a speedtest that way you can determine where 95% stands on true speeds. Without NAT acceleration your speeds will be cut regardless because the router simply isn’t strong enough to push those speeds with cake. But if cake is what you want to achieve better bufferbloat scores and fairness on your network then you’re going to have to play around with the settings to see what kinds of speeds you can get. Personally unless you’re having a ton of congestion from client devices using too much speed I’d just leave QoS off at your speeds. But if you have devices that leach then maybe QoS and bufferbloat is a concern.

I can’t remember the ssh command to disable nat acceleration temporarily. Someone here might know.

MPU can remain blank. Besides the manual speed you can mirror my settings.
I dont think I have NAT acceleration as a setting anymore? its not in WAN or QoS

anyway Ive given up and turned off QOS for now (again!)

Thanks for your help
 
I dont think I have NAT acceleration as a setting anymore? its not in WAN or QoS

anyway Ive given up and turned off QOS for now (again!)

Thanks for your help

IMG_0179.jpeg

For reference NAT acceleration status is located under tools - sysinfo

No problem.
 
Could it be, might it be, that Wifi Calling is a VoIP protocol that requires SIP Passthrough enabled?

Further, if you dig into Cake, you might find that people with WAN connections greater than a few hundred Mbps had issues; in fact, it's likely that you'll find arguments that QoS on the DL of a Gigabit connection only causes more problems than you might hope it solves.
 
One other thing to consider - rule out your network if possible by trying WiFi calling on another Wireless LAN, like the local starbucks for example...

Some phones just don't perform well on WiFi calling...
 
Traditional or Cake QoS, bandwidth limiter etc. are hardware NAT acceleration incompatible (Runner and Flow Cache disabled). Router speed limit is ~350-400Mbps.

This is also a valid point - QoS will shed packets as needed to maintain quality across all flows...

HW accel like CTF and Runner, operate under the assumption that no packets can be discarded once the traffic flow is assigned the fast path...
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top