Unable to set lan mac address on RT-AC88U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Palanivelrajan

New Around Here
I got a new AC88u router yesterday. The first thing i did was install asus-merlin latest firmare. (384.17).

My internet provided will work only with a specific mac address. Before this router i had a AC68u router and the way i setup the access address is

Code:
#!/bin/sh

nvram set et0macaddr=88:71:B1:XX:XX:XX
nvram commit
reboot

exit 0
I got this from the forum sometime back. This did not work for RT-AC88U. So i searched around and found that RT-AC88U did not have et0macaddr, so i tried this one.

Code:
#!/bin/sh

ATT_MACADDR=88:71:B1:XX:XX:XX

nvram set et0macaddr=$ATT_MACADDR
nvram set et1macaddr=$ATT_MACADDR
nvram set et2macaddr=$ATT_MACADDR
nvram set lan_hwaddr=$ATT_MACADDR
nvram set 0:macaddr=$ATT_MACADDR
nvram set label_mac=$ATT_MACADDR
nvram set wan0_hwaddr=$ATT_MACADDR
nvram commit
reboot

exit 0
After doing this, the updated MAC show in the UI. But rebooting the router sets it back to the original mac addess that came with the asus device. Basically my changes are reset to default after a reboot. Do you know the correct way to set the mac address?

By the way, i also tried to set the mac address in WAN setting. That does not work either.

Any suggestions?
 

Attachments

Palanivelrajan

New Around Here
Hey. My bad. The WAN Mac address option in the UI worked. Sorry for the false alarm.

Sent from my Pixel 2 using Tapatalk
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top