vpnmgr vpnmgr - Manage and update VPN Client configurations for NordVPN and PIA

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Which VPN provider do you use?


  • Total voters
    179

Jack Yaz

Part of the Furniture
I found a reddit reply from pia support from just over a month ago where they gave this link. Not sure which option is "next gen"... It seems to suggest some are and some aren't - maybe they're in the process of moving servers over! I also found posts where linux users have experienced issues although (unspecified) "routers" may be ok.
I did discover they'd renamed their openvpn files, that was a PItA (see what I did there? :D) to update. v2.2.0 coming soon
 

Jack Yaz

Part of the Furniture
I'll add it as a feature request on my to-do list
That’d be awesome if we could specify the percentage value at what I’d like to change the server to a recommended one from the same country or automatic... and that check to run every so often. As far as I’m aware right now the gui scheduler doesn’t accept “*/5” every 5 min check. Only once a day at certain time. Please correct if I’m wrong. I know that it could be modified with cru, but then I’ll have a server change every 5 min say.
Worth pointing out you can specify hours and minute ranges currently, but it would simply query for a new server regardless of current server load (i.e. anything over 0% load)
For */5 you would specify 5,10,15,20,25,30,35,40,45,50,55
for the minutes, and hours as *
 

roger33

New Around Here
Hi,

I am trying to install vpnmgr but in the terminal I receive this warning / error:
vpnmgr: Entware not detected!

I searched if someone had a similar problem but couldn't find an answer related to vpnmgr.
What do you suggest I should do?

I am kinda new here so pls be patient :)
Thank you
 
Last edited:

Jack Yaz

Part of the Furniture
Hi,

I am trying to install vpnmgr but in the terminal I receive this warning / error:
vpnmgr: Entware not detected!

I searched if someone had a similar problem but couldn't find an answer related to vpnmgr.
What do you suggest I should do?

I am kinda new here so pls be patient :)
Thank you
You need a USB plugged in to the router, and then to install entware. You can do this by running the
Code:
amtm
command, then selecting option i , followed by option ep
 

L&LD

Part of the Furniture

sambosoul

Occasional Visitor
Hello everyone,

i managed to get vpnmgr fully installed and everything is working perfectly fine :)
just to confirm my understanding, this morning I logged into the router and saw that the vpnmgr tab disappeared from the VPN menu. I do know that I had a brief power outage last night and the router must have restarted. I did remove the usb drive after the initial vpnmgr installation so when the router restarted, the usb drive was disconnected.

in essence, does the usb drive have to be connected at all times? How do I get the vpnmgr add-on enabled again? Apologies for these basic questions but it’s the first time I am working with scripts.

any advise is highly appreciated
 

L&LD

Part of the Furniture
Yes, the USB drive must stay attached to the router. Do not remove it. :)
 

sambosoul

Occasional Visitor
Yes, the USB drive must stay attached to the router. Do not remove it. :)

Thanks L&LD, reconnected the drive and rebooted router, automatic mount of vpnmgr completed. All working again ;)

Say, would it be possible that you include a little development roadmap on Github, you know, so that we know what we can look forward to in future? That would be great :cool:
 

BreakingDad

Senior Member
Other - cyberghost
 

roger33

New Around Here
I managed to install diversion (entware included), then vpnmgr and YazFi on the USB drive. Thanks for ur hint Jack and L&LD.

Is it possible to setup:
1. Guest WiFi 1 with VPN (server A)
2. Guest WiFi 2 with NO VPN
3. The main connection( I do not know how to call it) with VPN (server B) ?

Point 1 works. But 2&3 don’t, even if I played for a few hours :)

I tried searching and also skimming through the official thread but I could not find the right key words.
Thanks for your time.
 

ex99125b

New Around Here
Thank you for your hard work. (Paypal on the way)
VpnMgr is my first script install, all seems to be running fine. Im using Nordvpn and Im wondering about schedule days; what seems to be the consensus on how often to run it? Currently I have it set to the same as the screenshot on Git, every day, 2 hrs, 2 minutes. But honestly I dont know why.
When installed it was at 0 hours, 1 min...I assume that means the manager runs every minute, Im ok with that as long as it doesnt interrupt the connection unless it needs to change servers.

What appears to be the overhead/down time for checking Nords API and also overhead/downtime for changing servers?

Thanks in advance for any help.
AC66U-B1 (now with added USB stick!)
184.19
NordVpn

UPDATE: So apparently setting the hours to (for example) 2,4,6,8,10 works (mins to 0)
Screen Shot 2021-01-22 at 5.02.36 PM.png
 
Last edited:

roger33

New Around Here
I managed to install diversion (entware included), then vpnmgr and YazFi on the USB drive. Thanks for ur hint Jack and L&LD.

Is it possible to setup:
1. Guest WiFi 1 with VPN (server A)
2. Guest WiFi 2 with NO VPN
3. The main connection( I do not know how to call it) with VPN (server B) ?

Point 1 works. But 2&3 don’t, even if I played for a few hours :)

I tried searching and also skimming through the official thread but I could not find the right key words.
Thanks for your time.

Hi guys,

I come back to this post b/c I do not have very extended knowledge about subnets and how to make vpnmgr work as I wanted to.
Please read my post and if I am not clear just let me know and I'll exaplain more.

Guest 1: setup for VPN server 1 (what ever Nord VPN picks). Subnet 192.168.2.0
Guest 2: I want no VPN, just normal internet through my ISP. Subnet 192.168.5.0. This does not work.
Main connection: I want it to be with VPN, but I do not know how to configure it !?



1611218608113.png
1611218631435.png


VPN 1:
1611219422922.png
1611219472608.png


VPN 2:
1611219646842.png
 

cplay

Senior Member

JT Strickland

Senior Member
Are there any advantages for users of unsupported VPN providers?
 

CaptainSTX

Part of the Furniture
After reading some comments regarding VPN tunnels on guest network I decided to check mine.

AC86 running 384.19 (Running scripts but not YazFi nor do I have any blocks on IoT devices communicating.)

Devices connected to my guest network (IoT devices) are not being routed using VPN tunnel even though strict policy based routing is in place. Tested on all three 2.4 Ghz guest networks still no VPN connection. If I connect the same device to my primary network it is routed using the VPN tunnel based on its static IP.

I had installed VPNmgr but was not using it to manage my VPNs. Removed VPNmgr using the built in option to do so but the removal wasn't complete. After removal It left the VPNmgr tab and the first two rows (Version and cached data) but more importantly IoT devices still not connecting using VPN tunnel.

Wife doesn't have the patience to let me give the router a lobotomy right now by doing a factory reset and reformat NVRAM looks like what it is going to take to see if I can get IoT devices back using VPN tunnel. Not sure that tunnels were working before VPNmgr but until I can remove all its artifacts.
 

Jack Yaz

Part of the Furniture
After reading some comments regarding VPN tunnels on guest network I decided to check mine.

AC86 running 384.19 (Running scripts but not YazFi nor do I have any blocks on IoT devices communicating.)

Devices connected to my guest network (IoT devices) are not being routed using VPN tunnel even though strict policy based routing is in place. Tested on all three 2.4 Ghz guest networks still no VPN connection. If I connect the same device to my primary network it is routed using the VPN tunnel based on its static IP.

I had installed VPNmgr but was not using it to manage my VPNs. Removed VPNmgr using the built in option to do so but the removal wasn't complete. After removal It left the VPNmgr tab and the first two rows (Version and cached data) but more importantly IoT devices still not connecting using VPN tunnel.

Wife doesn't have the patience to let me give the router a lobotomy right now by doing a factory reset and reformat NVRAM looks like what it is going to take to see if I can get IoT devices back using VPN tunnel. Not sure that tunnels were working before VPNmgr but until I can remove all its artifacts.
vpnmgr doesn't touch routing at all, merely automates configuring an OpenVPN client
 

Similar threads

Top