Windows doesn't connect automatically and when it does picks up weaker node in mesh network

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

deepskydiver

Occasional Visitor
Hi all,

Running Windows 10 updated to current with a TP-Link AC1200.
I have two Asus routers one acting as a node. The stronger signal is in the low 50s dba and the weaker one low 70s.
First, about half the time when I reboot or wake my PC reboot from sleep there is no network until I manually connect. When doing so that network is already marked to connect automatically.
Then when connected it connects to the weaker of the 2 networks in my mesh network and holds that for 5 or so minutes where I have difficulty in remote sessions until it switches to the stronger signal.
Does anyone have experience with these sort of issues?
 

L&LD

Part of the Furniture
Remove the nodes from the AiMesh setup. Fully reset those routers (I prefer the WPS method appropriate for the router in question).

Re-associate the nodes to the network.
 

airgap

Occasional Visitor
and also look roaming settings your wifi card. Sometimes it helps to set the roaming "aggressiv". Just try if it makes it worse then revert back.
 

deepskydiver

Occasional Visitor
Thank you both.

Here's what I've tried:
* resetting Windows network settings
* deleting the network profiles (which curiously do not get deleted when resetting network settings)
* reset the mesh node

No difference unfortunately.

There is no setting for roaming aggressiveness in device manager, the only options listed are:
* Beacon Interval
* Preamble mode
* Wireless Mode

There are no other options to set I can find.
 

noah way

Regular Contributor
Set the nodes as different SSIDs and only allow the computer to connect to the stronger one. You can also play with router location and antenna direction, even small adjusments can have large effects.
 

L&LD

Part of the Furniture
How did you reset the mesh node?
 

deepskydiver

Occasional Visitor
I don't have control over the node's SSID. It's ASUS AiMesh and of course the purpose of a mesh network is that they all have the same SSID.
I have already disabled the ability to turn off the wifi card to save power.
When my PC just woke up it lost the internet and intermittently showed a network with no internet or no network for 5 minutes. It's just ridiculous..
 

thiggins

Mr. Easy
Staff member
Remove the nodes from the AiMesh setup. Fully reset those routers (I prefer the WPS method appropriate for the router in question).

Re-associate the nodes to the network.
How would this help? What do you think is happening?
 

noah way

Regular Contributor
I don't have control over the node's SSID. It's ASUS AiMesh and of course the purpose of a mesh network is that they all have the same SSID.
I have already disabled the ability to turn off the wifi card to save power.
When my PC just woke up it lost the internet and intermittently showed a network with no internet or no network for 5 minutes. It's just ridiculous..
You can set the node to be a repeater, and then set it to a different SSID. Performance is exactly the same, the difference is you will have full control of the repeater.

A repeater can use the same SSID as the router.
 

L&LD

Part of the Furniture
How would this help? What do you think is happening?

Just from observing various AiMesh set ups, it seems that occasionally the settings shared between the routers somehow get corrupted out of sync.

I've seen this with all combination of RT-AC86U, RT-AC68U, RT-AX88U, RT-AC66U_B1, RT-AC3100, and even my two RT-AX86U's too.

Removing the nodes via the GUI, and then re-associating them again gets the network fast, stable and working as expected again.
 

airgap

Occasional Visitor
There is no setting for roaming aggressiveness in device manager, the only options listed are:
* Beacon Interval
* Preamble mode
* Wireless Mode

There are no other options to set I can find.

What wifi module (vendor & model) is installed on your computer?

I guess realtek :rolleyes: but don't worry intel has sometimes bad models also :D
 

deepskydiver

Occasional Visitor
@airgap I have a TP-Link AC1200.
I originally bought an ASUS PCE-AX3000 but despite all options being to the contrary it always came out of sleep with no network connection.
I'll try disconnecting the node again @L&LD
@"noah way" I don't know how to implement your your suggestion or why a repeater would be any more successful if it has the same Network ID? I'm using Merlin on an RT-AC86U though have a new AX88U I want to move to as the main router. The node is a Blue Cave.
 

airgap

Occasional Visitor
@airgap I have a TP-Link AC1200.
I originally bought an ASUS PCE-AX3000 but despite all options being to the contrary it always came out of sleep with no network connection.

OK I guess there is a misunderstanding what I asked for - I should have been clear what I asked for.

With wifi module I am refering to the exact chip which is used.

In your case it seems to be a small mini-pcie module which is installed on a an pci-e adapter to connect to your computer internaly.

May be you have to open your computer and have look on the chip! So it's important to know which vendor a model is being used as chip for wifi.

Here just an example: https://www.amazon.com/dp/B08C69GKSV/?tag=snbforums-20
 

airgap

Occasional Visitor
Thank you. Well the old "not-so-well" chips :D

Did you update/upgrade the driver(s)? Which one are you using right now?
 

deepskydiver

Occasional Visitor
Thank you. Well the old "not-so-well" chips :D

Did you update/upgrade the driver(s)? Which one are you using right now?
It's just hat source from Windows updates.
Showing as "2023.70.0109.2018"

1624862449960.png
 

airgap

Occasional Visitor
OK. To be honest I am almost sure that the issue is related to your TP Link and the realtek chip. Just search yourself and you see a lot of complaints about it - so it's obvious for me.

You could tryo to install another wifi module on it (if it's possible) something like an intel wifi or you switch to your old ASUS PCE-AX3000 and try to install with updated drivers and check if it helps. But if the ASUS PCE-AX3000 has the same realtek chip (hopefully not) then there is no use to even think about trying it.
 

deepskydiver

Occasional Visitor
OK. To be honest I am almost sure that the issue is related to your TP Link and the realtek chip. Just search yourself and you see a lot of complaints about it - so it's obvious for me.

You could tryo to install another wifi module on it (if it's possible) something like an intel wifi or you switch to your old ASUS PCE-AX3000 and try to install with updated drivers and check if it helps. But if the ASUS PCE-AX3000 has the same realtek chip (hopefully not) then there is no use to even think about trying it.

What chipsets / cards would you suggest?
 

airgap

Occasional Visitor
I wish I could suggest you one but I can't. If you do some research you will find people complaining about the same kind of issue which you have and others say their card works perfect.

So it seems to depend on the used card and the router. But in general the intel wifi modules or should I say the one with intel wifi chips have lesser complaints about stability then realtek but as I said it depends.

There are some cards which seems to be good like "ASUS PCE-AC68 Dual-Band 3x3 AC1900" but there are reports that it can't handle channels above 48 in 5GHz.

As you can see there are some factors which you have to consider on chosing the right one.

I hope someone else here in the forum (who has the same or very similar setup like you) can suggest a device which will work great - but I can't :(
 

HTBruceM

Regular Contributor
Just from observing various AiMesh set ups, it seems that occasionally the settings shared between the routers somehow get corrupted out of sync.

I've seen this with all combination of RT-AC86U, RT-AC68U, RT-AX88U, RT-AC66U_B1, RT-AC3100, and even my two RT-AX86U's too.

Removing the nodes via the GUI, and then re-associating them again gets the network fast, stable and working as expected again.
This would be a bug, right? I wonder if Asus has a bug report on it.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top