What's new

After 384.9 update internet shows disconnected....

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

gilstrac

Occasional Visitor
After updating the internet status show as disconnected but it is not disconnected.

On startup, it will momentarily show the correct information then show the disconnected status.
Please note, the internet is working correctly. If you click the global, the internet status pane shows the current information for the internet connection.

If you refresh the page, it again momentarily shows the correct information.

The attached files show what I am seeing.

Has anyone seen this?
 

Attachments

  • internetstatus2019-02-20_8-33-53.png
    internetstatus2019-02-20_8-33-53.png
    30.3 KB · Views: 1,015
  • Internetstatus20190220_82714.gif
    Internetstatus20190220_82714.gif
    72.9 KB · Views: 1,444
Go to the Administration -> System page, and make sure that the WAN monitoring options are enabled.
 
1) By default, DNS lookups to Microsoft are used by the router to determine WAN status
2) You are using Google DNS
3) You might be in mainland China
4) Is it possible that something could be interfering with Google DNS?
5) Alternatively ping can be used for WAN status instead of DNS. Run a traceroute to any site and use the first hop as the WAN status ping destination. Perhaps there is a better IP address you can count on for this.
 
Not sure which setting you are referring too in the adminstration--> System
I attached the current setting in images
 

Attachments

  • 2019-02-20_19-16-45.png
    2019-02-20_19-16-45.png
    370.6 KB · Views: 938
  • 2019-02-20_19-17-02.png
    2019-02-20_19-17-02.png
    268.5 KB · Views: 877
1) By default, DNS lookups to Microsoft are used by the router to determine WAN status
2) You are using Google DNS
3) You might be in mainland China
4) Is it possible that something could be interfering with Google DNS?
5) Alternatively ping can be used for WAN status instead of DNS. Run a traceroute to any site and use the first hop as the WAN status ping destination. Perhaps there is a better IP address you can count on for this.

I guess I can c
 
Playing with the settings... I have a vpnclient setup using ipvanish. If I turn off the vpn, it displays connected. It appears to work for a while after turning the vpn back on but then reverts back to disconnected.
Not sure related but seems very consistent.
 
Not sure which setting you are referring too in the adminstration--> System
I attached the current setting in images
Administration>System>Basic Config>Network Monitoring
It appears that you have neither "DNS Query" or "Ping" selected.
By VPN client I take it you mean at the router level as opposed to the computer level. I have never done this.
So I would imagine you would go with whatever works in both contexts, your ISP and your VPN provider. I guess Ping to 1.1.1.1 could be most reliable.
 
So, it's recommended to >enable< the WAN monitoring?
I had this happen and >disabled< the options.
 
So, it's recommended to >enable< the WAN monitoring?
I had this happen and >disabled< the options.
I too wish that we could get a definitive answer on this one: I haven't had a problem (yet) with what seems to be the "default" setting of having neither of the WAN monitoring checkboxes ticked/enabled (admittedly, this is on a "dirty" upgrade from 384.8_2). However, I'm not sure what good would be gained from having one or the other checked/enabled, especially given the fact that I have yet to see a problem in at least two weeks of uptime since upgrading to 384.9: my internet status always shows as "connected". Under what circumstances what having the monitoring turned on benefit me?
 
I too wish that we could get a definitive answer on this one: I haven't had a problem (yet) with what seems to be the "default" setting of having neither of the WAN monitoring checkboxes ticked/enabled (admittedly, this is on a "dirty" upgrade from 384.8_2). However, I'm not sure what good would be gained from having one or the other checked/enabled, especially given the fact that I have yet to see a problem in at least two weeks of uptime since upgrading to 384.9: my internet status always shows as "connected". Under what circumstances what having the monitoring turned on benefit me?
I find it aids in troubleshooting to know whether my router can ping the first hop router at my ISP.
 
It has something to do with the openvpn client on the router. When it is running you see the above-mentioned issue. I also observed other clients having intermittent to no internet access.
I rolled back to the prior version of firmware to stop all the trouble tickets from my family.
The prior version is working fine.
Any one else seeing this?
 
Guys, just configure the WAN monitoring on the Administration page. If you have it set for DNS monitoring and your use a VPN forcing all traffic through it AND that VPN rejects any DNS server other than their own, then the DNS-based monitoring will fail. Either switch to Ping monitoring, or exclude your router's IP from the VPN.
 
I believe I had the same issue and it was related to the IP address ranges used by the vpn clients and vpn server.

I run a server and a client and found they were both using the same address range... 10.8.0.0 I think!?!? I changed the vpn server subnet to 10.9.0.0.

To those affected... Do you run vpn server/s or just clients?
 
Guys, just configure the WAN monitoring on the Administration page. If you have it set for DNS monitoring and your use a VPN forcing all traffic through it AND that VPN rejects any DNS server other than their own, then the DNS-based monitoring will fail. Either switch to Ping monitoring, or exclude your router's IP from the VPN.

Any idea of what the frequency of these pings are ? I don't want my ISP getting po'd at me for constantly pinging their gateway.
 
Guys, just configure the WAN monitoring on the Administration page. If you have it set for DNS monitoring and your use a VPN forcing all traffic through it AND that VPN rejects any DNS server other than their own, then the DNS-based monitoring will fail. Either switch to Ping monitoring, or exclude your router's IP from the VPN.

I do not use a VPN and I had this the other day for the first time. In order for the status to be normal, I had to disable both settings. Enabling either or both resulted in disconnected status.
 
Any idea of what the frequency of these pings are ? I don't want my ISP getting po'd at me for constantly pinging their gateway.

A few seconds I believe, something like every 15 secs.
 
I was having this issue too. Fixed it by setting "Internet Detection" to "DNS Probe" on the WAN Settings page.
 
I too experienced this issue, however I think it is a bigger problem with the OpenVPN. I run several OpenVPN clients. One wouldn't work at all with 384.9.
Others usually would work. Sometimes would cause other issues though - for example when I was trying to fix the disconnected message, I lost connectivity on a PC that wasn't part of the VPN policy at all when I reconnected to the VPN.

When the VPN was off, the disconnected status wouldn't appear.

Setting Network Monitoring made no difference.

I rolled back to 384.8_2, all is working correctly again. Will stay on this until the next release: if it still happens, I'll reset the router and re-enter all the settings again.
 
I have the same problem. I did have ping enabled (not DNS) for network monitoring and my router would show disconnected.
However I am RDP into my home server from remote (not over VPN)
I am on 384.9

I would need to restart my router to fix this. This is not a modem problem.
 
I have the same problem. I did have ping enabled (not DNS) for network monitoring and my router would show disconnected.
However I am RDP into my home server from remote (not over VPN)
I am on 384.9

I would need to restart my router to fix this. This is not a modem problem.


Have you tried to turn off network monitoring altogether? It works for me.


Sent from my iPhone using Tapatalk Pro
 

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top