After firmware update, can't login to my Asus RT-AC68U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

Bee Bee

New Around Here
I have 2 T-Mobile Cellspot routers that were converted a year ago to Asus RT-AC68U routers. I set up Aimesh (wireless backhaul) and the routers worked flawlessly, even though the Mesh router would occasionally disconnect. I was using firmware version 300438520630 and this morning I tried upgrading to their latest firmware, version 300438643129. The firmware update failed and I had to use the Rescue utility to restore the old firmware.

The restoration was successful. Internet and my local network were restored. All of my devices connected to the network. The only problem I have is that I am unable to logon to my router to change settings. It says that my password is incorrect.

The password wasn't changed. I also tried the original passwords, both the T-Mobile password and the Asus password, and that didn't work. Is there any way I can get get the password that that the router wants..
 

thiggins

Mr. Easy
Staff member
Reflashing T-Mobile Cellspots with ASUS firmware is illegal use of firmware. You won't find support for questions like yours in these forums.
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top