Asus AX56u using a lot of RAM & Internet Disconnects

andysoft83

New Around Here
Hello,
I am facing a strange situation with my Router since ~ 1 month ago, my Mesh setup is AX56U as main router and AX55 as second Mesh router connected via 1 Gb LAN , they are both running the latest official Asus firmware's.
My issue is that I found several times the internet disconnected and taking a look in the Logs I did found something related to memory
CSS:
Aug 19 07:45:17 dnsmasq-dhcp[1277]: failed to write /var/lib/misc/dnsmasq.leases: No space left on device (retry in 60s)
Aug 19 07:45:17 dnsmasq-dhcp[1277]: failed to write /var/lib/misc/dnsmasq.leases: No space left on device (retry in 60s)
Aug 19 07:45:19 watchdog: restart_firewall due DST time changed(0->1)
Aug 19 07:45:19 rc_service: watchdog 29653:notify_rc restart_firewall
Aug 19 07:45:19 firewall: apply rules error(2794)
Aug 19 07:45:19 rc_service: watchdog 29653:notify_rc restart_wan
Aug 19 07:45:19 firewall: apply rules error(2829)
Aug 19 07:45:19 rc_service: waitting "restart_firewall" via watchdog ...
Aug 19 07:45:19 services: apply rules error(16569)
Aug 19 07:45:20 firewall: apply rules error(4374)
Aug 19 07:45:20 dnsmasq-dhcp[1277]: failed to write /var/lib/misc/dnsmasq.leases: No space left on device (retry in 60s)

After restart the Internet is connected again and everything runs smooth
What I saw is the RAM usage after restart is already at 75% and after 24 H I checked and is at 80%
I have disabled :
- QoS
- Parental Controls
-VPN and FTP is off

I have ON
- Download Master
- DLNA server
- SAMBA server
- AI Protection

Do you have any ideas what could be the cause of the errors and if they are affecting my Internet connection.

Thank you
 

Adooni

Senior Member
is internet gone on main router AX56U or AiMesh node AX55. if it is node AX55 this is common issue from 1st time Asus introduced AIMesh and the reason people are reboot main router or sometimes Node - you can find post about it on forum.

here you have similar post (please look at forum before start new one)
https://www.snbforums.com/threads/f...s-no-space-left-on-device-retry-in-60s.28247/

with download master it is possible you would need SWAP
try install latest RMerlin and amtm, then create SWAP on USB device (you have a lot info about it on this forum) and check again.

RMerlin moved same same variables from NVRAM what can help - I do not knwo if your NVRAM is gone or RAM
I have 256MB RAM too and with firewall I hade same situation that internet was gone etc and I see I use Swap 3.93 / 2048.00 MB now.
I am using transmission but not via router and downloads Master take a lot RAM.
 
Last edited:

andysoft83

New Around Here
I don't want to use Merlin , I need help/suggestions for the original ASUSWRT firmware . Thanks for the reply anyway.
 

ColinTaylor

Part of the Furniture
I have ON
- Download Master
- DLNA server
- SAMBA server
- AI Protection
Disable all of these and see if the problem goes away. If it does then turn each one back on one at a time to discover which is the cause. It could simply be a bug that you will have to wait for Asus to fix.
 

bbunge

Part of the Furniture
I don't want to use Merlin , I need help/suggestions for the original ASUSWRT firmware . Thanks for the reply anyway.
You can create a swap on a thumb drive with stock Asus firmware. There is a post on the forum about this I wrote years ago.
 

andysoft83

New Around Here
Meanwhile to be on the safe side and also for testing I downgraded to previous FW version Version 3.0.0.4.386.42808, with this one I never had problems ( e.g. internet disconnected ) and I will monitor the Sys LOG .
Guess what, also with this version my RAM usage is ~ 70-80% with the features/settings mentioned above.
 

Attachments

  • memory.JPG
    memory.JPG
    83.4 KB · Views: 60

ColinTaylor

Part of the Furniture
Guess what, also with this version my RAM usage is ~ 70-80% with the features/settings mentioned above.
That's perfectly normal when you have an attached USB device. See the countless posts in these forums for why that is.

Untitled.png
 

andysoft83

New Around Here
Small update, 3 days uptime for the router after I downgraded to FW version Version 3.0.0.4.386.42808 , RAM load is 81 % . No issues so far in the logs.
 

Volt

Regular Contributor
RAM usage has nothing to do with the "No space left on device" message. Besides, looking at RAM usage is meaningless, since Linux extensively uses memory caching.
 

ColinTaylor

Part of the Furniture
RAM usage has nothing to do with the "No space left on device" message.
It does actually, albeit indirectly. As /var is created from tmpfs, and tmpfs is virtual memory. But as you say, the "free" RAM shown in the GUI is meaningless because it includes cached memory. To get the true amount of "available" memory he'd need to run top or free.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top