Asus RT-N66U - Using VLAN = LAN3 + LAN4 stop working?

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

Kusuri

Occasional Visitor
Asus RT-N66U - Using VLAN = LAN3 + LAN4 stop working as normal LAN

Hello,

I hope someone who is more knowledgeable of VLANs than me could help me here... I've already asked this in 3 different forums, including the official Asus forum and Asus support itself, but got no answers at all.

My ISP delivers only Internet + VoIP, no IPTV. Also, it's not any of the ISPs that already come in the ISP Profile list in the IPTV settings (MioTV, Singtel etc).

I successfully managed to connect to the Internet via the correct VLAN IDs my ISP provided (10 for Internet), as shown in attachments.

The problem with what I tested so far though, is that only LAN1, LAN2 and Wireless still work as normal (through which clients become automatically associated to the router) when using VLAN.

LAN3 and LAN4 become essentially dead. Can't even access router page through them. As soon as I stop using VLAN I can use LAN3 and LAN4 as normal again...

Since I won't be using LAN4 for IPTV, as my ISP is only Internet + VoIP, how could I have LAN4 work the same way as LAN1-2 + Wireless, while having Internet VLAN ID 10 and LAN3 VLAN ID 12?

I've tried leaving it blank, setting VID 2 (which I was told was the default VLAN ID for LAN1-2 + Wireless) to see if that would help, but it didn't... No idea if PRIO would help here, left it at 0.

Does this mean the LAN4 port becomes useless since my ISP is just VoIP?

Is this normal behaviour or is the router defective?
Could a custom firmware like Tomato USB solve this or am I missing a step in the official firmware config? Maybe I'm forced to use a Gigabit switch?


Thanks
 

Attachments

Last edited:

Kusuri

Occasional Visitor
Ok so I contacted Asus support directly and all they could say was to install fw 3.0.0.3.112, even though I had mentioned it was the one I had beforehand. Then after asking again all I was told was to ask for warranty...

I'll rephrase my question, so anyone, even those who aren't using VLAN or don't understand it, can help me confirm if this is normal software behavior or hardware defect:

First make sure you're using the latest official fw 3.0.0.3.112.

- Go to http://192.168.1.1/Advanced_IPTV_Content.asp
select ISP Profile Manual, leave everything blank then Apply and Reboot.
Most likely won't have Internet connection in this mode, but it doesn't matter, as the point is to test local network connection.

- Connect any device to the 3rd or 4th LAN ports (the two last ports)
and go to http://192.168.1.1/device-map/clients.asp
and Refresh. See if the clients connected to those ports are in the list (wireless devices don't count of course). In my case they aren't in the list unless I connect them to the 1st or 2nd LAN, meaning there's no connection with the Router at all through ports 3 and 4. As soon as I disable VLAN by selecting ISP Profile None all is normal again.

If your only device connected via ethernet cable is the one you use to configure (or don't have a laptop w/ wireless) then the simple fact you can't access 192.168.1.1 should be enough to know the LAN3/LAN4 ports aren't working.

- If you have the same results as me, try going back to the VLAN config and setting VLAN ID 2 for both "IPTV (LAN4)" and "VoIP (LAN3)" - I was told ID 2 is the one used by LAN1, LAN2 and Wireless - Apply and Reboot and check the clients list again/try accessing 192.168.1.1.

- Set back ISP Profile to None and Apply after testing (obviously).

This shouldn't take much of your time, but I only have 2 days left for warranty...
Thanks
 

srinivasvaradaraj

Regular Contributor
Hello,
Unfortunately, the fix for you may not be quick, If your ISP is truely sending you a trunk with multiple tagged VLANs then you have to have have trunk port on your WAN and untag to individual VLAN interfaces. All this can be done but you may have to use Tomato USB or take the ASUS code and mod it. Alternately, you may request code from Merlin (see custom build of Asus) to included VLAN utils (vconfigs commands). The reason is possibly giving an issue is most of the router firmware internally use VLAN 1 & VLAN 2 , this is combined with bridging0 between the wired and wireless interfaces. Your best bet is to start with Tomato, remove the VLANs you require from the bridge and assign them to the an individual interface and treat them at L3 directly by manually routing and filtering btw them.

This dd-wrt document shows how VLANs are usually used
http://www.dd-wrt.com/wiki/index.php/VLAN_Detached_Networks_(Separate_Networks_With_Internet)
Also, checkout these VLAN howtos.
http://www.dd-wrt.com/wiki/index.php/Configuration_HOWTOs

I can def say that it is possible to untag the VLANs unleash the power of ur router.
-sri
 

Kusuri

Occasional Visitor
Thanks for the reply.

I see I may really need to go for cfw, moreso after what I found through further tests:

I experimented with the ISP Profile presets the router comes with and found Singtel-Others gave the necessary VID for Internet (10), while LAN3 still worked as normal.

When I was going back to Manual it showed the following values that were previously applied by the Singtel-Others profile:

VLAN Internet: VID 10
VLAN LAN4: VID 20
VLAN LAN3: VID 0

So 0 seems to make LAN3 work as normal port, but 0 is a value that the Asus configuration page won't let me use, because it always asks for 2-4094.

So I take it that LAN1-2 + Wireless are using VLAN ID 0.
If there was a way I could be able to force VLAN ID 0 for LAN3 and LAN4, then both could perhaps work as normal.

But now knowing this is a limitation of the official firmware I can rest easier knowing I don't need RMA after all.

I will surely read those links you gave me. Thanks for taking your time! :)
Hopefully Asus will fix the NVRAM issue this month and there'll be proper DD-WRT cfw for RT-N66U?
 
Last edited:

Mark Uhde

Regular Contributor
Umm, I maybe stating the obvious but it looks like you just need to make LAN3 and LAN4 VLAN tag 10? Or whichever VLAN is VoIP on whichever of those ports you want to use for VoIP? Does it not let you bridge the same VLAN to multiple ports? If not, that's a product design issue nothing but a new firmware update can help you with.
 
Last edited:

Kusuri

Occasional Visitor
Umm, I maybe stating the obvious but it looks like you just need to make LAN3 and LAN4 VLAN tag 10? Or whichever VLAN is VoIP on whichever of those ports you want to use for VoIP? Does it not let you bridge the same VLAN to multiple ports? If not, that's a product design issue nothing but a new firmware update can help you with.
LAN3 and LAN4 with VLAN ID 10 doesn't work. I read the router becomes confused or something because of using VLAN ID 10 for CPU/Internet as well...

I just found this picture from openwrt about Asus WL-500 Premium default config that shows VLAN 0 for the LAN ports. So I guess that's what I'd need to set if I want them working as regular LAN, except the configuration page only accepts 2-4094 for some reason.
 

Attachments

Mark Uhde

Regular Contributor
LAN3 and LAN4 with VLAN ID 10 doesn't work. I read the router becomes confused or something because of using VLAN ID 10 for CPU/Internet as well...

I just found this picture from openwrt about Asus WL-500 Premium default config that shows VLAN 0 for the LAN ports. So I guess that's what I'd need to set if I want them working as regular LAN, except the configuration page only accepts 2-4094 for some reason.
I don't quite understand what ASUS is doing but if your goal is to route into the VID 10 tagged on the WAN port, it sure LOOKS like those should be set to VID 10.

This is a complex enough setup I think you may need something like pfSense that can do VLAN's as interfaces, and let you configure your incoming VLAN interfaces as separate interfaces and route them as you wish.
 

xman

New Around Here
Not sure if you have resolved the problem after such a long time.

My Asus RT-AC66U has exactly the same behavior.

I managed to hack around the javascript of the iptv admin page.

The vlan ID for port 3 and 4 should be left empty.
In addition, you'll need to set the javascript:

document.form.switch_stb_x.value = "0";

in order to disable the iptv ports.

If you are using manual profile, the value is wrongly set to value 6 which assign port 3 and 4 to iptv, yet they don't provide options to disable the iptv ports in the admin page.

So you got to hack the javascript using browser such as Chrome with good debugging tool.
 
Last edited:

xptopt

Occasional Visitor
Hi

I have the same problem , need to use VID 10 to the internet service and let port 3 and 4 on normal lan.

There’s any telnet command on merlin builds that can fix this problem .
Many thanks

Edit

Thanks to Merlin the problem can simply be fixed with this telnet commands

nvram set switch_stb_x=0
nvram commit
reboot

Now i have manual VLan INTERNET VID 10 and all ports can be used as lan.

Thanks Merlin
 
Last edited:

Micke_wth

New Around Here
Ive almost got the same problem except Ive got IPTV on port4 and port3 doesn't work with a computer connected.

To get the IPTV to work I set the port4 VID to 845 and left everything as default. What should I do get port3 to provide internet to the computer connected?
 

Micke_wth

New Around Here
Hi

I have the same problem , need to use VID 10 to the internet service and let port 3 and 4 on normal lan.

There’s any telnet command on merlin builds that can fix this problem .
Many thanks

Edit

Thanks to Merlin the problem can simply be fixed with this telnet commands

nvram set switch_stb_x=0
nvram commit
reboot

Now i have manual VLan INTERNET VID 10 and all ports can be used as lan.

Thanks Merlin
So I tried this, now the internet on port 3 works, but not the tv. The VID for the IPTV must be set to 845 to work.
 

xptopt

Occasional Visitor
So I tried this, now the internet on port 3 works, but not the tv. The VID for the IPTV must be set to 845 to work.
after you use the commands and set port 4 to VID 845, port 3 should work as normal lan i think ,just leave port 3 VID blank .

Or try this

nvram set switch_stb_x=0
nvram set switch_wan1tagid=845
nvram set switch_wan2tagid=0
nvram commit
reboot

don't know if it works but you can try it

NOTE!!!
switch_wan1tagid is the port 4
switch_wan2tagid is the port 3
 
Last edited:

Micke_wth

New Around Here
after you use the commands and set port 4 to VID 845, port 3 should work as normal lan i think ,just leave port 3 VID blank .

Or try this

nvram set switch_stb_x=0
nvram set switch_wan1tagid=845
nvram set switch_wan2tagid=0
nvram commit
reboot

don't know if it works but you can try it

NOTE!!!
switch_wan1tagid is the port 4
switch_wan2tagid is the port 3
Yeah, I thought that would work so I tried it yesterday - unfortunately it didtn work... :mad: I get internet on port 1-3 but the IPTV doesnt work. Now Im clueless what to do.

What does "set switch_stb_x=0" really do? Why not using the Manual-option in the Asus interface?
 

xptopt

Occasional Visitor
Yeah, I thought that would work so I tried it yesterday - unfortunately it didtn work... :mad: I get internet on port 1-3 but the IPTV doesnt work. Now Im clueless what to do.

What does "set switch_stb_x=0" really do? Why not using the Manual-option in the Asus interface?

set switch_stb_x=0 puts port 3 and 4 on the same vlan as 1 and 2 , by default the firmware puts lan tag port 3 and 4 if value is left empty to vid 6 but to use port 3 or 4 as lan the value should be 0


try this, after config the iptv vid use only this command

nvram set switch_wan2tagid=0
nvram commit
reboot

this should put only port 3 in lan
 
Last edited:

Micke_wth

New Around Here
set switch_stb_x=0 puts port 3 and 4 on the same vlan as 1 and 2 , by default the firmware puts lan tag port 3 and 4 if value is left empty to vid 6 but to use port 3 or 4 as lan the value should be 0


try this, after config the iptv vid use only this command

nvram set switch_wan2tagid=0
nvram commit
reboot


this should put only port 3 in lan
Ive tried both:

Alt. 1
nvram set switch_stb_x=0
nvram set switch_wan1tagid=845
nvram commit
reboot


and then

nvram set switch_wan2tagid=0
nvram commit
reboot


Alt2:
nvram set switch_stb_x=0
nvram set switch_wan1tagid=845
nvram set switch_wan2tagid=0
nvram commit
reboot


None of the alternatives worked. Getting IPTV on both tries but no internet on port 3.

This is how my javascript looks like:

<tr id="wan_internet_x">
<th width="30%">Internet</th>
<td>
VID&nbsp;<input type="text" name="switch_wan0tagid" class="input_6_table" maxlength="4" value="" onKeyPress="return is_number(this, event);">&nbsp;&nbsp;&nbsp;&nbsp;
PRIO&nbsp;<input type="text" name="switch_wan0prio" class="input_3_table" maxlength="1" value="0" onKeyPress="return is_number(this, event);">
</td>
</tr>
<tr id="wan_iptv_port4_x">
<th width="30%">LAN port 4</th>
<td>
VID&nbsp;<input type="text" name="switch_wan1tagid" class="input_6_table" maxlength="4" value="845" onKeyPress="return is_number(this, event);">&nbsp;&nbsp;&nbsp;&nbsp;
PRIO&nbsp;<input type="text" name="switch_wan1prio" class="input_3_table" maxlength="1" value="0" onKeyPress="return is_number(this, event);">
</td>
</tr>
<tr id="wan_voip_port3_x">
<th width="30%">LAN port 3</th>
<td>
VID&nbsp;<input type="text" name="switch_wan2tagid" class="input_6_table" maxlength="4" value="0" onKeyPress="return is_number(this, event);">&nbsp;&nbsp;&nbsp;&nbsp;
PRIO&nbsp;<input type="text" name="switch_wan2prio" class="input_3_table" maxlength="1" value="0" onKeyPress="return is_number(this, event);">
</td>


Since "VID&nbsp;<input type="text" name="switch_wan0tagid" class="input_6_table" maxlength="4" value="" onKeyPress="return is_number..." the internet port value is "", I tried setting switch_wan1tagid="" aswell, that didnt work either. This is getting ridiciolous. Im running Merlin firmware I should mention, Firmware:3.0.0.4.374.32 (Merlin build).
 
Last edited:

andytuinman3

New Around Here
Ive tried both:

Alt. 1
nvram set switch_stb_x=0
nvram set switch_wan1tagid=845
nvram commit
reboot


and then

nvram set switch_wan2tagid=0
nvram commit
reboot


Alt2:
nvram set switch_stb_x=0
nvram set switch_wan1tagid=845
nvram set switch_wan2tagid=0
nvram commit
reboot


None of the alternatives worked. Getting IPTV on both tries but no internet on port 3.

This is how my javascript looks like:

<tr id="wan_internet_x">
<th width="30%">Internet</th>
<td>
VID&nbsp;<input type="text" name="switch_wan0tagid" class="input_6_table" maxlength="4" value="" onKeyPress="return is_number(this, event);">&nbsp;&nbsp;&nbsp;&nbsp;
PRIO&nbsp;<input type="text" name="switch_wan0prio" class="input_3_table" maxlength="1" value="0" onKeyPress="return is_number(this, event);">
</td>
</tr>
<tr id="wan_iptv_port4_x">
<th width="30%">LAN port 4</th>
<td>
VID&nbsp;<input type="text" name="switch_wan1tagid" class="input_6_table" maxlength="4" value="845" onKeyPress="return is_number(this, event);">&nbsp;&nbsp;&nbsp;&nbsp;
PRIO&nbsp;<input type="text" name="switch_wan1prio" class="input_3_table" maxlength="1" value="0" onKeyPress="return is_number(this, event);">
</td>
</tr>
<tr id="wan_voip_port3_x">
<th width="30%">LAN port 3</th>
<td>
VID&nbsp;<input type="text" name="switch_wan2tagid" class="input_6_table" maxlength="4" value="0" onKeyPress="return is_number(this, event);">&nbsp;&nbsp;&nbsp;&nbsp;
PRIO&nbsp;<input type="text" name="switch_wan2prio" class="input_3_table" maxlength="1" value="0" onKeyPress="return is_number(this, event);">
</td>


Since "VID&nbsp;<input type="text" name="switch_wan0tagid" class="input_6_table" maxlength="4" value="" onKeyPress="return is_number..." the internet port value is "", I tried setting switch_wan1tagid="" aswell, that didnt work either. This is getting ridiciolous. Im running Merlin firmware I should mention, Firmware:3.0.0.4.374.32 (Merlin build).
I don't know if you got it working yet but i just did a few minutes ago:

Here's what i did

I have a fiber connection that requires internet through vlan 6 and IPTV through VLAN 4

IPTV is set on LAN 4

so what i did:

1. set the router so that your IPTV works and LAN3 doesn't.
2. Go to Quick internet setup.
3. set the correct internet settings (mine was PPPoE).
4. Check the box "special requirements by ISP".
5. Set the settings the same like you would always do BUT set LAN 3 to VID 1 (yes at the normal IPTV settings asus won't let you set it to VID 1 but here it does)
6. Let it configure itself.
7. when it's finished you should have tv but no internet on lan 3 (like it used to be).
8. log in through telnet.
9. here is the part that you should try because i don't know which is the correct setting for you. The only thing you have to change is "switch_stb_x"
In my case it's switch_stb_x=4. With this setting both my LAN3 and IPTV works. So i think yours has to be switch_stb_x=845 unless it referres to the LAN port than it should be switch_stb_x=4. i think one of the two should work for you.

So that should be:

nvram set switch_stb_x=845
nvram commit
reboot

OR

nvram set switch_stb_x=4
nvram commit
reboot

This was what i did to make it work. I hope it works for you aswell.

again this is the switch part of the nvram: (nvram show | grep switch)

switch_wan1prio=0
switch_wan2tagid=1
switch_wan0tagid=6
Ate_dev_status=switch=O,2G=O,5G=O
switch_stb_x=4
pci/1/1/antswitch=0
pci/2/1/antswitch=0
switch_wan2prio=0
switch_wantag=manual
switch_wan0prio=0
switch_wan1tagid=4

(No english is not my native language :p)
 
Last edited:

Bigguns21

New Around Here
VLAN stopped working

Hello,

I am new to Tomato by Shibby on the Asus RT-66 Router but I did get separate VLANs to work on the physical ports with quite a bit of trial and error.

It is kinda strange but br2 shows to be designated to LAN Port 4 but I actually have it plugged into LAN Port 1 on the RT-N66. Is this what is happening to you?

192.168.100.x Wired/Wireless Friendly Network
192.168.150.x Wireless Guest Network
192.168.160.x Wired Gues Network


Router IP Addresses br0 (LAN) - 192.168.100.100/24
br1 (LAN1) - 192.168.150.100/24
br2 (LAN2) - 192.168.160.100/24
DHCP br0 (LAN) - 192.168.100.105 - 192.168.100.200
br1 (LAN1) - 192.168.150.200 - 192.168.150.254
br2 (LAN2) - 192.168.160.200 - 192.168.160.254


VLAN VID Port 1 Tagged Port 2 Tagged Port 3 Tagged Port 4 Tagged WAN Port Tagged Default Bridge
1 1 Yes Yes Yes LAN (br0)
2 2 Yes WAN
3 3 Yes * LAN2 (br2)
 

andytuinman3

New Around Here
It's known that tomato (and i think dd-wrt too) reverse the LAN ports. So LAN1 is 4, LAN 2 is 3, LAN 3 is 2 and LAN 4 is 1.
 

Micke_wth

New Around Here
I don't know if you got it working yet but i just did a few minutes ago:

Here's what i did

I have a fiber connection that requires internet through vlan 6 and IPTV through VLAN 4

IPTV is set on LAN 4

so what i did:

1. set the router so that your IPTV works and LAN3 doesn't.
2. Go to Quick internet setup.
3. set the correct internet settings (mine was PPPoE).
4. Check the box "special requirements by ISP".
5. Set the settings the same like you would always do BUT set LAN 3 to VID 1 (yes at the normal IPTV settings asus won't let you set it to VID 1 but here it does)
6. Let it configure itself.
7. when it's finished you should have tv but no internet on lan 3 (like it used to be).
8. log in through telnet.
9. here is the part that you should try because i don't know which is the correct setting for you. The only thing you have to change is "switch_stb_x"
In my case it's switch_stb_x=4. With this setting both my LAN3 and IPTV works. So i think yours has to be switch_stb_x=845 unless it referres to the LAN port than it should be switch_stb_x=4. i think one of the two should work for you.

So that should be:

nvram set switch_stb_x=845
nvram commit
reboot

OR

nvram set switch_stb_x=4
nvram commit
reboot

This was what i did to make it work. I hope it works for you aswell.

again this is the switch part of the nvram: (nvram show | grep switch)

switch_wan1prio=0
switch_wan2tagid=1
switch_wan0tagid=6
Ate_dev_status=switch=O,2G=O,5G=O
switch_stb_x=4
pci/1/1/antswitch=0
pci/2/1/antswitch=0
switch_wan2prio=0
switch_wantag=manual
switch_wan0prio=0
switch_wan1tagid=4

(No english is not my native language :p)
Just tried this and got it to work!

I did the following:

1. Set the router so that your IPTV works and LAN3 doesn't. (Vid 845 for me)
2. Go to Quick internet setup. (Had to unplug the internet cable, otherwise the guide would just run automatically)
4. Check the box "special requirements by ISP".
5. Set LAN 3 to VID 1

Then I used Telnet to connect to the router and used the following commands:

nvram set switch_stb_x=4
nvram commit
reboot

Now Ive got IPTV on port 4 and internet on the rest of the ports! Thanks man and sorry for the delay ;)
 
Last edited:

Janneman1979v2

New Around Here
Just tried this and got it to work!

I did the following

2. Go to Quick internet setup.
4. Check the box "special requirements by ISP".
5. Set the settings the same like you would always do BUT set LAN 3 to VID 1

Then I went to the LAN setup tab and set the VID on port 4 to 845, now Ive got IPTV on port 4 and internet on the rest of the ports! Thanks man and sorry for the delay ;)
Hi all. Really glad I stumbled onto this thread, as it seems this is almost exactly what I need to to. My ISP is using VLAN 34 for internet and VLAN 4 for IPTV (SIP for VOIP) and supplied a Zyxel router that will handle everything. I'm using Merlin as well on my RT-N66U (latest build from yesterday), an where I need to get to is replacing the Zyxel with the Asus, and letting the Zyxel deal with the VOIP behind the Asus.

My problem is that y networking skills are simply too limited to implement this change. Trying to learn though for the past few days, (so one could say I'm stupid yet unafraid..
) but I just can't seem to get my head around this so far.

Since you got this to work, but with different VLANs, I was hoping you could give me some slightly more detailed pointers on how to go about this without having to talk me through step-by-step. That is, if anyone actually get to reading this..
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top