Beta ASUSWRT 386 RC2 public beta with full functions AiMesh 2.0

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

OzarkEdge

Part of the Furniture

bits

Regular Contributor
No, I think Merlin has suggested that there is an internal difference.
The files being the same size doesn't mean they are the same file at all.
It is common for images for firmware to have zero padding to fill partitions to a particular size. The image having identical size from release to release is normal.
 

RMerlin

Asuswrt-Merlin dev
No, I think Merlin has suggested that there is an internal difference.

OE
I don't know as I haven't downloaded them. That's why I suggested comparing their md5 hashes to determine if they are different or not. I'd be surprised however if they'd be the same, since the filename is actually determined at compile time (that's why the actual git hash is part of the filename).
 

jass

Regular Contributor
@ASUSWRT_2020 After resetting and reloading for many times and testing N times, the node tuf-ax3000 still can't connect to any client and has to go back to the version 3.0.0.4.384.9923
What exactly are you reloading?

Please give an exact description on how you perform your factory resets.
 

Uugh12

New Around Here
Hello all, I have 2 RT-AX88U both running this Rc-7 release. Clean install on both units. Node is using wifi backhaul.

One thing I have noticed is running the speed test from the router gives significantly lower results than running the same test from the desktop PC app - both connecting to the same server. Pc is Cat 6 cabled directly to the main router. The PC gives the faster result over the router inbuilt test.
 

cniedzi

Occasional Visitor
Hi.

My AiMesh system consist of these routers in optimal path order: RT-AX86U (main router)->RT-AX82U (-66dBm)->RT-AC86U(-66dBm). All with 386 rc2-7.
Preferable backhauls are set according to above path.

System starts with optimal path, but after some time it reconfigures to not optimal path: RT-AX86U (main router)->RT-AX82U (-66dBm) and RT-AX86U (main router)->RT-AC86U (-76dBm)...
When I manually reconnect RT-AC86U node it connects to preferred backhaul, but after some time it reconnect to main router directly (with lower RSSI)...

Any suggestion how to always stay with optimal path?
 

ASUSWRT_2020

Regular Contributor
Hello all, I have 2 RT-AX88U both running this Rc-7 release. Clean install on both units. Node is using wifi backhaul.

One thing I have noticed is running the speed test from the router gives significantly lower results than running the same test from the desktop PC app - both connecting to the same server. Pc is Cat 6 cabled directly to the main router. The PC gives the faster result over the router inbuilt test.
It may happen. The speedtest on router using the router's CPU.
If there are many network activities, the speedtest result may be lower.
 

ASUSWRT_2020

Regular Contributor
Hi.

My AiMesh system consist of these routers in optimal path order: RT-AX86U (main router)->RT-AX82U (-66dBm)->RT-AC86U(-66dBm). All with 386 rc2-7.
Preferable backhauls are set according to above path.

System starts with optimal path, but after some time it reconfigures to not optimal path: RT-AX86U (main router)->RT-AX82U (-66dBm) and RT-AX86U (main router)->RT-AC86U (-76dBm)...
When I manually reconnect RT-AC86U node it connects to preferred backhaul, but after some time it reconnect to main router directly (with lower RSSI)...

Any suggestion how to always stay with optimal path?
Go to AiMesh page and click the node icon.
Click the Preferable backhaul in the Management tab and you can select the uplink AP

chrome_ZzrwzBpi6N.png
 

YCY

New Around Here
What exactly are you reloading?

Please give an exact description on how you perform your factory resets.
Hi,
Sorry, I can only communicate by translation software.
.The reset button on the back of the router.
.Router management page- Administration - Restore/Save/Upload Setting-Factory default-restore.
All of the above methods have been tried. Main route and the node all reset.
 
Last edited:

OzarkEdge

Part of the Furniture
Btw. I have noticed higher RSSI values with 386 FW vs 384:)
Me, too. Backhauls are tops and I had to raise Roaming Assistant 2.4 RSSI threshold to -62.

OE
 

OzarkEdge

Part of the Furniture
Hi OzarkEdge,

Thanks for your remind, actually, we have found the symptom in amas_lib. This issue has fixed in new beta firmware 386-40577. You could verify, thanks!
Thanks!

I don't see anymore amas_lib Log entries with RC2-7, but I still have these entries... this batch is for a Roku Ultra wired through an Asus Gigabit 8-Port Switch GX-D1081 V3 to the RT-AC86U router/root node while all are sleeping:

Oct 23 03:57:13 wlceventd: wlceventd_proc_event(474): eth6: Deauth_ind 54:60:09:BA:BB:10, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3)
Oct 23 03:57:13 wlceventd: wlceventd_proc_event(491): eth6: Disassoc 54:60:09:BA:BB:10, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Oct 23 03:57:13 wlceventd: wlceventd_proc_event(474): eth6: Deauth_ind 54:60:09:BA:BB:10, status: 0, reason: Class 3 frame received from nonassociated station (7)
Oct 23 03:57:35 wlceventd: wlceventd_proc_event(510): eth6: Auth 54:60:09:BA:BB:10, status: Successful (0)
Oct 23 03:57:35 wlceventd: wlceventd_proc_event(539): eth6: Assoc 54:60:09:BA:BB:10, status: Successful (0)
Oct 23 03:57:36 kernel: 54:60:09:BA:BB:10 not mesh client, can't update it's ip
Oct 23 03:57:36 kernel: 54:60:09:BA:BB:10 not mesh client, can't update it's ip

Oct 23 08:47:25 kernel: eth4 (Ext switch port: 3) (Logical Port: 11) Link DOWN.
Oct 23 08:47:27 kernel: eth4 (Ext switch port: 3) (Logical Port: 11) Link UP 1000 mbps full duplex

OE
 

dave14305

Part of the Furniture
If anyone is running Adaptive QoS under this 386 firmware, would you please share the output of the following ssh command with me?
Bash:
tc filter show dev br0 | grep -B1 0x80000000
Just wondering if unidentified traffic is still mis-directed in the new firmware. Thanks!
 

SloPoke

Occasional Visitor
ZenWiFi XT8 with 3 nodes, all using ethernet backhaul. No problems under RC2-4. Updated main router to RC2-7, seemed OK, much better than RC2-5. Updated first node, seemed OK also. However, as I updated each subsequent node, each disconnected and would not reconnect, ethernet backhaul or otherwise. All disappeared from AIMesh except the closest one, with a very weak backhaul wireless signal, which eventually disconnected entirely. Back to the drawing board.
 

OzarkEdge

Part of the Furniture
ZenWiFi XT8 with 3 nodes, all using ethernet backhaul. No problems under RC2-4. Updated main router to RC2-7, seemed OK, much better than RC2-5. Updated first node, seemed OK also. However, as I updated each subsequent node, each disconnected and would not reconnect, ethernet backhaul or otherwise. All disappeared from AIMesh except the closest one, with a very weak backhaul wireless signal, which eventually disconnected entirely. Back to the drawing board.
Try cycling power on all nodes and reboot the router/root node.

OE
 

SloPoke

Occasional Visitor
I rebooted the router, all nodes disappeared. I power cycled each node. The LED on them turns white for a minute, the main router show a weak wireless backhaul connection, then the LED starts rapidly blinking blue and they disconnect.
 

OzarkEdge

Part of the Furniture
I rebooted the router, all nodes disappeared. I power cycled each node. The LED on them turns white for a minute, the main router show a weak wireless backhaul connection, then the LED starts rapidly blinking blue and they disconnect.
Next step would be to clean install... reset all, configure router from scratch, add nodes, system reboot and/or power cycle. The beta dance.

Be sure to set each node for wired 1G WAN backhaul first and enable Ethernet backhaul (only) to free up WiFi.

OE
 
Last edited:

drabisan

Senior Member
ZenWiFi XT8 with 3 nodes, all using ethernet backhaul. No problems under RC2-4. Updated main router to RC2-7, seemed OK, much better than RC2-5. Updated first node, seemed OK also. However, as I updated each subsequent node, each disconnected and would not reconnect, ethernet backhaul or otherwise. All disappeared from AIMesh except the closest one, with a very weak backhaul wireless signal, which eventually disconnected entirely. Back to the drawing board.
Do you have a reason not ticking the option "Ethernet Backhaul Mode"?
That, in theory, should eliminate the option to fall-back to wifi backhaul. If you're looking for pure performance, that should be the only path.
 

SloPoke

Occasional Visitor
Yes, Ethernet Backhaul Mode is checked and always has been. Ok, reset the router and set it up again. Reset one of the nodes and added it back in again. It gets added with a weak wireless backhaul despite ethernet backhaul being checked, stays connected for about a minute, and then disconnects entirely.
 

Mattias

Occasional Visitor
rt-ax88u + rt-ax58u backhaul wireless (with AX) seems to work fine with latest version.
Only thing, which is a question mark for me. How does biding work?
I tried it to bind my oneplus nord to aimesh node(ax58u). It was attached there, then I wanted to check what happen if aimesh node goes down suddenly...does it connect to main router if possible. That worked fine. But when I turned aimesh node back on, it did not go back to that.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top