Beta ASUSWRT 386 RC2 public beta with full functions AiMesh 2.0

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

ginny

Occasional Visitor
Yes, Ethernet Backhaul Mode is checked and always has been. Ok, reset the router and set it up again. Reset one of the nodes and added it back in again. It gets added with a weak wireless backhaul despite Ethernet backhaul being checked, stays connected for about a minute, and then disconnects entirely.
If you have the nodes connected over a managed switch "Ethernet Backhaul Mode" in the System Settings, it will fail always . I had that experience already.
While I had set "Ethernet first" within the nodes it worked and and displayed Ethernet as Backhaul. But with this setup there was still a 5Gig Wifi Band reserved for Backhaul.
I connectect then the nodes directly at the Routers Ethernet Port and Ethernet Backhaul Mode works no without any problems. Try to find an unmanaged Switch if you can't connect the nodes directly. Maybe someone watching this thread may give a hint if some managed switches will work as well.
 

OzarkEdge

Part of the Furniture
So should i update nodes 1st? Or main? Thanks
Upload the nodes and remove them to reset them automatically.

Upload the router and Restore/Initialize from the webUI to reset it.

Configure the router from scratch and add the nodes.

AiMesh system reboot all.

If any issues, power cycle router, then nodes.

Test your WAN security.

Perform inbuilt QoS Internet Speed test to benchmark it.

Let it settle and use it.

I have two AC86U nodes 77' apart and had to raise the Roaming Assistant 2.4 RSSI threshold to -62.

OE
 

yamvmax

Occasional Visitor
Upload the nodes and remove them to reset them automatically.

Upload the router and Restore/Initialize from the webUI to reset it.

Configure the router from scratch and add the nodes.

AiMesh system reboot all.

If any issues, power cycle router, then nodes.

Test your WAN security.

Perform inbuilt QoS Internet Speed test to benchmark it.

Let it settle and use it.

I have two AC86U nodes 77' apart and had to raise the Roaming Assistant 2.4 RSSI threshold to -62.

OE
Well i did the main router 1st, then each node. I already had mesh setup. All seems to be ok, with no resetting. Time will tell. Thanks.
 

OzarkEdge

Part of the Furniture
ASUSWRT_2020

Thanks for confirming/testing that. I have again checked and yes, it seems a reboot of the main router is required for this option to work/take effect, So why is this there no display message to indicate this function (reboot) of the main router is required and or, reboot the main router automatically on selection of this option?
Rebooting automatically would kick everyone off the network; instead, reboots should be more controlled to protect the network and users, when possible, imo. Plus, multiple reboots would consume too much time when just one would do at the end of all changes.

Alerts to reboot the router would probably get noisy after awhile to the point where you would prefer to just assume it.

OE
 
Last edited:

OzarkEdge

Part of the Furniture
Well i did the main router 1st, then each node. I already had mesh setup. All seems to be ok, with no resetting. Time will tell. Thanks.
I only choose nodes first to not upset the router I'm using for admin.

OE
 

Scottp

Occasional Visitor
Ethernet backhaul speed is displayed wrong with rc2-7. Conncetion is with Cat6 cables and before rc2-7 I always had 'Excellent' connection, that's dropped to 'Normal'. I get full speed through the node though (400/40 Mbps) so it's not really a problem.

View attachment 27110
View attachment 27111
There is a command line tool to look at the ethernet ports and run diagnostics, cable-diag will show if any wires are broken/shorted, this is on RT-AX95Q Zenwifi XT8, your version may have different

[email protected]_XT8-6FB0:/bin# ethctl phy-map
eth0: Up <D4:5D:64:C7:6F:B0> <IntSw P1, Logical 01> PHY_ID <0x06180006:0x06:External 2.5G SERDES> Cfg: FIX.100M; Up 100M
PHY_ID <0x0388001f:0x1f:External Cascaded 10G EXT3> Cfg: ANG.2.5G; Up 100M
eth1: Down <D4:5D:64:C7:6F:B0> <ExtSw P0, Logical 08> PHY_ID <0x20000000:0x00: On-chip 1G GPHY> Cfg: ANG.1G; Down
eth2: Up <D4:5D:64:C7:6F:B0> <ExtSw P1, Logical 09> PHY_ID <0x20000001:0x01: On-chip 1G GPHY> Cfg: ANG.1G; Up 1G
eth3: Up <D4:5D:64:C7:6F:B0> <ExtSw P2, Logical 10> PHY_ID <0x20000002:0x02: On-chip 1G GPHY> Cfg: ANG.1G; Up 1G

[email protected]_XT8-6FB0:/bin# ethctl eth2 media-type
Auto-Negotiation: Enabled
PHY Capabilities: 1GFD|1GHD|100MFD|100MHD|10MFD|10MHD
Link is Up at Speed: 1G, Duplex: FD

[email protected]_XT8-6FB0:/bin# ethctl bcmsw cable-diag run
Interface eth1: PHY address 0:No cable connected to the port.
Interface eth2: PHY address 1:Connected Cable length: 21.32 meter
Interface eth3: PHY address 2:Connected Cable length: 18.86 meter
Interface eth0: PHY address 31:Cable Diagnosis Not Supported
 

OzarkEdge

Part of the Furniture
Anyone use the optimization tab in Aimesh? Does it just reassign clients to strongest signal?
I believe it reassigns wireless nodes/backhauls, not clients.

I assume it just repeats what should have already occurred, so it should be harmless. I almost tried it but then realized I only have one remote node!

OE
 
Last edited:

SloPoke

Occasional Visitor
If you have the nodes connected over a managed switch "Ethernet Backhaul Mode" in the System Settings, it will fail always . I had that experience already.
While I had set "Ethernet first" within the nodes it worked and and displayed Ethernet as Backhaul. But with this setup there was still a 5Gig Wifi Band reserved for Backhaul.
I connectect then the nodes directly at the Routers Ethernet Port and Ethernet Backhaul Mode works no without any problems. Try to find an unmanaged Switch if you can't connect the nodes directly. Maybe someone watching this thread may give a hint if some managed switches will work as well.
There are switches between the router and the nodes, but none of my switches are managed. I'm guessing the managed switch problem shows up with these later releases because I'm having no problems with rc2-4, which I'm sticking with for now.
 

bumpengrinder

Occasional Visitor
Anyone running RC2-3 ok on an AC66U B1 wireless node? The 66U B1 is only $80.

(ASUS needs less routers and more indoor/outdoor/mountable/PoE AiMesh nodes.)

OE

I have not gone back as far as RC2-3, but I have not been able to get my RT-AC66U B1 running as a node at all, on neither RC2-6 nor RC2-7 firmware for RT-AC68U. I appreciate that this is a late response to your post (but at least it shows I have now read the thread, further to my slap on the wrists earlier :) )

I have been trying this with a new GT-AC2900 (that I couldn't resist acquiring after I got sucked in by this thread!) as the AIMesh router which, in all my attempts, has been flashed to the same RC as the hopeful node. Any tips welcome please!


More info:
I have been following the AIMesh setup guide on the Asus website (here). This instructs not to configure the node device at all after its factory reset. However, I see that the RT-AC66U B1 (with wither RC2-6 or 7) offers a wizard after factory reset allowing it to be set as an AIMesh node, so I tried that too. When I reconnect my PC to the GT-AC2900 (when instructed by the wizard), the GT-AC2900 seems to register that I have just come form the RT-AC66U B1 (ref. screen1.jpg), but thereafter fails to connect (ref. screen2.jpg):

screen1.jpg:
screen1.jpg




screen2.jpg
screen2.png



I have tried all this many times time with devices 0.5-3m apart and also with and without wired backhaul enabled on the GT-AC2900.


Two questions I'd be grateful to know the answers to:
  1. I notice that, after factory resets, default IP of RT-AC66U = 192.168.1.1 and GT-AC2900 = 192.168.50.1. Should one of these be changed, e.g. to get them on the same subnet, or does it not matter?
  2. Is my factory reset method correct? For both devices I:
    1. start with device off
    2. hold WPS button
    3. switch device on
    4. When Boost Key light goes off (RT-AC2900) or power light goes flashes (for RT-AC66U B1), I release the WPS button.
In both cases I successfully revert to default SSIDs, but maybe there is more to it?


Thanks!
 

KingBravery

Regular Contributor
I have not gone back as far as RC2-3, but I have not been able to get my RT-AC66U B1 running as a node at all, on neither RC2-6 nor RC2-7 firmware for RT-AC68U. I appreciate that this is a late response to your post (but at least it shows I have now read the thread, further to my slap on the wrists earlier :) )

I have been trying this with a new GT-AC2900 (that I couldn't resist acquiring after I got sucked in by this thread!) as the AIMesh router which, in all my attempts, has been flashed to the same RC as the hopeful node. Any tips welcome please!


More info:
I have been following the AIMesh setup guide on the Asus website (here). This instructs not to configure the node device at all after its factory reset. However, I see that the RT-AC66U B1 (with wither RC2-6 or 7) offers a wizard after factory reset allowing it to be set as an AIMesh node, so I tried that too. When I reconnect my PC to the GT-AC2900 (when instructed by the wizard), the GT-AC2900 seems to register that I have just come form the RT-AC66U B1 (ref. screen1.jpg), but thereafter fails to connect (ref. screen2.jpg):

screen1.jpg:
View attachment 27126



screen2.jpg
View attachment 27125


I have tried all this many times time with devices 0.5-3m apart and also with and without wired backhaul enabled on the GT-AC2900.


Two questions I'd be grateful to know the answers to:
  1. I notice that, after factory resets, default IP of RT-AC66U = 192.168.1.1 and GT-AC2900 = 192.168.50.1. Should one of these be changed, e.g. to get them on the same subnet, or does it not matter?
  2. Is my factory reset method correct? For both devices I:
    1. start with device off
    2. hold WPS button
    3. switch device on
    4. When Boost Key light goes off (RT-AC2900) or power light goes flashes (for RT-AC66U B1), I release the WPS button.
In both cases I successfully revert to default SSIDs, but maybe there is more to it?


Thanks!
you can try with another method : hold reset button for 30 second
 

PretorianADB

New Around Here
If you have the nodes connected over a managed switch "Ethernet Backhaul Mode" in the System Settings, it will fail always . I had that experience already.
While I had set "Ethernet first" within the nodes it worked and and displayed Ethernet as Backhaul. But with this setup there was still a 5Gig Wifi Band reserved for Backhaul.
I connectect then the nodes directly at the Routers Ethernet Port and Ethernet Backhaul Mode works no without any problems. Try to find an unmanaged Switch if you can't connect the nodes directly. Maybe someone watching this thread may give a hint if some managed switches will work as well.
Hi @ginny,
There is a way to use Ethernet backhaul with unmanaged switch between router and node??? Because if don’t I can’t use AiMesh 2.0 in my home, Wi-Fi can’t reach from router to node...
 

JWoo

Regular Contributor
Used the 386 rc2-7 on an RT-AX58U. @ASUSWRT_2020 good job on the SDK integration, which was not easy. Would be interesting to know if updated drivers from Broadcom or something else was the fix to the SDK woes. Common code base should reduce your maintenance costs a lot. The 386 rc-7 is pretty darn stable on the RT-AX58U. I did notice there is no Speedtest and no DNS over TLS yet (it was talked about that DNS over TLS would be in the standard AsusWRT).
 

OzarkEdge

Part of the Furniture
I have not gone back as far as RC2-3, but I have not been able to get my RT-AC66U B1 running as a node at all, on neither RC2-6 nor RC2-7 firmware for RT-AC68U. I appreciate that this is a late response to your post (but at least it shows I have now read the thread, further to my slap on the wrists earlier :) )

I have been trying this with a new GT-AC2900 (that I couldn't resist acquiring after I got sucked in by this thread!) as the AIMesh router which, in all my attempts, has been flashed to the same RC as the hopeful node. Any tips welcome please!


More info:
I have been following the AIMesh setup guide on the Asus website (here). This instructs not to configure the node device at all after its factory reset. However, I see that the RT-AC66U B1 (with wither RC2-6 or 7) offers a wizard after factory reset allowing it to be set as an AIMesh node, so I tried that too. When I reconnect my PC to the GT-AC2900 (when instructed by the wizard), the GT-AC2900 seems to register that I have just come form the RT-AC66U B1 (ref. screen1.jpg), but thereafter fails to connect (ref. screen2.jpg):

screen1.jpg:
View attachment 27126



screen2.jpg
View attachment 27125


I have tried all this many times time with devices 0.5-3m apart and also with and without wired backhaul enabled on the GT-AC2900.


Two questions I'd be grateful to know the answers to:
  1. I notice that, after factory resets, default IP of RT-AC66U = 192.168.1.1 and GT-AC2900 = 192.168.50.1. Should one of these be changed, e.g. to get them on the same subnet, or does it not matter?
  2. Is my factory reset method correct? For both devices I:
    1. start with device off
    2. hold WPS button
    3. switch device on
    4. When Boost Key light goes off (RT-AC2900) or power light goes flashes (for RT-AC66U B1), I release the WPS button.
In both cases I successfully revert to default SSIDs, but maybe there is more to it?


Thanks!
1. Set the router static LAN IP to whatever you want. I still use 192.168.1.1.

2. Reset FAQ, Reset Button/webUI Restore, WPS Button Hard Reset.
I use the webUI Restore/Initialize reset on the router/root node and when it's convenient. Otherwise, I use the Reset Button... hold it until the power LED begins to flash. Removing a remote node automatically resets it... good enough. A node should be in a reset state (no configuration) before adding it to the AiMesh... and WPS must be enabled on the router.

OE
 

bumpengrinder

Occasional Visitor
1. Set the router static LAN IP to whatever you want. I still use 192.168.1.1.

2. Reset FAQ, Reset Button/webUI Restore, WPS Button Hard Reset.
I use the webUI Restore/Initialize reset on the router/root node and when it's convenient. Otherwise, I use the Reset Button... hold it until the power LED begins to flash. Removing a remote node automatically resets it... good enough. A node should be in a reset state (no configuration) before adding it to the AiMesh... and WPS must be enabled on the router.

OE
1 - I like 192.168.1.1 too. I will go back to it once I have things working (indeed, I think you said similar, way back!)

2 - Alas, I have tried all these reset ways.

Thanks for confirming all this as it means less uncertainty and many less permutations to try from now. Phew.


My way forward? @kisbalazs83 mentioned (here) no that he had not success with the RT-AC66U as node on RC2-5 but it was okay on previous version, so maybe RC2-4 worth a go...
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top