What's new

Beta Asuswrt-Merlin 3004.388.5-beta is now available

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Not open for further replies.
Yea I was actually quite surprised when @RMerlin took on limited support for the ROG theme's. It is quite amazing what he is able to do with what limited time he actually has.

I appreciate it being included. My only pet peeve with the ROG theme (stock included) is the constant pinging it does to check game servers. The way I have skynet set up it leaves a lot of blocked logs unnecessarily when I’d prefer that feature disabled. But either way..
I dirty flashed over the alpha yesterday and it's running just as flawless as the alpha.
USB mounted successfully, Wireguard and OVPN both connected automatically etc, 160mhz working flawlessly.

I really, really love this software.

I didn't want to let go of my (very, very) old Fritz!Box this year, but I had to upgrade when I got FTTP.

My 86U-Pro is a worthy successful and Merlin's software just makes everything work exactly the way I want it to.
Could just be a coincidence but I have been having frequent disconnects of my Alexa speakers since doing a dirty upgrade to this from latest stable AsusMerlin on my GT-AX6000. Will continue to keep an eye on things....
What is required for the QoS - WAN/LAN Bandwidth Monitor page to work?
I thought it used to work on 388.4 with these same settings but currently not getting anything on it.
I have the TrendMicro bwdpi stuff all disabled (revoked the privacy agreement).
I have the QoS set to Cake since that was the next best I could use.

I found the AX68U is MUCH more stable with the TrendMicro stuff all disabled.
Thank you very much for the beta FW. No issues so far on the GT-AX6000 after dirty update.
It needs the bwdpi engine.
At least for me, the bwdpi engine (with both ASUSWRT or Merlin - both 388.x) upon a reboot will work for a few minutes or randomly if there is anything set in either http://www.asusrouter.com/Advanced_QOSUserPrio_Content.asp or http://www.asusrouter.com/Advanced_QOSUserRules_Content.asp (exposed via ScMerlin), I have all the QoS settings set to off, Web and Appfilter and Timeschedueling as well. But because I use DDNS, privacy is eanbled.

I had an issue with 388.x where my bandwidth would be cut by 50% ramdomly, by chance I stumbled upon http://www.asusrouter.com/Advanced_QOSUserPrio_Content.asp add cleared everything out as soon as I did and applied, problem solved immediately without a reboot, bandwidth back to 100%. Recently upon a reboot (post flash to the beta), I discovered that the Bandwidth Monitor and Data Classification was active if only for a few minutes while the bwdpi engine was running, even with all the QoS settings set to off. Once it bwdpi shutt down, going into Data classification I get greeted with "Note: Statistics require Traditional QoS mode or the TrendMicro bwdpi engine to be enabled." which is correct.

Though I will add, upon reboot if you go to Bandwidth Monitor and its working, then to Data Classification it will work for a few seconds, three seconds default refresh. But while the engine is alive you can hop back Bnadwidth Monitor and if it is still updating, then to Data Classification to see statistics for another three seconds. Untill the engine finally falls asleeep, because QoS is off, then both stop working.

Digging around I found
Master@Router:/tmp/bwdpi# cat dcd.stat

***** data_colld statistics ************************************
start_time : 1701140094 (2023-11-27 21:54:54)

which correlates to the last reboot, note: post 388.5 beta. Upon reboot, after the firmware update form the second alpha I had all sorts of errors (have log) and firewall restarts, even got kicked out of the GUI at one point, but a few minute power off and reboot, solved them and its been 100% stable every since. I suspect it was something with the USB dirver/USB stick as I SSH'd in and found certain directories were no longer visible, but the power off reboot solved it.

I wouldn't call this bwdpi temporary activation a bug and if I did its closed source anyway (out of @RMerlin control) but its an interesting behavior that I've managed to stumble across and get around, under 388.x (both ASUSWRT native and Merlin/w scripts albeit with better visibility).

As of this morning it's running, still going strong
Last edited:
That behaviour has been there for years, it`s nothing new.
Surprise to me and good to know, but I still never figured out why it why the bwdpi engine would randomly start (388.x only, didn't do it under 386.x) and apply whatever was set under http://www.asusrouter.com/Advanced_QOSUserPrio_Content.asp cutting my bandwidth in half. I understand why, based on the settings that were there, why the bandwidth was cut in half, before clearing them out and applying. But QoS was off and the bwdpi engine started and used those settings and I didn't know why or when it would but I sure would see the effects in my SpdMerlin results, but again that was mystery was resolved solved when I cleared those settings out and applied.

But no matter, now I know what to look out for. It's water under the proverbial bridge, a lesson learned. At least now I know I wasn't going nuts or it an issue with the add on scripts incompatibilies with the 388 firmware as several other implied.

Photo says it all by itself.
No outstanding issues.

Terrific Beta.
Login error/Bug is now fixed for me here

All good
Christmas arrived here at Alpha stages 😂

  • Like
Reactions: Gar
Well, after 100 days on 388.4 Release, loaded Beta 1 on the GT-AX6000 router tonight...


Will put it through the regular paces and see how it settles overnight. But expecting no surprises. So far, so good.


Let's GO!

EDIT: So far all is good since the update last night. Everything checks out: VPN Director, DNS Director, IOT Devices all good, IPTV all good, Nest Cams/Devices all good, Google Home/TP-Link devices all good. Internet speed as expected.

Last edited:
Dirty Upgrade 2 days ago, all OK my end. :)
Dirty upgrade last night....So far so good!
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!