What's new

Release Asuswrt-Merlin 3004.388.5 is now available

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Not open for further replies.


Asuswrt-Merlin dev
Asuswrt-Merlin 3004.388.5 is now available for all supported Wifi 6 models. The focus of this release is component updates, bug fixes, and reworking the way the QOS Classification page works (solving various issues, and also making it works even when not using Adaptive QoS).

3004.388.5 (2-Dec-2023)
  - UPDATED: OpenSSL to 1.1.1w.
  - UPDATED: Curl to 8.4.0.
  - UPDATED: OpenVPN to 2.6.8.
  - CHANGED: Enable fast-io for OpenVPN clients and servers that
             use UDP, which will speed up performance on some models.
  - CHANGED: You can now directly enter an IPv6 address on the
             Network Tools page as a target.
  - CHANGED: Display tracked connections on the QoS/Classification
             page even if QoS isn't set to Adaptive QoS.
  - CHANGED: QOS/Classification page can now resolve local IPv6
  - CHANGED: Allow custom MTU for Wireguard clients (patch from
  - FIXED: CIDR-formatted addresses were rejected on the Network
           Filter page.  Implemented temporary workaround.
  - FIXED: Various issues with the QOS Classification page.
  - FIXED: Netfilter TEE kernel module is missing.
  - FIXED: OpenVPN client state getting cleared when Wireless
           was being restarted.
  - FIXED: Networkmap wasn't recognizing the GT-AX11000_PRO as
           having USB 3.0 ports

Downloads are here.
Changelog is here.
LOL! Of course. Let's GO!

EDIT: Filthy upgrade of all my gear from Beta 1 to Release. No issues to report off the bat, full reboot of the system done. Will let it settle over night and verify the rest.

EDIT2: 24hrs later and all is still well. All devices happy. VPN Director, DNS Director, IPTV, Google/Nest/TP-Link/IOT devices all good. Internet speed within expected range.

Many thanks to @RMerlin and team.
Last edited:
All done!,

Just an observation;
AX86 Nodes first, then Ax88 router.
Router applied settings then flashed the firmware, faster than the nodes just applying the firmware
Node flash took noticibly longer, felt 2x longer but didn't actually time it.

Everything came up clean, everything connected without issue (cameras, doorbell, Samsung TVs, Samsung Soundbars, DirecTv (Osprey's), thermostat's, several Alexa devices ,other assorted appliances, Volvo XC 60). All Add On Scripts up and running. Signature updated.

WiFi running great, SmartConnect and Guest 2.4Ghz and 5Ghz networks - Channels 4, 36/100 fixed.

OpenVPN and Wireguard running and connected and accepting connections as well.
Current condition: Pleasantly Bored
Thank you @RMerlin
Strange thing. After the reboot Guest Wifi 1 (2.4GHz) was disabled. I've enabled it and it's settled down fine again. I'll just keep an eye on it.
It did this once before on the beta but I just thought I may have disabled it myself.

Edit: Does it every reboot. If no-one else sees it in the next couple of days it's time for a factory reset 😒
Last edited:

Over the hump...
No issues so far, willl reboot system in its full and will update as well.
Dirty Upgrade from 3004.388.4 to 3004.388.5 successful.

So far so good for past 5-10 mins.
Done a whole system reboot.
Up just fine.
Then I rebooted manually router and first AiMesh Node, after 5-6 min router crashed and reboot.
Then I made another manual healthy reboot.

Weird but possible.
Hopefully will not come back on us again later
Missing more 3-4 devices that will come back I hope by themselves, most system is back up.
List is arranged correctly


44/160Mhz is up and running!


Hopefully will stay at this peacfull and smoothnes
Dirty upgrade from 3004.388.4 and no issues so far. I usually do the full reset, but in this case wife closed my change window :p

Thank you @RMerlin and everyone else spending their time and skills to make this happen!
Last edited:
I am still at 388.4, but when I try to retrieve the changelog for the new FW 388.5, the router returns a message "failed to find release notes". Is this the same problem that was found for FW 386.12?
oh well tried to upgrade GT AX1100pro got network cable unplugged even if i go back to the beta build will have to check another day for now borrowing a neighbors connection hope i find the problem
found the problem modem needed resetting all working perfectly as usual thanks
Last edited:
oh well tried to upgrade GT AX1100pro got network cable unplugged even if i go back to the beta build will have to check another day for now borrowing a neighbors connection hope i find the problem
This "full" release is almost entirely bit-for-bit the beta 1 build. All I found different were compiled-in timestamp and version character strings. If you're running the beta, save your memory chip erase cycles. If you had a problem with the beta, the "release" won't fix it.
Not open for further replies.

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!