Beta Asuswrt-Merlin 386.3 beta is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

octopus

Very Senior Member

mvadu

Regular Contributor
with DNS set to "Exclusive" does the router still resolve the local peers? With the older firmware clients using the tunnel with DNS set to "Exclusive" would not resolve the local peers even though they are using router as DNS server. Is it something that can be done (i.e. to allow for local peers to be resolved, but use the VPN provider DNS for everything else) in strict mode?
 

Laxarus

Regular Contributor
For VPN director, is it possible to use domain names instead of remote IP addresses for selective routing?
 

RMerlin

Asuswrt-Merlin dev

nzwayne

Regular Contributor

dave14305

Part of the Furniture

RMerlin

Asuswrt-Merlin dev
I hope you can consider adding that. It would be a most welcome addition since manually finding out ips 1-by-1 and adding them are not very practical.
Not possible. A routing table works with IP addresses, not text.
 

RMerlin

Asuswrt-Merlin dev
Perhaps a WAN rule should be ignored for DNS if it also has a Remote IP defined?
It used to be back in the vpnrouting.sh days. I don't remember if that was re-implemented with VPN Director, I would have to check.
 

octopus

Very Senior Member
.
It used to be back in the vpnrouting.sh days. I don't remember if that was re-implemented with VPN Director, I would have to check.
I saw you have fixed this issue. Thanks

Is it supposed to apply all WAN-rule to all vpn-clients chain when you not specific "Remote IP"?
 

RMerlin

Asuswrt-Merlin dev
Is it supposed to apply all WAN-rule to all vpn-clients chain when you not specific "Remote IP"?
WAN rules will always have priority over any other rules.
 

iTyPsIDg

Regular Contributor
I dirty flashed from 386.2_4 to 386.3 Beta 1 on Friday. I noticed that my Guest Network VPNs worked fine, but my main network wouldn't go through the VPN at all. I also noticed that I still have the old dropdown without VPN Director listed:
1626359264362.png
If I select Policy Rules (strict) I can't change the option back to anything else.

Today, I reflashed with Beta 2, then I did a full reset and reconfigured everything manually. I still don't see VPN director in the dropdown and my traffic still doesn't go through the VPN.

My Unbound configuration does go through the VPN, so according to DNS Leak Test, my DNS IP is correct but my LAN doesn't go through the VPN at all.
 

Attachments

  • 1626359237287.png
    1626359237287.png
    8.8 KB · Views: 37
Last edited:

octopus

Very Senior Member
I dirty flashed from 386.2_4 to 386.3 Beta 1 on Friday. I noticed that my Guest Network VPNs worked fine, but my main network wouldn't go through the VPN at all. I also noticed that I still have the old dropdown without VPN Director listed:
If I select Policy Rules (strict) I can't change the option back to anything else.

Today, I reflashed with Beta 2, then I did a full reset and reconfigured everything manually. I still don't see VPN director in the dropdown and my traffic still doesn't go through the VPN.

My Unbound configuration does go through the VPN, so according to DNS Leak Test, my DNS IP is correct but my LAN doesn't go through the VPN at all.
If you missed that part in changelog , here it is
Asuswrt-Merlin 386/NG Changelog
===============================

386.3 (xx-xxx-xxxx)
- NOTE: First time you boot into this version, you need to
either shift-reload the main index page, or clear
your browser cache.
 

iTyPsIDg

Regular Contributor
If you missed that part in changelog , here it is
Asuswrt-Merlin 386/NG Changelog
===============================

386.3 (xx-xxx-xxxx)
- NOTE: First time you boot into this version, you need to
either shift-reload the main index page, or clear
your browser cache.
I cleared the browser cache and tried shift-reload, but it still doesn't mention VPN Director in that dropdown.
 

dave14305

Part of the Furniture
I cleared the browser cache and tried shift-reload, but it still doesn't mention VPN Director in that dropdown.
Show us exactly what version number the router shows you.
 

iTyPsIDg

Regular Contributor

dave14305

Part of the Furniture
Is x3mrouting overwriting the default VPN Client page?
Test with:
Code:
umount /www/Advanced_OpenVPNClient_Content.asp
Refresh GUI page. Be happy. Put x3mrouting page back:
Code:
mount -o bind /jffs/addons/x3mRouting/Advanced_OpenVPNClient_Content.asp /www/Advanced_OpenVPNClient_Content.asp
 
Last edited:

iTyPsIDg

Regular Contributor
Is x3mrouting overwriting the default firmware page?
I'm not sure I fully understand. Do you mean this page?
1626362815955.png
 
Status
Not open for further replies.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top